mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 22:38:07 -05:00
gnu: gnome-todo: Fix compatibility with libical >= 3.0.
* gnu/packages/patches/gnome-todo-libical-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/gnome.scm (gnome-todo)[source](patches): Use it.
This commit is contained in:
parent
4c8413cd61
commit
5de561a796
3 changed files with 19 additions and 0 deletions
|
@ -724,6 +724,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/glog-gcc-5-demangling.patch \
|
||||
%D%/packages/patches/gmp-arm-asm-nothumb.patch \
|
||||
%D%/packages/patches/gmp-faulty-test.patch \
|
||||
%D%/packages/patches/gnome-todo-libical-compat.patch \
|
||||
%D%/packages/patches/gnome-tweak-tool-search-paths.patch \
|
||||
%D%/packages/patches/gnucash-price-quotes-perl.patch \
|
||||
%D%/packages/patches/gnutls-skip-trust-store-test.patch \
|
||||
|
|
|
@ -6207,6 +6207,7 @@ (define-public gnome-todo
|
|||
(uri (string-append "mirror://gnome/sources/" name "/"
|
||||
(version-major+minor version) "/"
|
||||
name "-" version ".tar.xz"))
|
||||
(patches (search-patches "gnome-todo-libical-compat.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"106xx1w18pxjmj5k0k2qjzi6b3c3kaz7b5kyrpknykibnr401ff9"))))
|
||||
|
|
17
gnu/packages/patches/gnome-todo-libical-compat.patch
Normal file
17
gnu/packages/patches/gnome-todo-libical-compat.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
Fix compatibility with libical 3.0.
|
||||
|
||||
Patch copied from Arch Linux:
|
||||
https://git.archlinux.org/svntogit/packages.git/tree/trunk/gnome-todo-3.26.2-libical-3.0.patch?h=packages/gnome-todo
|
||||
|
||||
diff -up gnome-todo-3.26.2/src/gtd-task.c.libical-3.0 gnome-todo-3.26.2/src/gtd-task.c
|
||||
--- gnome-todo-3.26.2/src/gtd-task.c.libical-3.0 2017-11-08 14:53:53.484294926 +0100
|
||||
+++ gnome-todo-3.26.2/src/gtd-task.c 2017-11-08 14:53:57.208294874 +0100
|
||||
@@ -778,7 +778,7 @@ gtd_task_set_complete (GtdTask *task,
|
||||
dt->minute = g_date_time_get_minute (now);
|
||||
dt->second = g_date_time_get_seconds (now);
|
||||
dt->is_date = 0;
|
||||
- dt->is_utc = 1;
|
||||
+ dt->zone = icaltimezone_get_utc_timezone ();
|
||||
|
||||
/* convert timezone
|
||||
*
|
Loading…
Reference in a new issue