mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: gnutls: Update to 3.2.20--this fixes CVE-2014-8564.
* gnu/packages/patches/gnutls-server-name-fix.patch: Remove. * gnu-system.am (dist_patch_DATA): Adjust accordingly. * gnu/packages/gnutls.scm (gnutls): Update to 3.2.20. Remove 'patches' field.
This commit is contained in:
parent
b173d0e443
commit
5dee9acf53
3 changed files with 2 additions and 21 deletions
|
@ -353,7 +353,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/glibc-ldd-x86_64.patch \
|
||||
gnu/packages/patches/gnunet-fix-scheduler.patch \
|
||||
gnu/packages/patches/gnunet-fix-tests.patch \
|
||||
gnu/packages/patches/gnutls-server-name-fix.patch \
|
||||
gnu/packages/patches/gobject-introspection-cc.patch \
|
||||
gnu/packages/patches/grub-gets-undeclared.patch \
|
||||
gnu/packages/patches/gstreamer-0.10-bison3.patch \
|
||||
|
|
|
@ -63,7 +63,7 @@ (define-public libtasn1
|
|||
(define-public gnutls
|
||||
(package
|
||||
(name "gnutls")
|
||||
(version "3.2.19")
|
||||
(version "3.2.20")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri
|
||||
|
@ -74,8 +74,7 @@ (define-public gnutls
|
|||
"/gnutls-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1krx33ab2ijwfz71f1ba8labxfsic7jhlhv6rvjsyw566jj9a3d2"))
|
||||
(patches (list (search-patch "gnutls-server-name-fix.patch")))))
|
||||
"165mpmm506jgpiffgf0s01rrn8c14qkan1saaa79dvf3g1z0arvr"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:configure-flags
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
Fix a typo introduced in the first series implementing
|
||||
'set-session-server-name!' whereby the trailing nul character would
|
||||
be passed on the wire, thereby breaking connections.
|
||||
|
||||
diff --git a/guile/src/core.c b/guile/src/core.c
|
||||
index 82fd573..2778205 100644
|
||||
--- a/guile/src/core.c
|
||||
+++ b/guile/src/core.c
|
||||
@@ -719,7 +719,7 @@ SCM_DEFINE (scm_gnutls_set_session_server_name_x, "set-session-server-name!",
|
||||
c_name = scm_to_locale_string (name);
|
||||
|
||||
err = gnutls_server_name_set (c_session, c_type, c_name,
|
||||
- strlen (c_name) + 1);
|
||||
+ strlen (c_name));
|
||||
free (c_name);
|
||||
|
||||
if (EXPECT_FALSE (err != GNUTLS_E_SUCCESS))
|
Loading…
Reference in a new issue