mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-25 12:09:15 -05:00
patchutils: Update to 0.3.4.
* gnu/packages/patchutils.scm (patchutils): Update to 0.3.4. [arguments]: Simplify 'patch-test-scripts' phase. * gnu/packages/patches/patchutils-xfail-gendiff-tests.patch: Rename to... * gnu/packages/patches/patchutils-test-perms.patch: ...this. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
7b05e957fa
commit
5f230fb279
4 changed files with 20 additions and 34 deletions
|
@ -1026,7 +1026,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/p7zip-remove-unused-code.patch \
|
%D%/packages/patches/p7zip-remove-unused-code.patch \
|
||||||
%D%/packages/patches/patchelf-page-size.patch \
|
%D%/packages/patches/patchelf-page-size.patch \
|
||||||
%D%/packages/patches/patchelf-rework-for-arm.patch \
|
%D%/packages/patches/patchelf-rework-for-arm.patch \
|
||||||
%D%/packages/patches/patchutils-xfail-gendiff-tests.patch \
|
%D%/packages/patches/patchutils-test-perms.patch \
|
||||||
%D%/packages/patches/patch-hurd-path-max.patch \
|
%D%/packages/patches/patch-hurd-path-max.patch \
|
||||||
%D%/packages/patches/perf-gcc-ice.patch \
|
%D%/packages/patches/perf-gcc-ice.patch \
|
||||||
%D%/packages/patches/perl-archive-tar-CVE-2018-12015.patch \
|
%D%/packages/patches/perl-archive-tar-CVE-2018-12015.patch \
|
||||||
|
|
14
gnu/packages/patches/patchutils-test-perms.patch
Normal file
14
gnu/packages/patches/patchutils-test-perms.patch
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
Need to mark one of the tests as PHONY to get permissions set correctly on
|
||||||
|
built scripts.
|
||||||
|
|
||||||
|
--- a/Makefile.in 2011-02-10 09:44:43.000000000 -0600
|
||||||
|
+++ b/Makefile.in 2018-11-29 21:52:05.000000000 -0600
|
||||||
|
@@ -1106,5 +1108,6 @@
|
||||||
|
rm -f $(DESTDIR)$(bindir)/"`echo lsdiff|sed '$(transform)'`"
|
||||||
|
rm -f $(DESTDIR)$(bindir)/"`echo grepdiff|sed '$(transform)'`"
|
||||||
|
|
||||||
|
+.PHONY: tests/newline1/run-test
|
||||||
|
tests/newline1/run-test: src/combinediff$(EXEEXT) src/flipdiff$(EXEEXT) \
|
||||||
|
src/lsdiff$(EXEEXT) src/grepdiff$(EXEEXT) \
|
||||||
|
scripts/splitdiff
|
||||||
|
|
|
@ -1,26 +0,0 @@
|
||||||
The gendiff1 and gendiff2 tests need the gendiff script that's distributed
|
|
||||||
with the rpm package management tool. Without that script, these tests are
|
|
||||||
expected to fail.
|
|
||||||
|
|
||||||
Need to mark one of the tests as PHONY to get permissions set correctly on
|
|
||||||
built scripts.
|
|
||||||
|
|
||||||
--- a/Makefile.in 2011-02-10 09:44:43.000000000 -0600
|
|
||||||
+++ b/Makefile.in 2014-03-06 17:27:55.610048953 -0600
|
|
||||||
@@ -378,6 +378,8 @@
|
|
||||||
# These ones don't work yet.
|
|
||||||
# Feel free to send me patches. :-)
|
|
||||||
XFAIL_TESTS = \
|
|
||||||
+ tests/gendiff1/run-test \
|
|
||||||
+ tests/gendiff2/run-test \
|
|
||||||
tests/delhunk5/run-test \
|
|
||||||
tests/delhunk6/run-test
|
|
||||||
|
|
||||||
@@ -1106,6 +1108,7 @@
|
|
||||||
rm -f $(DESTDIR)$(bindir)/"`echo lsdiff|sed '$(transform)'`"
|
|
||||||
rm -f $(DESTDIR)$(bindir)/"`echo grepdiff|sed '$(transform)'`"
|
|
||||||
|
|
||||||
+.PHONY: tests/combine1/run-test
|
|
||||||
tests/combine1/run-test: src/combinediff$(EXEEXT) src/flipdiff$(EXEEXT) \
|
|
||||||
src/lsdiff$(EXEEXT) src/grepdiff$(EXEEXT)
|
|
||||||
for script in $(bin_SCRIPTS); do \
|
|
|
@ -43,7 +43,7 @@ (define-module (gnu packages patchutils)
|
||||||
(define-public patchutils
|
(define-public patchutils
|
||||||
(package
|
(package
|
||||||
(name "patchutils")
|
(name "patchutils")
|
||||||
(version "0.3.3")
|
(version "0.3.4")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -51,8 +51,8 @@ (define-public patchutils
|
||||||
name "-" version ".tar.xz"))
|
name "-" version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0g5df00cj4nczrmr4k791l7la0sq2wnf8rn981fsrz1f3d2yix4i"))
|
"0xp8mcfyi5nmb5a2zi5ibmyshxkb1zv1dgmnyn413m7ahgdx8mfg"))
|
||||||
(patches (search-patches "patchutils-xfail-gendiff-tests.patch"))))
|
(patches (search-patches "patchutils-test-perms.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("perl" ,perl)))
|
(inputs `(("perl" ,perl)))
|
||||||
(arguments
|
(arguments
|
||||||
|
@ -61,10 +61,8 @@ (define-public patchutils
|
||||||
(modify-phases %standard-phases
|
(modify-phases %standard-phases
|
||||||
(add-before 'check 'patch-test-scripts
|
(add-before 'check 'patch-test-scripts
|
||||||
(lambda _
|
(lambda _
|
||||||
(let ((echo (which "echo")))
|
(substitute* (find-files "tests" "^run-test$")
|
||||||
(substitute*
|
(("/bin/echo") (which "echo")))
|
||||||
(find-files "tests" "^run-test$")
|
|
||||||
(("/bin/echo") echo)))
|
|
||||||
#t))
|
#t))
|
||||||
(add-after 'install 'wrap-program
|
(add-after 'install 'wrap-program
|
||||||
;; Point installed scripts to the utilities they need.
|
;; Point installed scripts to the utilities they need.
|
||||||
|
|
Loading…
Reference in a new issue