mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: emacs-lispy: Fix failing test under Emacs 28.
* gnu/packages/patches/emacs-lispy-fix-thread-last-test.patch: New file. * gnu/packages/emacs-xyz.scm (emacs-lispy): Use it here. * gnu/local.mk (dist_patch_DATA): Register it here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
This commit is contained in:
parent
de652e4e81
commit
5fc5cc2f73
3 changed files with 43 additions and 1 deletions
|
@ -1034,6 +1034,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
|
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
|
||||||
%D%/packages/patches/emacs-hyperbole-toggle-messaging.patch \
|
%D%/packages/patches/emacs-hyperbole-toggle-messaging.patch \
|
||||||
%D%/packages/patches/emacs-libgit-use-system-libgit2.patch \
|
%D%/packages/patches/emacs-libgit-use-system-libgit2.patch \
|
||||||
|
%D%/packages/patches/emacs-lispy-fix-thread-last-test.patch \
|
||||||
%D%/packages/patches/emacs-source-date-epoch.patch \
|
%D%/packages/patches/emacs-source-date-epoch.patch \
|
||||||
%D%/packages/patches/emacs-telega-path-placeholder.patch \
|
%D%/packages/patches/emacs-telega-path-placeholder.patch \
|
||||||
%D%/packages/patches/emacs-telega-test-env.patch \
|
%D%/packages/patches/emacs-telega-test-env.patch \
|
||||||
|
|
|
@ -21,7 +21,7 @@
|
||||||
;;; Copyright © 2017, 2018, 2019, 2020, 2022 Mathieu Othacehe <m.othacehe@gmail.com>
|
;;; Copyright © 2017, 2018, 2019, 2020, 2022 Mathieu Othacehe <m.othacehe@gmail.com>
|
||||||
;;; Copyright © 2017, 2018, 2019, 2020, 2021, 2022 Clément Lassieur <clement@lassieur.org>
|
;;; Copyright © 2017, 2018, 2019, 2020, 2021, 2022 Clément Lassieur <clement@lassieur.org>
|
||||||
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
|
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
|
||||||
;;; Copyright © 2017, 2018 Kyle Meyer <kyle@kyleam.com>
|
;;; Copyright © 2017, 2018, 2022 Kyle Meyer <kyle@kyleam.com>
|
||||||
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
|
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
|
||||||
;;; Copyright © 2017 George Clemmer <myglc2@gmail.com>
|
;;; Copyright © 2017 George Clemmer <myglc2@gmail.com>
|
||||||
;;; Copyright © 2017, 2018 Feng Shu <tumashu@163.com>
|
;;; Copyright © 2017, 2018 Feng Shu <tumashu@163.com>
|
||||||
|
@ -9726,6 +9726,8 @@ (define-public emacs-lispy
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1q3sgk8ffwajmh8l7c4p4fz36xw4fqds8yqblbi5kardaa8bs8cs"))
|
"1q3sgk8ffwajmh8l7c4p4fz36xw4fqds8yqblbi5kardaa8bs8cs"))
|
||||||
|
(patches
|
||||||
|
(search-patches "emacs-lispy-fix-thread-last-test.patch"))
|
||||||
(file-name (git-file-name name version))))
|
(file-name (git-file-name name version))))
|
||||||
(build-system emacs-build-system)
|
(build-system emacs-build-system)
|
||||||
(propagated-inputs
|
(propagated-inputs
|
||||||
|
|
39
gnu/packages/patches/emacs-lispy-fix-thread-last-test.patch
Normal file
39
gnu/packages/patches/emacs-lispy-fix-thread-last-test.patch
Normal file
|
@ -0,0 +1,39 @@
|
||||||
|
From dbe23aec174001c42f6edc7a594863a82a24bcfa Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kyle Meyer <kyle@kyleam.com>
|
||||||
|
Date: Sun, 15 May 2022 13:56:37 -0400
|
||||||
|
Subject: [PATCH] lispy-test.el (lispy-toggle-threaded-last): Update for Emacs
|
||||||
|
28
|
||||||
|
|
||||||
|
Starting with Emacs 28.1, thread-first uses `(declare (indent 0) ...)`
|
||||||
|
rather than `(declare (indent 1) ...)`.
|
||||||
|
---
|
||||||
|
|
||||||
|
Proposed upstream at <https://github.com/abo-abo/lispy/pull/632>.
|
||||||
|
|
||||||
|
lispy-test.el | 8 +++++++-
|
||||||
|
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/lispy-test.el b/lispy-test.el
|
||||||
|
index d946731..87d8c87 100644
|
||||||
|
--- a/lispy-test.el
|
||||||
|
+++ b/lispy-test.el
|
||||||
|
@@ -150,7 +150,13 @@ (ert-deftest lispy-toggle-threaded-last ()
|
||||||
|
"|(thread-last (a 1) (b 2) (c 3))"))
|
||||||
|
(should (string= (lispy-with "|(equal 1443070800.0\n (ts-unix\n (ts-parse-org-element\n (org-element-context))))"
|
||||||
|
(lispy-toggle-thread-last))
|
||||||
|
- "|(thread-last (org-element-context)\n (ts-parse-org-element)\n (ts-unix)\n (equal 1443070800.0))"))
|
||||||
|
+ (let ((indent (make-string
|
||||||
|
+ (if (version< emacs-version "28.1") 2 13)
|
||||||
|
+ ?\s)))
|
||||||
|
+ (concat "|(thread-last (org-element-context)\n"
|
||||||
|
+ indent "(ts-parse-org-element)\n"
|
||||||
|
+ indent "(ts-unix)\n"
|
||||||
|
+ indent "(equal 1443070800.0))"))))
|
||||||
|
(should (string= (lispy-with "|(thread-last (org-element-context)\n (ts-parse-org-element)\n (ts-unix)\n (equal 1443070800.0))"
|
||||||
|
(lispy-toggle-thread-last))
|
||||||
|
"|(equal 1443070800.0\n (ts-unix\n (ts-parse-org-element\n (org-element-context))))")))
|
||||||
|
|
||||||
|
base-commit: df1b7e614fb0f73646755343e8892ddda310f427
|
||||||
|
--
|
||||||
|
2.36.0
|
||||||
|
|
Loading…
Reference in a new issue