mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 13:58:15 -05:00
gnu: dav1d: Update to 0.5.1.
* gnu/packages/patches/dav1d-aarch64-symbol-alignment.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/video.scm (dav1d): Update to 0.5.1. [source](patches): Remove.
This commit is contained in:
parent
24adcbab0a
commit
5fd4d02666
3 changed files with 2 additions and 29 deletions
|
@ -769,7 +769,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/cursynth-wave-rand.patch \
|
||||
%D%/packages/patches/cvs-CVE-2017-12836.patch \
|
||||
%D%/packages/patches/darkice-workaround-fpermissive-error.patch \
|
||||
%D%/packages/patches/dav1d-aarch64-symbol-alignment.patch \
|
||||
%D%/packages/patches/dbus-helper-search-path.patch \
|
||||
%D%/packages/patches/dbus-c++-gcc-compat.patch \
|
||||
%D%/packages/patches/dbus-c++-threading-mutex.patch \
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
Ensure local debug symbols are aligned on AArch64.
|
||||
|
||||
Taken from upstream:
|
||||
https://code.videolan.org/videolan/dav1d/commit/a6228f47f0eebcdfebb1753a786e3e1654b51ea4
|
||||
|
||||
diff --git a/src/arm/64/ipred.S b/src/arm/64/ipred.S
|
||||
index 41b3c1c..9513212 100644
|
||||
--- a/src/arm/64/ipred.S
|
||||
+++ b/src/arm/64/ipred.S
|
||||
@@ -2244,6 +2244,7 @@ L(ipred_cfl_ac_420_tbl):
|
||||
.hword L(ipred_cfl_ac_420_tbl) - L(ipred_cfl_ac_420_w16)
|
||||
.hword L(ipred_cfl_ac_420_tbl) - L(ipred_cfl_ac_420_w8)
|
||||
.hword L(ipred_cfl_ac_420_tbl) - L(ipred_cfl_ac_420_w4)
|
||||
+ .hword 0
|
||||
|
||||
L(ipred_cfl_ac_420_w16_tbl):
|
||||
.hword L(ipred_cfl_ac_420_w16_tbl) - L(ipred_cfl_ac_420_w16_wpad0)
|
||||
@@ -2432,6 +2433,7 @@ L(ipred_cfl_ac_422_tbl):
|
||||
.hword L(ipred_cfl_ac_422_tbl) - L(ipred_cfl_ac_422_w16)
|
||||
.hword L(ipred_cfl_ac_422_tbl) - L(ipred_cfl_ac_422_w8)
|
||||
.hword L(ipred_cfl_ac_422_tbl) - L(ipred_cfl_ac_422_w4)
|
||||
+ .hword 0
|
||||
|
||||
L(ipred_cfl_ac_422_w16_tbl):
|
||||
.hword L(ipred_cfl_ac_422_w16_tbl) - L(ipred_cfl_ac_422_w16_wpad0)
|
|
@ -3544,16 +3544,15 @@ (define-public openshot
|
|||
(define-public dav1d
|
||||
(package
|
||||
(name "dav1d")
|
||||
(version "0.5.0")
|
||||
(version "0.5.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://downloads.videolan.org/pub/videolan"
|
||||
"/dav1d/" version "/dav1d-" version ".tar.xz"))
|
||||
(patches (search-patches "dav1d-aarch64-symbol-alignment.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1586k439fm8db9lsxxywm34iqibj5mw4xrppr4g2wqr0hjlhcbxn"))))
|
||||
"03cf6f9if45prq97qp7llzi1p71dyw9ymc87hc225iy89kmzjsdd"))))
|
||||
(build-system meson-build-system)
|
||||
(native-inputs `(("nasm" ,nasm)))
|
||||
(home-page "https://code.videolan.org/videolan/dav1d")
|
||||
|
|
Loading…
Reference in a new issue