mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-11 13:49:23 -05:00
gnu: gcc-4.7: Resurrect building with gcc-5.4.0.
* gnu/packages/patches/gcc-4-compile-with-gcc-5.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gcc.scm (gcc-4.7): Use it.
This commit is contained in:
parent
a67f094671
commit
625492ee1a
3 changed files with 68 additions and 0 deletions
|
@ -11,6 +11,7 @@
|
|||
# Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
|
||||
# Copyright © 2016, 2017 Alex Vong <alexvong1995@gmail.com>
|
||||
# Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
|
||||
# Copyright © 2016, 2017 Jan Nieuwenhuizen <janneke@gnu.org>
|
||||
# Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
# Copyright © 2017 Clément Lassieur <clement@lassieur.org>
|
||||
# Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
|
||||
|
@ -637,6 +638,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gcc-cross-environment-variables.patch \
|
||||
%D%/packages/patches/gcc-libvtv-runpath.patch \
|
||||
%D%/packages/patches/gcc-strmov-store-file-names.patch \
|
||||
%D%/packages/patches/gcc-4-compile-with-gcc-5.patch \
|
||||
%D%/packages/patches/gcc-4.6-gnu-inline.patch \
|
||||
%D%/packages/patches/gcc-4.9.3-mingw-gthr-default.patch \
|
||||
%D%/packages/patches/gcc-5.0-libvtv-runpath.patch \
|
||||
|
|
|
@ -136,6 +136,7 @@ (define-public gcc-4.7
|
|||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/gcc/gcc-"
|
||||
version "/gcc-" version ".tar.bz2"))
|
||||
(patches (search-patches "gcc-4-compile-with-gcc-5.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"10k2k71kxgay283ylbbhhs51cl55zn2q38vj5pk4k950qdnirrlj"))))
|
||||
|
|
65
gnu/packages/patches/gcc-4-compile-with-gcc-5.patch
Normal file
65
gnu/packages/patches/gcc-4-compile-with-gcc-5.patch
Normal file
|
@ -0,0 +1,65 @@
|
|||
Taken from https://gcc.gnu.org/cgi-bin/get-raw-msg?listname=gcc-patches&date=2016-01&msgid=1451802493-17406-1-git-send-email-vapier%40gentoo.org
|
||||
|
||||
Since the 3.0.3 release of gperf (made in May 2007), the generated func
|
||||
has had the gnu_inline attribute applied to it. The gcc source however
|
||||
has not been updated to include that which has lead to a mismatch.
|
||||
|
||||
In practice, this hasn't been an issue for two reasons:
|
||||
(1) Before gcc-5, the default standard was (gnu) C89, and gcc does not
|
||||
warn or throw an error in this mode.
|
||||
(2) Starting with gcc-4.8, the compiler driver used to build gcc was
|
||||
changed to C++, and g++ does not warn or throw an error in this mode.
|
||||
|
||||
This error does show up though when using gcc-5 to build gcc-4.7 or
|
||||
older as then the default is (gnu) C11 and the C compiler driver is
|
||||
used. That failure looks like:
|
||||
In file included from .../gcc-4.7.4/gcc/cp/except.c:990:0:
|
||||
cfns.gperf: At top level:
|
||||
cfns.gperf:101:1: error: 'gnu_inline' attribute present on 'libc_name_p'
|
||||
cfns.gperf:26:14: error: but not here
|
||||
|
||||
Whether the compiler should always emit this error regardless of the
|
||||
active standard or compiler driver is debatable (I think it should be
|
||||
consistent -- either always do it or never do it).
|
||||
|
||||
2015-08-06 Mike Frysinger <vapier@gentoo.org>
|
||||
|
||||
* cfns.gperf [__GNUC__, __GNUC_STDC_INLINE__]: Apply the
|
||||
__gnu_inline__ attribute.
|
||||
* cfns.h: Regenerated.
|
||||
---
|
||||
gcc/cp/cfns.gperf | 3 +++
|
||||
gcc/cp/cfns.h | 3 +++
|
||||
2 files changed, 6 insertions(+)
|
||||
|
||||
diff --git a/gcc/cp/cfns.gperf b/gcc/cp/cfns.gperf
|
||||
index 68acd3d..953262f 100644
|
||||
--- a/gcc/cp/cfns.gperf
|
||||
+++ b/gcc/cp/cfns.gperf
|
||||
@@ -22,6 +22,9 @@ __inline
|
||||
static unsigned int hash (const char *, unsigned int);
|
||||
#ifdef __GNUC__
|
||||
__inline
|
||||
+#ifdef __GNUC_STDC_INLINE__
|
||||
+__attribute__ ((__gnu_inline__))
|
||||
+#endif
|
||||
#endif
|
||||
const char * libc_name_p (const char *, unsigned int);
|
||||
%}
|
||||
diff --git a/gcc/cp/cfns.h b/gcc/cp/cfns.h
|
||||
index 1c6665d..6d00c0e 100644
|
||||
--- a/gcc/cp/cfns.h
|
||||
+++ b/gcc/cp/cfns.h
|
||||
@@ -53,6 +53,9 @@ __inline
|
||||
static unsigned int hash (const char *, unsigned int);
|
||||
#ifdef __GNUC__
|
||||
__inline
|
||||
+#ifdef __GNUC_STDC_INLINE__
|
||||
+__attribute__ ((__gnu_inline__))
|
||||
+#endif
|
||||
#endif
|
||||
const char * libc_name_p (const char *, unsigned int);
|
||||
/* maximum key range = 391, duplicates = 0 */
|
||||
--
|
||||
2.6.2
|
||||
|
Loading…
Reference in a new issue