mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 22:08:16 -05:00
gnu: docbook-xsl: Update to 1.79.2.
* gnu/packages/patches/docbook-xsl-support-old-url.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/patches/docbook-xsl-nonrecursive-string-subst.patch: Adjust URL and context. * gnu/packages/docbook.scm (docbook-xsl): Update to 1.79.2. [source](uri): Adjust for new download location.
This commit is contained in:
parent
4193095e18
commit
6268aa3184
4 changed files with 31 additions and 10 deletions
|
@ -869,6 +869,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/diffutils-gets-undeclared.patch \
|
||||
%D%/packages/patches/dkimproxy-add-ipv6-support.patch \
|
||||
%D%/packages/patches/docbook-xsl-nonrecursive-string-subst.patch \
|
||||
%D%/packages/patches/docbook-xsl-support-old-url.patch \
|
||||
%D%/packages/patches/doc++-include-directives.patch \
|
||||
%D%/packages/patches/doc++-segfault-fix.patch \
|
||||
%D%/packages/patches/docker-fix-tests.patch \
|
||||
|
|
|
@ -133,15 +133,17 @@ (define-public docbook-xml-4.1.2
|
|||
(define-public docbook-xsl
|
||||
(package
|
||||
(name "docbook-xsl")
|
||||
(version "1.79.1")
|
||||
(version "1.79.2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/docbook/docbook-xsl/"
|
||||
version "/docbook-xsl-" version ".tar.bz2"))
|
||||
(patches (search-patches "docbook-xsl-nonrecursive-string-subst.patch"))
|
||||
(uri (string-append "https://github.com/docbook/xslt10-stylesheets"
|
||||
"/releases/download/release%2F" version
|
||||
"/docbook-xsl-" version ".tar.bz2"))
|
||||
(patches (search-patches "docbook-xsl-support-old-url.patch"
|
||||
"docbook-xsl-nonrecursive-string-subst.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0s59lihif2fr7rznckxr2kfyrvkirv76r1zvidp9b5mj28p4apvj"))
|
||||
"0wd33z41kdsybyx3ay21w6bdlmgpd9kyn3mr5y520lsf8km28r9i"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
|
|
|
@ -5,7 +5,7 @@ https://bugzilla.samba.org/show_bug.cgi?id=9515
|
|||
https://bugzilla.gnome.org/show_bug.cgi?id=736077 (for xsltproc)
|
||||
|
||||
Patch copied from Debian:
|
||||
https://anonscm.debian.org/cgit/collab-maint/docbook-xsl.git/tree/debian/patches/765567_non-recursive_string_subst.patch
|
||||
https://salsa.debian.org/debian/docbook-xsl/-/blob/master/debian/patches/765567_non-recursive_string_subst.patch
|
||||
|
||||
Description: use EXSLT "replace" function when available
|
||||
A recursive implementation of string.subst is problematic,
|
||||
|
@ -15,11 +15,12 @@ Bug-Debian: https://bugs.debian.org/750593
|
|||
|
||||
--- a/lib/lib.xsl
|
||||
+++ b/lib/lib.xsl
|
||||
@@ -10,7 +10,10 @@
|
||||
@@ -6,7 +6,11 @@
|
||||
|
||||
This module implements DTD-independent functions
|
||||
|
||||
******************************************************************** -->
|
||||
-<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
|
||||
- ******************************************************************** --><xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
|
||||
+ ******************************************************************** -->
|
||||
+<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
|
||||
+ xmlns:str="http://exslt.org/strings"
|
||||
+ exclude-result-prefixes="str"
|
||||
|
@ -27,7 +28,7 @@ Bug-Debian: https://bugs.debian.org/750593
|
|||
|
||||
<xsl:template name="dot.count">
|
||||
<!-- Returns the number of "." characters in a string -->
|
||||
@@ -56,6 +59,9 @@
|
||||
@@ -52,6 +56,9 @@
|
||||
<xsl:param name="replacement"/>
|
||||
|
||||
<xsl:choose>
|
||||
|
|
17
gnu/packages/patches/docbook-xsl-support-old-url.patch
Normal file
17
gnu/packages/patches/docbook-xsl-support-old-url.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
Docbook 1.79.2 makes very few changes apart from changing the canonical URL
|
||||
to cdn.docbook.org. This patch adds support for the previous URL to avoid
|
||||
breaking packages that still use that.
|
||||
|
||||
Adapted from Debian:
|
||||
https://salsa.debian.org/debian/docbook-xsl/-/blob/master/debian/patches/0005-catalog.xml-Compatibility-with-1.79.1-or-earlier.patch
|
||||
|
||||
--- a/catalog.xml
|
||||
+++ b/catalog.xml
|
||||
@@ -5,4 +5,7 @@
|
||||
<rewriteSystem systemIdStartString="http://cdn.docbook.org/release/xsl/current/" rewritePrefix="./"/>
|
||||
<rewriteURI uriStartString="http://cdn.docbook.org/release/xsl/1.79.2/" rewritePrefix="./"/>
|
||||
<rewriteSystem systemIdStartString="http://cdn.docbook.org/release/xsl/1.79.2/" rewritePrefix="./"/>
|
||||
+ <!-- Also support old URI of v1.79.1 or earlier -->
|
||||
+ <rewriteURI uriStartString="http://docbook.sourceforge.net/release/xsl/current/" rewritePrefix="./"/>
|
||||
+ <rewriteSystem systemIdStartString="http://docbook.sourceforge.net/release/xsl/current/" rewritePrefix="./"/>
|
||||
</catalog>
|
Loading…
Reference in a new issue