gnu: onnx: Change source to 'git-fetch'.

* gnu/packages/machine-learning.scm (onnx)[source]: Change to
'git-fetch'.  Add "onnx-skip-model-downloads.patch".
[arguments]: Add 'make-test-directory-writable' phase.
* gnu/packages/patches/onnx-skip-model-downloads.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
Ludovic Courtès 2021-07-30 17:26:24 +02:00
parent fa2d94b5e3
commit 630c39d8df
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 38 additions and 10 deletions

View file

@ -1514,6 +1514,7 @@ dist_patch_DATA = \
%D%/packages/patches/oneko-remove-nonfree-characters.patch \
%D%/packages/patches/onnx-use-system-googletest.patch \
%D%/packages/patches/onnx-shared-libraries.patch \
%D%/packages/patches/onnx-skip-model-downloads.patch \
%D%/packages/patches/openbabel-fix-crash-on-nwchem-output.patch \
%D%/packages/patches/opencascade-oce-glibc-2.26.patch \
%D%/packages/patches/opencv-fix-build-of-grfmt_jpeg2000.cpp.patch \

View file

@ -585,16 +585,20 @@ (define-public onnx
(package
(name "onnx")
(version "1.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "onnx" version))
(patches (search-patches "onnx-use-system-googletest.patch"
"onnx-shared-libraries.patch"))
(sha256
(base32 "0yjv2axz2vc2ysniwislsp53fsb8f61y1warrr2ppn2d9ijml1d9"))
(modules '((guix build utils)))
(snippet '(delete-file-recursively "third_party"))))
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/onnx/onnx")
(commit (string-append "v" version))))
(sha256
(base32
"1xnii361f68x0masxgfc4ai7hh3wlxxk56aznwf4m4yr6wqx47ml"))
(file-name (git-file-name name version))
(patches (search-patches "onnx-use-system-googletest.patch"
"onnx-shared-libraries.patch"
"onnx-skip-model-downloads.patch"))
(modules '((guix build utils)))
(snippet '(delete-file-recursively "third_party"))))
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
@ -625,6 +629,13 @@ (define args
;; -j'.
(setenv "MAX_JOBS"
(number->string (parallel-job-count)))))
(add-before 'check 'make-test-directory-writable
(lambda _
;; Make things writable for tests.
(setenv "HOME" (getcwd))
(for-each make-file-writable
(find-files "onnx/examples" "."
#:directories? #t))))
(add-after 'install 'install-from-cmake
(lambda _
;; Run "make install" in the build tree 'setup.py'

View file

@ -0,0 +1,16 @@
A few tests require downloading models from URLs such as
<https://s3.amazonaws.com/download.onnx/models/opset_9/zfnet512.tar.gz>.
Skip those.
diff --git a/onnx/backend/test/runner/__init__.py b/onnx/backend/test/runner/__init__.py
index 049ed57b..f236f1bf 100644
--- a/onnx/backend/test/runner/__init__.py
+++ b/onnx/backend/test/runner/__init__.py
@@ -202,6 +202,7 @@ class Runner(object):
print('Start downloading model {} from {}'.format(
model_test.model_name,
model_test.url))
+ raise unittest.SkipTest('Skipping download')
urlretrieve(model_test.url, download_file.name)
print('Done')
with tarfile.open(download_file.name) as t: