mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-12 14:16:55 -05:00
gnu: libgda: Disable failing tests.
* gnu/packages/patches/libgda-disable-data-proxy-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/gnome.scm (libgda): Use it here. Change-Id: I0a86fb75b1ad048eca99408750b26f4b8ff448c1 Signed-off-by: Christopher Baines <mail@cbaines.net>
This commit is contained in:
parent
618cae45dc
commit
64785a7941
3 changed files with 61 additions and 0 deletions
|
@ -1582,6 +1582,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libcyaml-libyaml-compat.patch \
|
||||
%D%/packages/patches/libexpected-use-provided-catch2.patch \
|
||||
%D%/packages/patches/libgda-cve-2021-39359.patch \
|
||||
%D%/packages/patches/libgda-disable-data-proxy-test.patch \
|
||||
%D%/packages/patches/libgda-fix-build.patch \
|
||||
%D%/packages/patches/libgda-fix-missing-initialization.patch \
|
||||
%D%/packages/patches/libgda-skip-postgresql-tests.patch \
|
||||
|
|
|
@ -13505,6 +13505,7 @@ (define-public libgda
|
|||
(sha256
|
||||
(base32 "0w564z7krgjk19r39mi5qn4kggpdg9ggbyn9pb4aavb61r14npwr"))
|
||||
(patches (search-patches "libgda-cve-2021-39359.patch"
|
||||
"libgda-disable-data-proxy-test.patch"
|
||||
"libgda-fix-build.patch"
|
||||
"libgda-fix-missing-initialization.patch"
|
||||
"libgda-skip-postgresql-tests.patch"))))
|
||||
|
|
59
gnu/packages/patches/libgda-disable-data-proxy-test.patch
Normal file
59
gnu/packages/patches/libgda-disable-data-proxy-test.patch
Normal file
|
@ -0,0 +1,59 @@
|
|||
From c0bb1ed662011207ee13d5a20a70f9b55166aa13 Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Espinosa <esodan@gmail.com>
|
||||
Date: Wed, 1 Nov 2023 15:00:40 -0500
|
||||
Subject: [PATCH] GdaDataProxy: is no thread save so disabling its test
|
||||
|
||||
Has been difficutl to reproduce the problem when this test
|
||||
is running in Ci, so disabling until we can re-implement it
|
||||
is the better choice
|
||||
---
|
||||
libgda/gda-data-proxy.h | 4 +++-
|
||||
tests/data-models/meson.build | 17 +++++++++--------
|
||||
2 files changed, 12 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/libgda/gda-data-proxy.h b/libgda/gda-data-proxy.h
|
||||
index 4c31ab69b..ba0fa72b3 100644
|
||||
--- a/libgda/gda-data-proxy.h
|
||||
+++ b/libgda/gda-data-proxy.h
|
||||
@@ -77,7 +77,9 @@ struct _GdaDataProxyClass
|
||||
* @stability: Stable
|
||||
* @see_also: #GdaDataModel
|
||||
*
|
||||
- * This object stores modifications to be made to a #GdaDataModel object which is proxied until the modifications are actually
|
||||
+ * This object, is no thread save, so use with care.
|
||||
+ *
|
||||
+ * This object stores modifications to be made to a #GdaDataModel object which is proxied until the modifications are actually
|
||||
* written to the #GdaDataModel, it can also filter the proxied data model to show only a subset (a defined number of continuous
|
||||
* rows or by a filter to apply).
|
||||
*
|
||||
diff --git a/tests/data-models/meson.build b/tests/data-models/meson.build
|
||||
index a8c6a29d8..e0ec8692a 100644
|
||||
--- a/tests/data-models/meson.build
|
||||
+++ b/tests/data-models/meson.build
|
||||
@@ -61,14 +61,15 @@ tchkdp = executable('check_data_proxy',
|
||||
],
|
||||
install: false
|
||||
)
|
||||
-test('DataProxy', tchkdp,
|
||||
- timeout: 100,
|
||||
- workdir: meson.current_build_dir(),
|
||||
- env: [
|
||||
- 'GDA_TOP_SRC_DIR='+gda_top_src,
|
||||
- 'GDA_TOP_BUILD_DIR='+gda_top_build
|
||||
- ]
|
||||
- )
|
||||
+# This test is no thread save so disabling
|
||||
+#test('DataProxy', tchkdp,
|
||||
+# timeout: 100,
|
||||
+# workdir: meson.current_build_dir(),
|
||||
+# env: [
|
||||
+# 'GDA_TOP_SRC_DIR='+gda_top_src,
|
||||
+# 'GDA_TOP_BUILD_DIR='+gda_top_build
|
||||
+# ]
|
||||
+# )
|
||||
|
||||
tchkmc = executable('check_model_copy',
|
||||
['check_model_copy.c'] + common_sources,
|
||||
--
|
||||
GitLab
|
||||
|
Loading…
Reference in a new issue