mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 13:58:15 -05:00
gnu: Add xdg-desktop-portal-next.
This is based on Dan's "xdg-desktop-portal: Update to 1.18.4." commit, now reverted. * gnu/packages/freedesktop.scm (xdg-desktop-portal-next): New variable. * gnu/packages/patches/xdg-desktop-portal-disable-portal-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I7360d915bb0450f6772232c126fd0d4a4fec8997
This commit is contained in:
parent
ce6f571fbe
commit
64e1ae00e7
3 changed files with 91 additions and 1 deletions
|
@ -2308,6 +2308,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/wordnet-CVE-2008-3908-pt2.patch \
|
%D%/packages/patches/wordnet-CVE-2008-3908-pt2.patch \
|
||||||
%D%/packages/patches/wpa-supplicant-dbus-group-policy.patch \
|
%D%/packages/patches/wpa-supplicant-dbus-group-policy.patch \
|
||||||
%D%/packages/patches/x265-arm-flags.patch \
|
%D%/packages/patches/x265-arm-flags.patch \
|
||||||
|
%D%/packages/patches/xdg-desktop-portal-disable-portal-tests.patch\
|
||||||
%D%/packages/patches/xdg-desktop-portal-wlr-harcoded-length.patch\
|
%D%/packages/patches/xdg-desktop-portal-wlr-harcoded-length.patch\
|
||||||
%D%/packages/patches/xen-docs-use-predictable-ordering.patch \
|
%D%/packages/patches/xen-docs-use-predictable-ordering.patch \
|
||||||
%D%/packages/patches/xen-remove-config.gz-timestamp.patch \
|
%D%/packages/patches/xen-remove-config.gz-timestamp.patch \
|
||||||
|
|
|
@ -27,7 +27,7 @@
|
||||||
;;; Copyright © 2021 Robby Zambito <contact@robbyzambito.me>
|
;;; Copyright © 2021 Robby Zambito <contact@robbyzambito.me>
|
||||||
;;; Copyright © 2021, 2022, 2023 Maxime Devos <maximedevos@telenet.be>
|
;;; Copyright © 2021, 2022, 2023 Maxime Devos <maximedevos@telenet.be>
|
||||||
;;; Copyright © 2021, 2022 John Kehayias <john.kehayias@protonmail.com>
|
;;; Copyright © 2021, 2022 John Kehayias <john.kehayias@protonmail.com>
|
||||||
;;; Copyright © 2021, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
;;; Copyright © 2021-2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
||||||
;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
|
;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
|
||||||
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
|
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
|
||||||
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
|
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
|
||||||
|
@ -39,6 +39,7 @@
|
||||||
;;; Copyright © 2024 aurtzy <aurtzy@gmail.com>
|
;;; Copyright © 2024 aurtzy <aurtzy@gmail.com>
|
||||||
;;; Copyright © 2024 Dariqq <dariqq@posteo.net>
|
;;; Copyright © 2024 Dariqq <dariqq@posteo.net>
|
||||||
;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
|
;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
|
||||||
|
;;; Copyright © 2024 dan <i@dan.games>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -136,6 +137,7 @@ (define-module (gnu packages freedesktop)
|
||||||
#:use-module (gnu packages tls)
|
#:use-module (gnu packages tls)
|
||||||
#:use-module (gnu packages valgrind)
|
#:use-module (gnu packages valgrind)
|
||||||
#:use-module (gnu packages video)
|
#:use-module (gnu packages video)
|
||||||
|
#:use-module (gnu packages virtualization)
|
||||||
#:use-module (gnu packages w3m)
|
#:use-module (gnu packages w3m)
|
||||||
#:use-module (gnu packages web)
|
#:use-module (gnu packages web)
|
||||||
#:use-module (gnu packages xdisorg)
|
#:use-module (gnu packages xdisorg)
|
||||||
|
@ -3071,6 +3073,37 @@ (define-public xdg-desktop-portal
|
||||||
and others.")
|
and others.")
|
||||||
(license license:lgpl2.1+)))
|
(license license:lgpl2.1+)))
|
||||||
|
|
||||||
|
(define-public xdg-desktop-portal-next
|
||||||
|
(package
|
||||||
|
(inherit xdg-desktop-portal)
|
||||||
|
(version "1.18.4")
|
||||||
|
(source
|
||||||
|
(origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (string-append
|
||||||
|
"https://github.com/flatpak/xdg-desktop-portal/releases/download/"
|
||||||
|
version "/xdg-desktop-portal-" version ".tar.xz"))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"0r8y8qmzcfj7b7brqcxr9lg8pavfds815ffvj0kqc378fhgaln5q"))
|
||||||
|
;; Disable portal tests since they try to use fuse.
|
||||||
|
(patches (search-patches "xdg-desktop-portal-disable-portal-tests.patch"))))
|
||||||
|
(build-system meson-build-system)
|
||||||
|
(arguments
|
||||||
|
(substitute-keyword-arguments (package-arguments xdg-desktop-portal)
|
||||||
|
((#:configure-flags _ ''())
|
||||||
|
#~(list "-Dsystemd=disabled"))))
|
||||||
|
(native-inputs
|
||||||
|
(list pkg-config
|
||||||
|
`(,glib "bin")
|
||||||
|
gettext-minimal
|
||||||
|
python
|
||||||
|
python-dbusmock
|
||||||
|
python-pytest
|
||||||
|
python-pytest-xdist))
|
||||||
|
(inputs (modify-inputs (package-inputs xdg-desktop-portal)
|
||||||
|
(prepend bubblewrap)))))
|
||||||
|
|
||||||
(define-public xdg-desktop-portal-gtk
|
(define-public xdg-desktop-portal-gtk
|
||||||
(package
|
(package
|
||||||
(name "xdg-desktop-portal-gtk")
|
(name "xdg-desktop-portal-gtk")
|
||||||
|
|
|
@ -0,0 +1,56 @@
|
||||||
|
From b7750fa99c31c5f28ac2053fa154bef4038b5cc0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: dan <i@dan.games>
|
||||||
|
Date: Tue, 2 Jul 2024 19:37:38 +0800
|
||||||
|
Subject: [PATCH] tests: remove portal tests.
|
||||||
|
|
||||||
|
---
|
||||||
|
tests/meson.build | 24 ------------------------
|
||||||
|
1 file changed, 24 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/tests/meson.build b/tests/meson.build
|
||||||
|
index a2dafee..bcd87be 100644
|
||||||
|
--- a/tests/meson.build
|
||||||
|
+++ b/tests/meson.build
|
||||||
|
@@ -181,18 +181,6 @@ portal_tests = [
|
||||||
|
|
||||||
|
test_env = env_tests
|
||||||
|
test_env.set('XDG_CURRENT_DESKTOP', 'test')
|
||||||
|
-foreach p : portal_tests
|
||||||
|
- test(
|
||||||
|
- 'test-portals-@0@'.format(p),
|
||||||
|
- test_portals,
|
||||||
|
- args: ['--verbose', '--keep-going', '--tap', '-p', '/portal/@0@'.format(p)],
|
||||||
|
- depends: [test_backends, test_portals],
|
||||||
|
- env: test_env,
|
||||||
|
- is_parallel: false,
|
||||||
|
- protocol: test_protocol,
|
||||||
|
- suite: 'portals',
|
||||||
|
- )
|
||||||
|
-endforeach
|
||||||
|
|
||||||
|
# Split the portal tests into one test per portal, this makes debugging a lot
|
||||||
|
# easier.
|
||||||
|
@@ -204,18 +192,6 @@ portal_limited = [
|
||||||
|
|
||||||
|
limited_env = env_tests
|
||||||
|
limited_env.set('XDG_CURRENT_DESKTOP', 'limited')
|
||||||
|
-foreach p : portal_limited
|
||||||
|
- test(
|
||||||
|
- 'limited-portals-@0@'.format(p),
|
||||||
|
- limited_portals,
|
||||||
|
- args: ['--verbose', '--keep-going', '--tap', '-p', '/limited/@0@'.format(p)],
|
||||||
|
- depends: [test_backends, limited_portals],
|
||||||
|
- env: limited_env,
|
||||||
|
- is_parallel: false,
|
||||||
|
- protocol: test_protocol,
|
||||||
|
- suite: 'portals',
|
||||||
|
- )
|
||||||
|
-endforeach
|
||||||
|
|
||||||
|
if enable_installed_tests
|
||||||
|
install_data(
|
||||||
|
|
||||||
|
base-commit: 11c8a96b147aeae70e3f770313f93b367d53fedd
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
Loading…
Reference in a new issue