mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-26 04:29:25 -05:00
gnu: Remove unused patch.
This is a follow-up to commit fce910af55
.
* gnu/packages/patches/postgresql-riscv-spinlocks.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
6c7fcc71d1
commit
66e3adcad8
2 changed files with 0 additions and 42 deletions
|
@ -1646,7 +1646,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/portaudio-audacity-compat.patch \
|
||||
%D%/packages/patches/portmidi-modular-build.patch \
|
||||
%D%/packages/patches/postgresql-disable-resolve_symlinks.patch \
|
||||
%D%/packages/patches/postgresql-riscv-spinlocks.patch \
|
||||
%D%/packages/patches/procmail-ambiguous-getline-debian.patch \
|
||||
%D%/packages/patches/procmail-CVE-2014-3618.patch \
|
||||
%D%/packages/patches/procmail-CVE-2017-16844.patch \
|
||||
|
|
|
@ -1,41 +0,0 @@
|
|||
https://www.postgresql.org/message-id/dea97b6d-f55f-1f6d-9109-504aa7dfa421@gentoo.org
|
||||
|
||||
The attached patch adds native spinlock support to PostgreSQL on RISC-V
|
||||
systems. As suspected by Richard W.M. Jones of Red Hat back in 2016, the
|
||||
__sync_lock_test_and_set() approach applied on arm and arm64 works here
|
||||
as well.
|
||||
|
||||
|
||||
Tested against PostgreSQL 13.3 on a physical rv64gc system (BeagleV
|
||||
Starlight beta board) - builds and installs fine, all tests pass. From
|
||||
what I can see in gcc documentation this should in theory work on rv32
|
||||
(and possibly rv128) as well, therefore the patch as it stands covers
|
||||
all RISC-V systems (i.e. doesn't check the value of __risc_xlen) - but I
|
||||
haven't confirmed this experimentally.
|
||||
|
||||
--- a/src/include/storage/s_lock.h
|
||||
+++ b/src/include/storage/s_lock.h
|
||||
@@ -315,12 +315,12 @@
|
||||
#endif /* __ia64__ || __ia64 */
|
||||
|
||||
/*
|
||||
- * On ARM and ARM64, we use __sync_lock_test_and_set(int *, int) if available.
|
||||
+ * On ARM, ARM64 and RISC-V, we use __sync_lock_test_and_set(int *, int) if available.
|
||||
*
|
||||
* We use the int-width variant of the builtin because it works on more chips
|
||||
* than other widths.
|
||||
*/
|
||||
-#if defined(__arm__) || defined(__arm) || defined(__aarch64__) || defined(__aarch64)
|
||||
+#if defined(__arm__) || defined(__arm) || defined(__aarch64__) || defined(__aarch64) || defined(__riscv)
|
||||
#ifdef HAVE_GCC__SYNC_INT32_TAS
|
||||
#define HAS_TEST_AND_SET
|
||||
|
||||
@@ -337,7 +337,7 @@
|
||||
#define S_UNLOCK(lock) __sync_lock_release(lock)
|
||||
|
||||
#endif /* HAVE_GCC__SYNC_INT32_TAS */
|
||||
-#endif /* __arm__ || __arm || __aarch64__ || __aarch64 */
|
||||
+#endif /* __arm__ || __arm || __aarch64__ || __aarch64 || __riscv */
|
||||
|
||||
|
||||
/* S/390 and S/390x Linux (32- and 64-bit zSeries) */
|
Loading…
Reference in a new issue