mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: libjami: Fix build.
* gnu/packages/jami.scm (webrtc-audio-processing/jami): New variable. (libjami)[inputs]: Use it. * gnu/packages/patches/webrtc-audio-processing-big-endian.patch: New file. Change-Id: I51a25acd1b8d50e91869aef8ea1fadc862afe215
This commit is contained in:
parent
6661169697
commit
67a2073d27
2 changed files with 153 additions and 1 deletions
|
@ -81,6 +81,65 @@ (define-module (gnu packages jami)
|
|||
(define %jami-nightly-version "20240524.0")
|
||||
(define %jami-daemon-commit "fd2f2815448ce4072dcbc3995950788573d63f3b")
|
||||
|
||||
(define webrtc-audio-processing/jami
|
||||
;; libjami still requires an 0.x version of this package. Remove it when
|
||||
;; libjami moves on, and don't forget to delete the patch.
|
||||
(package
|
||||
(name "webrtc-audio-processing")
|
||||
(version "0.3.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri
|
||||
(string-append "http://freedesktop.org/software/pulseaudio/"
|
||||
"webrtc-audio-processing/webrtc-audio-processing-"
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32 "1gsx7k77blfy171b6g3m0k0s0072v6jcawhmx1kjs9w5zlwdkzd0"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
(if (or (target-riscv64?)
|
||||
(target-powerpc?))
|
||||
(list
|
||||
#:phases
|
||||
#~(modify-phases %standard-phases
|
||||
(add-after 'unpack 'patch-source
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
(let ((patch-file
|
||||
#$(local-file
|
||||
(search-patch
|
||||
"webrtc-audio-processing-big-endian.patch"))))
|
||||
(invoke "patch" "--force" "-p1" "-i" patch-file)
|
||||
(substitute* "webrtc/typedefs.h"
|
||||
(("defined\\(__aarch64__\\)" all)
|
||||
(string-append
|
||||
;; powerpc-linux
|
||||
"(defined(__PPC__) && __SIZEOF_SIZE_T__ == 4)\n"
|
||||
"#define WEBRTC_ARCH_32_BITS\n"
|
||||
"#define WEBRTC_ARCH_BIG_ENDIAN\n"
|
||||
;; powerpc64-linux
|
||||
"#elif (defined(__PPC64__) && defined(_BIG_ENDIAN))\n"
|
||||
"#define WEBRTC_ARCH_64_BITS\n"
|
||||
"#define WEBRTC_ARCH_BIG_ENDIAN\n"
|
||||
;; aarch64-linux
|
||||
"#elif " all
|
||||
;; riscv64-linux
|
||||
" || (defined(__riscv) && __riscv_xlen == 64)"
|
||||
;; powerpc64le-linux
|
||||
" || (defined(__PPC64__) && defined(_LITTLE_ENDIAN))"))))))))
|
||||
'()))
|
||||
(native-inputs
|
||||
(if (or (target-riscv64?)
|
||||
(target-powerpc?))
|
||||
(list
|
||||
(local-file (search-patch "webrtc-audio-processing-big-endian.patch"))
|
||||
patch)
|
||||
'()))
|
||||
(home-page (package-home-page webrtc-audio-processing))
|
||||
(synopsis (package-synopsis webrtc-audio-processing))
|
||||
(description (package-description webrtc-audio-processing))
|
||||
(license (package-license webrtc-audio-processing))))
|
||||
|
||||
(define-public libjami
|
||||
(package
|
||||
(name "libjami")
|
||||
|
@ -158,7 +217,7 @@ (define-public libjami
|
|||
sdbus-c++
|
||||
speex
|
||||
speexdsp
|
||||
webrtc-audio-processing
|
||||
webrtc-audio-processing/jami
|
||||
yaml-cpp))
|
||||
(native-inputs
|
||||
(list autoconf
|
||||
|
|
|
@ -0,0 +1,93 @@
|
|||
https://bugs.freedesktop.org/show_bug.cgi?id=95738
|
||||
https://bugs.freedesktop.org/attachment.cgi?id=124025
|
||||
|
||||
diff -up webrtc-audio-processing-0.2/webrtc/common_audio/wav_file.cc.than webrtc-audio-processing-0.2/webrtc/common_audio/wav_file.cc
|
||||
--- webrtc-audio-processing-0.2/webrtc/common_audio/wav_file.cc.than 2016-05-24 08:28:45.749940095 -0400
|
||||
+++ webrtc-audio-processing-0.2/webrtc/common_audio/wav_file.cc 2016-05-24 08:50:30.361020010 -0400
|
||||
@@ -64,9 +64,6 @@ WavReader::~WavReader() {
|
||||
}
|
||||
|
||||
size_t WavReader::ReadSamples(size_t num_samples, int16_t* samples) {
|
||||
-#ifndef WEBRTC_ARCH_LITTLE_ENDIAN
|
||||
-#error "Need to convert samples to big-endian when reading from WAV file"
|
||||
-#endif
|
||||
// There could be metadata after the audio; ensure we don't read it.
|
||||
num_samples = std::min(rtc::checked_cast<uint32_t>(num_samples),
|
||||
num_samples_remaining_);
|
||||
@@ -76,6 +73,12 @@ size_t WavReader::ReadSamples(size_t num
|
||||
RTC_CHECK(read == num_samples || feof(file_handle_));
|
||||
RTC_CHECK_LE(read, num_samples_remaining_);
|
||||
num_samples_remaining_ -= rtc::checked_cast<uint32_t>(read);
|
||||
+#ifndef WEBRTC_ARCH_LITTLE_ENDIAN
|
||||
+ //convert to big-endian
|
||||
+ for(size_t idx = 0; idx < num_samples; idx++) {
|
||||
+ samples[idx] = (samples[idx]<<8) | (samples[idx]>>8);
|
||||
+ }
|
||||
+#endif
|
||||
return read;
|
||||
}
|
||||
|
||||
@@ -120,10 +123,17 @@ WavWriter::~WavWriter() {
|
||||
|
||||
void WavWriter::WriteSamples(const int16_t* samples, size_t num_samples) {
|
||||
#ifndef WEBRTC_ARCH_LITTLE_ENDIAN
|
||||
-#error "Need to convert samples to little-endian when writing to WAV file"
|
||||
-#endif
|
||||
+ int16_t * le_samples = new int16_t[num_samples];
|
||||
+ for(size_t idx = 0; idx < num_samples; idx++) {
|
||||
+ le_samples[idx] = (samples[idx]<<8) | (samples[idx]>>8);
|
||||
+ }
|
||||
+ const size_t written =
|
||||
+ fwrite(le_samples, sizeof(*le_samples), num_samples, file_handle_);
|
||||
+ delete []le_samples;
|
||||
+#else
|
||||
const size_t written =
|
||||
fwrite(samples, sizeof(*samples), num_samples, file_handle_);
|
||||
+#endif
|
||||
RTC_CHECK_EQ(num_samples, written);
|
||||
num_samples_ += static_cast<uint32_t>(written);
|
||||
RTC_CHECK(written <= std::numeric_limits<uint32_t>::max() ||
|
||||
diff -up webrtc-audio-processing-0.2/webrtc/common_audio/wav_header.cc.than webrtc-audio-processing-0.2/webrtc/common_audio/wav_header.cc
|
||||
--- webrtc-audio-processing-0.2/webrtc/common_audio/wav_header.cc.than 2016-05-24 08:50:52.591379263 -0400
|
||||
+++ webrtc-audio-processing-0.2/webrtc/common_audio/wav_header.cc 2016-05-24 08:52:08.552606848 -0400
|
||||
@@ -129,7 +129,39 @@ static inline std::string ReadFourCC(uin
|
||||
return std::string(reinterpret_cast<char*>(&x), 4);
|
||||
}
|
||||
#else
|
||||
-#error "Write be-to-le conversion functions"
|
||||
+static inline void WriteLE16(uint16_t* f, uint16_t x) {
|
||||
+ *f = ((x << 8) & 0xff00) | ( ( x >> 8) & 0x00ff);
|
||||
+}
|
||||
+
|
||||
+static inline void WriteLE32(uint32_t* f, uint32_t x) {
|
||||
+ *f = ( (x & 0x000000ff) << 24 )
|
||||
+ | ((x & 0x0000ff00) << 8)
|
||||
+ | ((x & 0x00ff0000) >> 8)
|
||||
+ | ((x & 0xff000000) >> 24 );
|
||||
+}
|
||||
+
|
||||
+static inline void WriteFourCC(uint32_t* f, char a, char b, char c, char d) {
|
||||
+ *f = (static_cast<uint32_t>(a) << 24 )
|
||||
+ | (static_cast<uint32_t>(b) << 16)
|
||||
+ | (static_cast<uint32_t>(c) << 8)
|
||||
+ | (static_cast<uint32_t>(d) );
|
||||
+}
|
||||
+
|
||||
+static inline uint16_t ReadLE16(uint16_t x) {
|
||||
+ return (( x & 0x00ff) << 8 )| ((x & 0xff00)>>8);
|
||||
+}
|
||||
+
|
||||
+static inline uint32_t ReadLE32(uint32_t x) {
|
||||
+ return ( (x & 0x000000ff) << 24 )
|
||||
+ | ( (x & 0x0000ff00) << 8 )
|
||||
+ | ( (x & 0x00ff0000) >> 8)
|
||||
+ | ( (x & 0xff000000) >> 24 );
|
||||
+}
|
||||
+
|
||||
+static inline std::string ReadFourCC(uint32_t x) {
|
||||
+ x = ReadLE32(x);
|
||||
+ return std::string(reinterpret_cast<char*>(&x), 4);
|
||||
+}
|
||||
#endif
|
||||
|
||||
static inline uint32_t RiffChunkSize(uint32_t bytes_in_payload) {
|
Loading…
Reference in a new issue