mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 05:18:07 -05:00
gnu: Add libvdpau-va-gl.
* gnu/packages/video.scm (libvdpau-va-gl): New variable. * gnu/packages/patches/libvdpau-va-gl-unbundle.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
This commit is contained in:
parent
02345c963e
commit
67df7164e0
3 changed files with 71 additions and 0 deletions
|
@ -836,6 +836,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libunistring-gnulib-multi-core.patch \
|
||||
%D%/packages/patches/libusb-0.1-disable-tests.patch \
|
||||
%D%/packages/patches/libusb-for-axoloti.patch \
|
||||
%D%/packages/patches/libvdpau-va-gl-unbundle.patch \
|
||||
%D%/packages/patches/libvpx-CVE-2016-2818.patch \
|
||||
%D%/packages/patches/libxcb-python-3.5-compat.patch \
|
||||
%D%/packages/patches/libxml2-CVE-2016-4658.patch \
|
||||
|
|
35
gnu/packages/patches/libvdpau-va-gl-unbundle.patch
Normal file
35
gnu/packages/patches/libvdpau-va-gl-unbundle.patch
Normal file
|
@ -0,0 +1,35 @@
|
|||
From 18e3ff648356cf06a39372aa4a4bbf2732d9d0f4 Mon Sep 17 00:00:00 2001
|
||||
From: Efraim Flashner <efraim@flashner.co.il>
|
||||
Date: Tue, 12 Dec 2017 21:36:44 +0200
|
||||
Subject: [PATCH] don't use bundled libvdpau headers
|
||||
|
||||
---
|
||||
CMakeLists.txt | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 0484179..e950707 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -9,16 +9,17 @@ find_package(PkgConfig REQUIRED)
|
||||
find_package(X11 REQUIRED)
|
||||
pkg_check_modules(LIBVA libva-x11 REQUIRED)
|
||||
pkg_check_modules(LIBGL gl REQUIRED)
|
||||
+pkg_check_modules(LIBVDPAU vdpau REQUIRED)
|
||||
|
||||
set(DRIVER_NAME "vdpau_va_gl" CACHE STRING "driver name")
|
||||
set(LIB_SUFFIX "" CACHE STRING "library path suffix (if needed)")
|
||||
set(LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}/vdpau" CACHE PATH "library installation path")
|
||||
|
||||
include_directories (
|
||||
- 3rdparty
|
||||
${X11_INCLUDE_DIRS}
|
||||
${LIBVA_INCLUDE_DIRS}
|
||||
${LIBGL_INCLUDE_DIRS}
|
||||
+ ${LIBVDPAU_INCLUDE_DIRS}
|
||||
${GENERATED_INCLUDE_DIRS}
|
||||
${CMAKE_BINARY_DIR}
|
||||
)
|
||||
--
|
||||
2.15.1
|
||||
|
|
@ -1864,6 +1864,41 @@ (define-public vdpauinfo
|
|||
implementation.")
|
||||
(license (license:x11-style "file://COPYING"))))
|
||||
|
||||
(define-public libvdpau-va-gl
|
||||
(package
|
||||
(name "libvdpau-va-gl")
|
||||
(version "0.4.2")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://github.com/i-rinat/libvdpau-va-gl/"
|
||||
"releases/download/v" version "/libvdpau-va-gl-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1x2ag1f2fwa4yh1g5spv99w9x1m33hbxlqwyhm205ssq0ra234bx"))
|
||||
(patches (search-patches "libvdpau-va-gl-unbundle.patch"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet '(delete-file-recursively "3rdparty"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
'(#:tests? #f)) ; Tests require a running X11 server, with VA-API support.
|
||||
(native-inputs
|
||||
`(("libvdpau" ,libvdpau)
|
||||
("pkg-config" ,pkg-config)))
|
||||
(inputs
|
||||
`(("libva" ,libva)
|
||||
("mesa" ,mesa)))
|
||||
(home-page "https://github.com/i-rinat/libvdpau-va-gl")
|
||||
(synopsis "VDPAU driver with VA-API/OpenGL backend")
|
||||
(description
|
||||
"Many applications can use VDPAU to accelerate portions of the video
|
||||
decoding process and video post-processing to the GPU video hardware. Since
|
||||
there is no VDPAU available on Intel chips, they fall back to different drawing
|
||||
techniques. This driver uses OpenGL under the hood to accelerate drawing and
|
||||
scaling and VA-API (if available) to accelerate video decoding.")
|
||||
(license license:expat)))
|
||||
|
||||
(define-public recordmydesktop
|
||||
(package
|
||||
(name "recordmydesktop")
|
||||
|
|
Loading…
Reference in a new issue