mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 13:58:15 -05:00
quilt: Upgrade to 0.65.
* gnu/packages/patches/quilt-test-fix-regex.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/patchutils.scm (quilt)[version]: Upgrade to 0.65. [source]: Use patch. [arguments]: Adjust 'patch-tests' phase for new tests. Re-enable "mail" test.
This commit is contained in:
parent
000b540791
commit
68faa20e2d
3 changed files with 56 additions and 5 deletions
|
@ -1101,6 +1101,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/qtscript-disable-tests.patch \
|
%D%/packages/patches/qtscript-disable-tests.patch \
|
||||||
%D%/packages/patches/quagga-reproducible-build.patch \
|
%D%/packages/patches/quagga-reproducible-build.patch \
|
||||||
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \
|
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \
|
||||||
|
%D%/packages/patches/quilt-test-fix-regex.patch \
|
||||||
%D%/packages/patches/qtwebkit-pbutils-include.patch \
|
%D%/packages/patches/qtwebkit-pbutils-include.patch \
|
||||||
%D%/packages/patches/rapicorn-isnan.patch \
|
%D%/packages/patches/rapicorn-isnan.patch \
|
||||||
%D%/packages/patches/raptor2-heap-overflow.patch \
|
%D%/packages/patches/raptor2-heap-overflow.patch \
|
||||||
|
|
41
gnu/packages/patches/quilt-test-fix-regex.patch
Normal file
41
gnu/packages/patches/quilt-test-fix-regex.patch
Normal file
|
@ -0,0 +1,41 @@
|
||||||
|
From 5193b137b5a9034ce79946edd40760df2f63a82a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jean Delvare <jdelvare@suse.de>
|
||||||
|
Date: Tue, 25 Apr 2017 15:17:53 +0200
|
||||||
|
Subject: test: Escape curly braces in regex
|
||||||
|
|
||||||
|
Curly braces in perl regex are supposed to be escaped, recent
|
||||||
|
versions of perl complain when they aren't:
|
||||||
|
|
||||||
|
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/%{ <-- HERE (\w+)}/ at ./run line 114.
|
||||||
|
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/%{ <-- HERE \?}/ at ./run line 290.
|
||||||
|
|
||||||
|
Signed-off-by: Jean Delvare <jdelvare@suse.de>
|
||||||
|
---
|
||||||
|
test/run | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/test/run b/test/run
|
||||||
|
index 942014e..03afc7a 100755
|
||||||
|
--- a/test/run
|
||||||
|
+++ b/test/run
|
||||||
|
@@ -112,7 +112,7 @@ sub flush_output()
|
||||||
|
sub substitute_vars($)
|
||||||
|
{
|
||||||
|
my ($line) = @_;
|
||||||
|
- $line =~ s[%{(\w+)}][defined $ENV{$1} ? $ENV{$1} : ""]eg;
|
||||||
|
+ $line =~ s[%\{(\w+)\}][defined $ENV{$1} ? $ENV{$1} : ""]eg;
|
||||||
|
return $line;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -288,7 +288,7 @@ while (defined(my $line = <SOURCE>)) {
|
||||||
|
# Parse the next command
|
||||||
|
if ($line =~ s/^\s*\$ ?//) {
|
||||||
|
# Substitute %{?} with the last command's status
|
||||||
|
- $line =~ s[%{\?}][$last_status]eg;
|
||||||
|
+ $line =~ s[%\{\?\}][$last_status]eg;
|
||||||
|
|
||||||
|
chomp($prog = substitute_vars($line));
|
||||||
|
$prog_line = $lineno;
|
||||||
|
--
|
||||||
|
cgit v1.0-41-gc330
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
;;; GNU Guix --- Functional package management for GNU
|
;;; GNU Guix --- Functional package management for GNU
|
||||||
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
|
;;; Copyright © 2014, 2018 Eric Bavier <bavier@member.fsf.org>
|
||||||
;;; Copyright © 2015, 2018 Leo Famulari <leo@famulari.name>
|
;;; Copyright © 2015, 2018 Leo Famulari <leo@famulari.name>
|
||||||
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||||
;;;
|
;;;
|
||||||
|
@ -92,7 +92,7 @@ (define-public patchutils
|
||||||
(define-public quilt
|
(define-public quilt
|
||||||
(package
|
(package
|
||||||
(name "quilt")
|
(name "quilt")
|
||||||
(version "0.61")
|
(version "0.65")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -100,7 +100,8 @@ (define-public quilt
|
||||||
name "-" version ".tar.gz"))
|
name "-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1hwz58djkq9cv46sjwxbp2v5m8yjr41kd0nm1zm1xm6418khmv0y"))))
|
"06b816m2gz9jfif7k9v2hrm7fz76zjg5pavf7hd3ifybwn4cgjzn"))
|
||||||
|
(patches (search-patches "quilt-test-fix-regex.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("perl" ,perl)
|
(inputs `(("perl" ,perl)
|
||||||
("less" ,less)
|
("less" ,less)
|
||||||
|
@ -116,8 +117,16 @@ (define-public quilt
|
||||||
'("test/run"
|
'("test/run"
|
||||||
"test/edit.test")
|
"test/edit.test")
|
||||||
(("/bin/sh") (which "sh")))
|
(("/bin/sh") (which "sh")))
|
||||||
;; TODO: Run the mail tests once the mail feature can be supported.
|
(substitute* "test/create-delete.test"
|
||||||
(delete-file "test/mail.test")
|
;; We'd rather use quilt's compat/getopt than declare a
|
||||||
|
;; dependency on util-linux, but this test fails because of
|
||||||
|
;; compat/getopt's handling of "---" in this test, so remove it
|
||||||
|
;; for now.
|
||||||
|
((" ---") ""))
|
||||||
|
(substitute* '("test/empty-files.test" "test/faildiff.test")
|
||||||
|
;; compat/getopt seems not to handle splitting of short opts
|
||||||
|
;; from its arguments.
|
||||||
|
(("-pab") "-p ab"))
|
||||||
#t))
|
#t))
|
||||||
(add-after 'install 'wrap-program
|
(add-after 'install 'wrap-program
|
||||||
;; quilt's configure checks for the absolute path to the utilities it
|
;; quilt's configure checks for the absolute path to the utilities it
|
||||||
|
|
Loading…
Reference in a new issue