mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: metabat: Update to 2.11.3.
* gnu/packages/bioinformatics.scm (metabat): Update to 2.11.3. [source]: Use git-fetch. Remove boost-related patch. * gnu/packages/patches/metabat-fix-boost-issue.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
2d2e97bd71
commit
690a904ad7
3 changed files with 8 additions and 36 deletions
|
@ -841,7 +841,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/mesa-wayland-egl-symbols-check-mips.patch \
|
||||
%D%/packages/patches/metabat-remove-compilation-date.patch \
|
||||
%D%/packages/patches/metabat-fix-compilation.patch \
|
||||
%D%/packages/patches/metabat-fix-boost-issue.patch \
|
||||
%D%/packages/patches/mhash-keygen-test-segfault.patch \
|
||||
%D%/packages/patches/mingw-w64-5.0rc2-gcc-4.9.3.patch \
|
||||
%D%/packages/patches/mpc123-initialize-ao.patch \
|
||||
|
|
|
@ -3475,19 +3475,19 @@ (define-public mash
|
|||
(define-public metabat
|
||||
(package
|
||||
(name "metabat")
|
||||
(version "2.11.2")
|
||||
(version "2.11.3")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://bitbucket.org/berkeleylab/metabat/get/v"
|
||||
version ".tar.gz"))
|
||||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://bitbucket.org/berkeleylab/metabat.git")
|
||||
(commit "d0ad65367ffc8e08d1a9dd1388d6170daa047e5c")))
|
||||
(file-name (string-append name "-" version "-checkout"))
|
||||
(sha256
|
||||
(base32
|
||||
"0rws9r1ziv6way8cf49jg8bzj7x2131kfqkhj8byf0z5hnrq3bwv"))
|
||||
"1rlsrkz8iq8xah65222p055kzv5i3szz8bwysnvnh0pv72wvv6ww"))
|
||||
(patches (search-patches "metabat-remove-compilation-date.patch"
|
||||
"metabat-fix-compilation.patch"
|
||||
"metabat-fix-boost-issue.patch"))))
|
||||
"metabat-fix-compilation.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
This patch fixes the issue described at
|
||||
https://bitbucket.org/berkeleylab/metabat/issues/28/compilation-fail-with-boost-164
|
||||
|
||||
diff --git a/src/metabat.h b/src/metabat.h
|
||||
index 32ae94c..2292c04 100644
|
||||
--- a/src/metabat.h
|
||||
+++ b/src/metabat.h
|
||||
@@ -35,6 +35,7 @@ KSEQ_INIT(gzFile, gzread)
|
||||
|
||||
#include <boost/program_options.hpp>
|
||||
#include <boost/algorithm/string.hpp>
|
||||
+#include <boost/serialization/array_wrapper.hpp>
|
||||
#include <boost/numeric/ublas/matrix.hpp>
|
||||
#include <boost/math/distributions.hpp>
|
||||
#include <boost/serialization/serialization.hpp>
|
||||
diff --git a/src/metabat2.h b/src/metabat2.h
|
||||
index 60a9998..19fa815 100644
|
||||
--- a/src/metabat2.h
|
||||
+++ b/src/metabat2.h
|
||||
@@ -41,6 +41,7 @@ KSEQ_INIT(gzFile, gzread)
|
||||
|
||||
#include <boost/program_options.hpp>
|
||||
#include <boost/algorithm/string.hpp>
|
||||
+#include <boost/serialization/array_wrapper.hpp>
|
||||
#include <boost/numeric/ublas/matrix.hpp>
|
||||
#include <boost/numeric/ublas/matrix_sparse.hpp>
|
||||
#include <boost/numeric/ublas/matrix_proxy.hpp>
|
Loading…
Reference in a new issue