gnu: Remove unused patch 'ao-cad-aarch64-support.patch'.

This is a followup to commit 28f4d56dd3.

* gnu/packages/patches/ao-cad-aarch64-support.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Leo Famulari 2019-02-04 23:50:06 +01:00
parent ee2875e57d
commit 6bf2201350
No known key found for this signature in database
GPG key ID: 2646FA30BACA7F08
2 changed files with 0 additions and 19 deletions

View file

@ -639,7 +639,6 @@ dist_patch_DATA = \
%D%/packages/patches/antiword-CVE-2014-8123.patch \
%D%/packages/patches/antlr3-3_1-fix-java8-compilation.patch \
%D%/packages/patches/antlr3-3_3-fix-java8-compilation.patch \
%D%/packages/patches/ao-cad-aarch64-support.patch \
%D%/packages/patches/apr-skip-getservbyname-test.patch \
%D%/packages/patches/aria2-CVE-2019-3500.patch \
%D%/packages/patches/aspell-default-dict-dir.patch \

View file

@ -1,18 +0,0 @@
Support in ao-cad for aarch64.
Submitted upstream at https://github.com/mkeeter/ao/issues/69
--- ao/ui/vendor/efsw/src/efsw/inotify-nosys.h.orig 2017-12-14 16:27:16.125871099 -0600
+++ ao/ui/vendor/efsw/src/efsw/inotify-nosys.h 2017-12-14 16:26:39.786022981 -0600
@@ -69,6 +69,11 @@
# define __NR_inotify_add_watch (__NR_SYSCALL_BASE+317)
# define __NR_inotify_rm_watch (__NR_SYSCALL_BASE+318)
+#elif defined (__aarch64__)
+# define __NR_inotify_init 1043
+# define __NR_inotify_add_watch 27
+# define __NR_inotify_rm_watch 28
+
#elif defined (__frv__)
# define __NR_inotify_init 291
# define __NR_inotify_add_watch 292