mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 22:08:16 -05:00
gnu: isync: Add patch to improve openssl-3 compatibility.
* gnu/packages/patches/isync-openssl3-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/mail.scm (isync): Use patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
b5a85e31dd
commit
6d0571215d
3 changed files with 86 additions and 1 deletions
|
@ -1377,6 +1377,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/irrlicht-use-system-libs.patch \
|
%D%/packages/patches/irrlicht-use-system-libs.patch \
|
||||||
%D%/packages/patches/irrlicht-link-against-needed-libs.patch \
|
%D%/packages/patches/irrlicht-link-against-needed-libs.patch \
|
||||||
%D%/packages/patches/isl-0.11.1-aarch64-support.patch \
|
%D%/packages/patches/isl-0.11.1-aarch64-support.patch \
|
||||||
|
%D%/packages/patches/isync-openssl3-fix.patch \
|
||||||
%D%/packages/patches/itk-snap-alt-glibc-compat.patch \
|
%D%/packages/patches/itk-snap-alt-glibc-compat.patch \
|
||||||
%D%/packages/patches/jami-disable-integration-tests.patch \
|
%D%/packages/patches/jami-disable-integration-tests.patch \
|
||||||
%D%/packages/patches/jami-libjami-headers-search.patch \
|
%D%/packages/patches/jami-libjami-headers-search.patch \
|
||||||
|
|
|
@ -2233,7 +2233,10 @@ (define-public isync
|
||||||
(uri (string-append "mirror://sourceforge/isync/isync/"
|
(uri (string-append "mirror://sourceforge/isync/isync/"
|
||||||
version "/isync-" version ".tar.gz"))
|
version "/isync-" version ".tar.gz"))
|
||||||
(sha256 (base32
|
(sha256 (base32
|
||||||
"1zq0wwvmqsl9y71546dr0aygzn9gjjfiw19hlcq87s929y4p6ckw"))))
|
"1zq0wwvmqsl9y71546dr0aygzn9gjjfiw19hlcq87s929y4p6ckw"))
|
||||||
|
(patches
|
||||||
|
;; Likely to be included in next version
|
||||||
|
(search-patches "isync-openssl3-fix.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list perl))
|
(list perl))
|
||||||
|
|
81
gnu/packages/patches/isync-openssl3-fix.patch
Normal file
81
gnu/packages/patches/isync-openssl3-fix.patch
Normal file
|
@ -0,0 +1,81 @@
|
||||||
|
Upstream status: Taken from master branch. Likely included in versions > 1.4.4
|
||||||
|
|
||||||
|
Fixes issues with OpenSSL3. See related thread:
|
||||||
|
https://sourceforge.net/p/isync/mailman/isync-devel/thread/Y2jnr8hESp1PUW+6@bulldog/
|
||||||
|
|
||||||
|
From b6c36624f04cd388873785c0631df3f2f9ac4bf0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Oswald Buddenhagen <ossi@users.sf.net>
|
||||||
|
Date: Mon, 6 Jun 2022 11:55:37 +0200
|
||||||
|
Subject: [PATCH] work around "unexpected EOF" error messages at end of SSL
|
||||||
|
connections
|
||||||
|
|
||||||
|
gmail apparently doesn't send a close notification (SSL_shutdown())
|
||||||
|
before closing the TCP socket.
|
||||||
|
---
|
||||||
|
src/drv_imap.c | 7 +++++--
|
||||||
|
src/socket.c | 9 +++++++++
|
||||||
|
src/socket.h | 1 +
|
||||||
|
3 files changed, 15 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/drv_imap.c b/src/drv_imap.c
|
||||||
|
index fb8d165..6286045 100644
|
||||||
|
--- a/src/drv_imap.c
|
||||||
|
+++ b/src/drv_imap.c
|
||||||
|
@@ -1620,6 +1620,7 @@ imap_socket_read( void *aux )
|
||||||
|
error( "IMAP error: unexpected BYE response: %s\n", cmd );
|
||||||
|
/* We just wait for the server to close the connection now. */
|
||||||
|
ctx->expectEOF = 1;
|
||||||
|
+ socket_expect_eof( &ctx->conn );
|
||||||
|
} else {
|
||||||
|
/* We still need to wait for the LOGOUT's tagged OK. */
|
||||||
|
}
|
||||||
|
@@ -1882,10 +1883,12 @@ static void
|
||||||
|
imap_cleanup_p2( imap_store_t *ctx,
|
||||||
|
imap_cmd_t *cmd ATTR_UNUSED, int response )
|
||||||
|
{
|
||||||
|
- if (response == RESP_NO)
|
||||||
|
+ if (response == RESP_NO) {
|
||||||
|
imap_cancel_store( &ctx->gen );
|
||||||
|
- else if (response == RESP_OK)
|
||||||
|
+ } else if (response == RESP_OK) {
|
||||||
|
ctx->expectEOF = 1;
|
||||||
|
+ socket_expect_eof( &ctx->conn );
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
|
||||||
|
/******************* imap_open_store *******************/
|
||||||
|
diff --git a/src/socket.c b/src/socket.c
|
||||||
|
index ac3c847..892cece 100644
|
||||||
|
--- a/src/socket.c
|
||||||
|
+++ b/src/socket.c
|
||||||
|
@@ -810,6 +810,15 @@ socket_expect_activity( conn_t *conn, int expect )
|
||||||
|
conf_wakeup( &conn->fd_timeout, expect ? conn->conf->timeout : -1 );
|
||||||
|
}
|
||||||
|
|
||||||
|
+void
|
||||||
|
+socket_expect_eof( conn_t *sock )
|
||||||
|
+{
|
||||||
|
+#ifdef SSL_OP_IGNORE_UNEXPECTED_EOF // implies HAVE_LIBSSL
|
||||||
|
+ if (sock->ssl)
|
||||||
|
+ SSL_set_options( sock->ssl, SSL_OP_IGNORE_UNEXPECTED_EOF );
|
||||||
|
+#endif
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
int
|
||||||
|
socket_read( conn_t *conn, char *buf, uint len )
|
||||||
|
{
|
||||||
|
diff --git a/src/socket.h b/src/socket.h
|
||||||
|
index 5b1edd0..af679aa 100644
|
||||||
|
--- a/src/socket.h
|
||||||
|
+++ b/src/socket.h
|
||||||
|
@@ -142,6 +142,7 @@ void socket_start_tls(conn_t *conn, void (*cb)( int ok, void *aux ) );
|
||||||
|
void socket_start_deflate( conn_t *conn );
|
||||||
|
void socket_close( conn_t *sock );
|
||||||
|
void socket_expect_activity( conn_t *sock, int expect );
|
||||||
|
+void socket_expect_eof( conn_t *sock );
|
||||||
|
int socket_read( conn_t *sock, char *buf, uint len ); /* never waits */
|
||||||
|
char *socket_read_line( conn_t *sock ); /* don't free return value; never waits */
|
||||||
|
typedef enum { KeepOwn = 0, GiveOwn } ownership_t;
|
||||||
|
--
|
||||||
|
2.39.2
|
||||||
|
|
Loading…
Reference in a new issue