mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: Add go-github-com-warpfork-go-wish.
* gnu/packages/golang-check.scm (go-github-com-warpfork-go-wish): New variable. * gnu/packages/patches/go-github-com-warpfork-go-wish-fix-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add "go-github-com-warpfork-go-wish-fix-tests.patch". Change-Id: Ic3245a1112ef2e04b22cf26be23f27bf3ff90e9e Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
This commit is contained in:
parent
b803b9aad1
commit
6d36befee8
3 changed files with 114 additions and 0 deletions
|
@ -1394,6 +1394,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/go-github-com-golang-snappy-32bit-test.patch \
|
||||
%D%/packages/patches/go-github-com-urfave-cli-fix-tests.patch \
|
||||
%D%/packages/patches/go-github-com-urfave-cli-v2-fix-tests.patch \
|
||||
%D%/packages/patches/go-github-com-warpfork-go-wish-fix-tests.patch \
|
||||
%D%/packages/patches/go-github-com-wraparound-wrap-free-fonts.patch \
|
||||
%D%/packages/patches/go-skip-gc-test.patch \
|
||||
%D%/packages/patches/gourmet-sqlalchemy-compat.patch \
|
||||
|
|
|
@ -1003,6 +1003,34 @@ (define-public go-github-com-go-playground-assert-v2
|
|||
(arguments
|
||||
(list #:import-path "github.com/go-playground/assert/v2"))))
|
||||
|
||||
(define-public go-github-com-warpfork-go-wish
|
||||
(package
|
||||
(name "go-github-com-warpfork-go-wish")
|
||||
(version "0.0.0-20220906213052-39a1cc7a02d0")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/warpfork/go-wish")
|
||||
(commit (go-version->git-ref version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "0rqbxmqwzy1q2zwy3mszp0li0pg8zzh3j9l8wlzr6p1pq2idallq"))
|
||||
(patches (search-patches
|
||||
"go-github-com-warpfork-go-wish-fix-tests.patch"))))
|
||||
(build-system go-build-system)
|
||||
(arguments
|
||||
(list
|
||||
#:go go-1.21
|
||||
#:import-path "github.com/warpfork/go-wish"))
|
||||
(home-page "https://github.com/warpfork/go-wish")
|
||||
(synopsis "Test assertions for Golang")
|
||||
(description
|
||||
"@code{wish} is a test assertion library for Golang, designed to
|
||||
gracefully enhance standard library testing package and behaviors of the
|
||||
@command{go test} command.")
|
||||
(license license:expat)))
|
||||
|
||||
(define-public go-go-uber-org-goleak
|
||||
(package
|
||||
(name "go-go-uber-org-goleak")
|
||||
|
|
|
@ -0,0 +1,85 @@
|
|||
From d53c651a8fd65656e486eb5c7e20ab889f64639b Mon Sep 17 00:00:00 2001
|
||||
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
|
||||
Date: Sun, 28 Apr 2024 13:24:34 +0300
|
||||
Subject: [PATCH] output_test.go: Fix tests
|
||||
|
||||
* output_test.go (TestGoTestOutputTree, TestGoTestOutputFun): Fix
|
||||
tests.
|
||||
---
|
||||
output_test.go | 40 ++++++++++++++++++++--------------------
|
||||
1 file changed, 20 insertions(+), 20 deletions(-)
|
||||
|
||||
diff --git a/output_test.go b/output_test.go
|
||||
index eb3e0e9..58948c2 100644
|
||||
--- a/output_test.go
|
||||
+++ b/output_test.go
|
||||
@@ -75,15 +75,15 @@ func TestGoTestOutputTree(t *testing.T) {
|
||||
diff := strdiff(nom, Dedent(`
|
||||
=== RUN TestGoTestOutputTree_helper
|
||||
=== RUN TestGoTestOutputTree_helper/subtest
|
||||
+ output_test.go:NN: wtf
|
||||
=== RUN TestGoTestOutputTree_helper/subtest/subsubtest
|
||||
+ output_test.go:NN: sadz
|
||||
=== RUN TestGoTestOutputTree_helper/subtest/happy_subsubtest
|
||||
+ output_test.go:NN: ooh!
|
||||
--- FAIL: TestGoTestOutputTree_helper (N.NNs)
|
||||
--- FAIL: TestGoTestOutputTree_helper/subtest (N.NNs)
|
||||
- output_test.go:NN: wtf
|
||||
--- FAIL: TestGoTestOutputTree_helper/subtest/subsubtest (N.NNs)
|
||||
- output_test.go:NN: sadz
|
||||
--- PASS: TestGoTestOutputTree_helper/subtest/happy_subsubtest (N.NNs)
|
||||
- output_test.go:NN: ooh!
|
||||
FAIL
|
||||
exit status N
|
||||
FAIL github.com/warpfork/go-wish N.NNNs
|
||||
@@ -149,28 +149,28 @@ func TestGoTestOutputFun(t *testing.T) {
|
||||
diff := strdiff(nom, Dedent(`
|
||||
=== RUN TestGoTestOutputFun_helper
|
||||
=== RUN TestGoTestOutputFun_helper/subtest
|
||||
+ output_test.go:NNN: hello!
|
||||
=== RUN TestGoTestOutputFun_helper/subtest/subsubtest
|
||||
+ output_test.go:NNN: ShouldEqual check rejected:
|
||||
+ @@ -N +N @@
|
||||
+ - snafoo
|
||||
+ + zounds
|
||||
+
|
||||
+ output_test.go:NNN: ShouldEqual check rejected:
|
||||
+ @@ -N +N @@
|
||||
+ - zebras
|
||||
+ + cats
|
||||
+
|
||||
+ output_test.go:NNN: ShouldEqual check rejected:
|
||||
+ interface{}(
|
||||
+ - struct{ Foo string }{},
|
||||
+ + struct{ Bar string }{},
|
||||
+ )
|
||||
+
|
||||
=== RUN TestGoTestOutputFun_helper/subtest/happy_subsubtest
|
||||
--- FAIL: TestGoTestOutputFun_helper (N.NNs)
|
||||
--- FAIL: TestGoTestOutputFun_helper/subtest (N.NNs)
|
||||
- output_test.go:NNN: hello!
|
||||
--- FAIL: TestGoTestOutputFun_helper/subtest/subsubtest (N.NNs)
|
||||
- output_test.go:NNN: ShouldEqual check rejected:
|
||||
- @@ -N +N @@
|
||||
- - snafoo
|
||||
- + zounds
|
||||
-
|
||||
- output_test.go:NNN: ShouldEqual check rejected:
|
||||
- @@ -N +N @@
|
||||
- - zebras
|
||||
- + cats
|
||||
-
|
||||
- output_test.go:NNN: ShouldEqual check rejected:
|
||||
- interface{}(
|
||||
- - struct{ Foo string }{},
|
||||
- + struct{ Bar string }{},
|
||||
- )
|
||||
-
|
||||
--- PASS: TestGoTestOutputFun_helper/subtest/happy_subsubtest (N.NNs)
|
||||
FAIL
|
||||
exit status N
|
||||
|
||||
base-commit: 39a1cc7a02d01d037bc6bc075e6550279026e645
|
||||
--
|
||||
2.41.0
|
||||
|
Loading…
Reference in a new issue