gnu: Tcl/Tk: Update to 8.6.11.

* gnu/packages/patches/tcl-fix-cross-compilation.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/tcl.scm (tcl): Update to 8.6.11.
[source](patches): Remove.
[arguments]: Remove trailing #t's.
(tk): Update to 8.6.11.1.
[arguments]: Remove trailing #t's and reindent.
This commit is contained in:
Marius Bakke 2021-05-16 12:09:30 +02:00
parent 4119775de1
commit 6daa0b5af3
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 25 additions and 74 deletions

View file

@ -1686,7 +1686,6 @@ dist_patch_DATA = \
%D%/packages/patches/tar-skip-unreliable-tests.patch \
%D%/packages/patches/tcc-boot-0.9.27.patch \
%D%/packages/patches/tclxml-3.2-install.patch \
%D%/packages/patches/tcl-fix-cross-compilation.patch \
%D%/packages/patches/tcsh-fix-autotest.patch \
%D%/packages/patches/teensy-loader-cli-help.patch \
%D%/packages/patches/texinfo-5-perl-compat.patch \

View file

@ -1,39 +0,0 @@
From f7fa48c4c75a1e748dc5071e709c0b62ff739eaa Mon Sep 17 00:00:00 2001
From: "jan.nijtmans" <nijtmans@users.sourceforge.net>
Date: Mon, 9 Dec 2019 10:02:20 +0000
Subject: [PATCH] Fix [abd4abedd2]: Failed to build tk 8.6.10 with cross
compile
Patch taken from upstream to fix cross-compilation. To be removed on next Tcl release.
---
compat/strtol.c | 2 +-
compat/strtoul.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/compat/strtol.c b/compat/strtol.c
index b7f69196ce2..811006a64c3 100644
--- a/compat/strtol.c
+++ b/compat/strtol.c
@@ -53,7 +53,7 @@ strtol(
*/
p = string;
- while (TclIsSpaceProc(*p)) {
+ while (isspace(UCHAR(*p))) {
p += 1;
}
diff --git a/compat/strtoul.c b/compat/strtoul.c
index e37eb05f823..15587f1da1a 100644
--- a/compat/strtoul.c
+++ b/compat/strtoul.c
@@ -74,7 +74,7 @@ strtoul(
*/
p = string;
- while (TclIsSpaceProc(*p)) {
+ while (isspace(UCHAR(*p))) {
p += 1;
}
if (*p == '-') {

View file

@ -44,20 +44,19 @@ (define-module (gnu packages tcl)
(define-public tcl
(package
(name "tcl")
(version "8.6.10")
(version "8.6.11")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/tcl/Tcl/"
version "/tcl" version "-src.tar.gz"))
(sha256
(base32
"1vc7imilx6kcb5319r7hnrp4jn5pqb41an3vr3azhgcfcgvdp5ji"))
(patches (search-patches "tcl-fix-cross-compilation.patch"))))
"0n4211j80mxr6ql0xx52rig8r885rcbminfpjdb2qrw6hmk8c14c"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
(add-before 'configure 'pre-configure
(lambda _ (chdir "unix") #t))
(lambda _ (chdir "unix")))
(add-after 'install 'install-private-headers
(lambda* (#:key outputs #:allow-other-keys)
;; Private headers are needed by Expect.
@ -68,8 +67,7 @@ (define-public tcl
;; Programs such as Ghostscript rely on it.
(with-directory-excursion bin
(symlink (car (find-files "." "tclsh"))
"tclsh"))
#t))))
"tclsh"))))))
;; By default, man pages are put in PREFIX/man, but we want them in
;; PREFIX/share/man. The 'validate-documentation-location' phase is
@ -197,7 +195,7 @@ (define-public expect
(define-public tk
(package
(name "tk")
(version "8.6.10")
(version "8.6.11.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/tcl/Tcl/"
@ -205,38 +203,31 @@ (define-public tk
version "-src.tar.gz"))
(sha256
(base32
"11p3ycqbr5116vpaxv6fl6md6gcav1ffspgr8wrlc2lxhn543pv3"))
"1gh9k7l76qg9l0sb78ijw9xz4xl1af47aqbdifb6mjpf3cbsnv00"))
(patches (search-patches "tk-find-library.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
(add-before
'configure 'pre-configure
(lambda _
(chdir "unix")
#t))
(add-after
'install 'create-wish-symlink
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(symlink (string-append out "/bin/wish"
,(version-major+minor
(add-before 'configure 'pre-configure
(lambda _ (chdir "unix")))
(add-after 'install 'create-wish-symlink
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(symlink (string-append out "/bin/wish"
,(version-major+minor
(package-version tk)))
(string-append out "/bin/wish")))
#t))
(add-after
'install 'add-fontconfig-flag
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Add the missing -L flag for Fontconfig in 'tk.pc' and
;; 'tkConfig.sh'.
(let ((out (assoc-ref outputs "out"))
(fontconfig (assoc-ref inputs "fontconfig")))
(substitute* (find-files out
"^(tkConfig\\.sh|tk\\.pc)$")
(("-lfontconfig")
(string-append "-L" fontconfig
"/lib -lfontconfig")))
#t))))
(string-append out "/bin/wish")))))
(add-after 'install 'add-fontconfig-flag
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Add the missing -L flag for Fontconfig in 'tk.pc' and
;; 'tkConfig.sh'.
(let ((out (assoc-ref outputs "out"))
(fontconfig (assoc-ref inputs "fontconfig")))
(substitute* (find-files out
"^(tkConfig\\.sh|tk\\.pc)$")
(("-lfontconfig")
(string-append "-L" fontconfig
"/lib -lfontconfig")))))))
#:configure-flags
(list (string-append "--with-tcl="