mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
gnu: graphite2: Update to 1.3.11.
* gnu/packages/patches/graphite2-ffloat-store.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/fontutils.scm (graphite2): Update to 1.3.11. [source](patches): Remove.
This commit is contained in:
parent
1b5292ca54
commit
6eb45016d6
3 changed files with 2 additions and 38 deletions
|
@ -729,7 +729,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/gpm-glibc-2.26.patch \
|
%D%/packages/patches/gpm-glibc-2.26.patch \
|
||||||
%D%/packages/patches/gpsbabel-minizip.patch \
|
%D%/packages/patches/gpsbabel-minizip.patch \
|
||||||
%D%/packages/patches/gpsbabel-qstring.patch \
|
%D%/packages/patches/gpsbabel-qstring.patch \
|
||||||
%D%/packages/patches/graphite2-ffloat-store.patch \
|
|
||||||
%D%/packages/patches/grep-timing-sensitive-test.patch \
|
%D%/packages/patches/grep-timing-sensitive-test.patch \
|
||||||
%D%/packages/patches/groff-source-date-epoch.patch \
|
%D%/packages/patches/groff-source-date-epoch.patch \
|
||||||
%D%/packages/patches/gsl-test-i686.patch \
|
%D%/packages/patches/gsl-test-i686.patch \
|
||||||
|
|
|
@ -378,16 +378,15 @@ (define-public teckit
|
||||||
(define-public graphite2
|
(define-public graphite2
|
||||||
(package
|
(package
|
||||||
(name "graphite2")
|
(name "graphite2")
|
||||||
(version "1.3.10")
|
(version "1.3.11")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://github.com/silnrsi/graphite/releases/"
|
(uri (string-append "https://github.com/silnrsi/graphite/releases/"
|
||||||
"download/" version "/" name "-" version ".tgz"))
|
"download/" version "/" name "-" version ".tgz"))
|
||||||
(patches (search-patches "graphite2-ffloat-store.patch"))
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1bm1rl2ww0m8rvmknh8fpajyz9xqv43qs9qrzf7xd5gaz6rf7zch"))))
|
"0z5dcgh8r3678awq6fb8igik7xmar5m6z9xxwpkkhradhk8jxfds"))))
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("python" ,python-2) ; because of "import imap" in tests
|
`(("python" ,python-2) ; because of "import imap" in tests
|
||||||
|
|
|
@ -1,34 +0,0 @@
|
||||||
Fix test failures of awamicmp1 and awamicmp2.
|
|
||||||
|
|
||||||
Debian bug report:
|
|
||||||
|
|
||||||
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=855814
|
|
||||||
|
|
||||||
Patch adapted from upstream source repository:
|
|
||||||
|
|
||||||
https://github.com/silnrsi/graphite/commit/f7bbdd87d510d587c872e314d6458160c0069c65
|
|
||||||
|
|
||||||
From f7bbdd87d510d587c872e314d6458160c0069c65 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Martin Hosken <martin_hosken@sil.org>
|
|
||||||
Date: Tue, 14 Feb 2017 17:00:03 +0000
|
|
||||||
Subject: [PATCH] try -ffloat-store for fp stability. Remove nested const to
|
|
||||||
work around VS bug
|
|
||||||
|
|
||||||
---
|
|
||||||
src/CMakeLists.txt | 2 +-
|
|
||||||
src/inc/locale2lcid.h | 4 ++--
|
|
||||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
|
||||||
index 4f1e7e5..5b61b5c 100644
|
|
||||||
--- a/src/CMakeLists.txt
|
|
||||||
+++ b/src/CMakeLists.txt
|
|
||||||
@@ -108,7 +108,7 @@ set_target_properties(graphite2 PROPERTIES PUBLIC_HEADER "${GRAPHITE_HEADERS}"
|
|
||||||
|
|
||||||
if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
|
|
||||||
set_target_properties(graphite2 PROPERTIES
|
|
||||||
- COMPILE_FLAGS "-Wall -Wextra -Wno-unknown-pragmas -Wendif-labels -Wshadow -Wctor-dtor-privacy -Wnon-virtual-dtor -fno-rtti -fno-exceptions -fvisibility=hidden -fvisibility-inlines-hidden -fno-stack-protector"
|
|
||||||
+ COMPILE_FLAGS "-Wall -Wextra -Wno-unknown-pragmas -Wendif-labels -Wshadow -Wctor-dtor-privacy -Wnon-virtual-dtor -fno-rtti -fno-exceptions -fvisibility=hidden -fvisibility-inlines-hidden -fno-stack-protector -ffloat-store"
|
|
||||||
LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}"
|
|
||||||
LINKER_LANGUAGE C)
|
|
||||||
if (CMAKE_COMPILER_IS_GNUCXX)
|
|
Loading…
Reference in a new issue