mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-12 22:26:40 -05:00
gnu: supertux: Update to 0.6.3.
* gnu/packages/games.scm (supertux): Update to 0.6.3. [inputs] Sort list and add glm. * gnu/packages/patches/supertux-unbundle-squirrel.patch: Adjust patch to apply with upstream changes. Signed-off-by: Leo Famulari <leo@famulari.name>
This commit is contained in:
parent
0fea9aec59
commit
707acc4cfb
2 changed files with 23 additions and 19 deletions
|
@ -5442,7 +5442,7 @@ (define-public tuxpaint-config
|
||||||
(define-public supertux
|
(define-public supertux
|
||||||
(package
|
(package
|
||||||
(name "supertux")
|
(name "supertux")
|
||||||
(version "0.6.2")
|
(version "0.6.3")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://github.com/SuperTux/supertux/"
|
(uri (string-append "https://github.com/SuperTux/supertux/"
|
||||||
|
@ -5451,7 +5451,7 @@ (define-public supertux
|
||||||
(file-name (string-append name "-" version ".tar.gz"))
|
(file-name (string-append name "-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"167m3z4m8n76dvbv42m1fnvabpbpsxvr28zk9641916jl9pfba96"))
|
"1xkr3ka2sxp5s0spp84iv294i29s1vxqzazb6kmjc0n415h0x57p"))
|
||||||
(patches
|
(patches
|
||||||
(search-patches "supertux-unbundle-squirrel.patch"))))
|
(search-patches "supertux-unbundle-squirrel.patch"))))
|
||||||
(arguments
|
(arguments
|
||||||
|
@ -5471,18 +5471,19 @@ (define-public supertux
|
||||||
(string-append "${SQUIRREL_PREFIX}/include/squirrel"))))
|
(string-append "${SQUIRREL_PREFIX}/include/squirrel"))))
|
||||||
#t)))))
|
#t)))))
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
(inputs (list sdl2
|
(inputs (list boost
|
||||||
|
curl
|
||||||
|
freetype
|
||||||
|
glew
|
||||||
|
glm
|
||||||
|
libogg
|
||||||
|
libvorbis
|
||||||
|
mesa
|
||||||
|
openal
|
||||||
|
physfs
|
||||||
|
sdl2
|
||||||
sdl2-image
|
sdl2-image
|
||||||
sdl2-mixer
|
sdl2-mixer
|
||||||
openal
|
|
||||||
mesa
|
|
||||||
glew
|
|
||||||
libvorbis
|
|
||||||
libogg
|
|
||||||
physfs
|
|
||||||
curl
|
|
||||||
boost
|
|
||||||
freetype
|
|
||||||
squirrel))
|
squirrel))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list pkg-config))
|
(list pkg-config))
|
||||||
|
|
|
@ -1,9 +1,8 @@
|
||||||
diff -ur a/CMakeLists.txt b/CMakeLists.txt
|
--- a/CMakeLists.txt 2022-01-05 18:51:17.828392874 +0100
|
||||||
--- a/CMakeLists.txt 2019-05-24 17:58:19.693090158 -0400
|
+++ b/CMakeLists.txt 2022-01-05 18:54:50.826717830 +0100
|
||||||
+++ b/CMakeLists.txt 2019-05-24 17:57:43.349473252 -0400
|
@@ -487,48 +487,15 @@
|
||||||
@@ -375,44 +375,15 @@
|
include_directories(${CMAKE_CURRENT_SOURCE_DIR}/src/ppc)
|
||||||
|
endif()
|
||||||
include(ConfigureChecks)
|
|
||||||
|
|
||||||
-
|
-
|
||||||
-## Also build external/squirrel
|
-## Also build external/squirrel
|
||||||
|
@ -15,6 +14,9 @@ diff -ur a/CMakeLists.txt b/CMakeLists.txt
|
||||||
set(SQUIRREL_PREFIX ${CMAKE_BINARY_DIR}/squirrel/ex)
|
set(SQUIRREL_PREFIX ${CMAKE_BINARY_DIR}/squirrel/ex)
|
||||||
-ExternalProject_Add(squirrel
|
-ExternalProject_Add(squirrel
|
||||||
- SOURCE_DIR "${CMAKE_SOURCE_DIR}/external/squirrel/"
|
- SOURCE_DIR "${CMAKE_SOURCE_DIR}/external/squirrel/"
|
||||||
|
- BUILD_BYPRODUCTS
|
||||||
|
- "${SQUIRREL_PREFIX}/lib/${CMAKE_STATIC_LIBRARY_PREFIX}sqstdlib_static${CMAKE_STATIC_LIBRARY_SUFFIX}"
|
||||||
|
- "${SQUIRREL_PREFIX}/lib/${CMAKE_STATIC_LIBRARY_PREFIX}squirrel_static${CMAKE_STATIC_LIBRARY_SUFFIX}"
|
||||||
- CMAKE_ARGS
|
- CMAKE_ARGS
|
||||||
- -DCMAKE_BUILD_TYPE=${CMAKE_BUILD_TYPE}
|
- -DCMAKE_BUILD_TYPE=${CMAKE_BUILD_TYPE}
|
||||||
- -DCMAKE_C_COMPILER=${CMAKE_C_COMPILER}
|
- -DCMAKE_C_COMPILER=${CMAKE_C_COMPILER}
|
||||||
|
@ -22,7 +24,8 @@ diff -ur a/CMakeLists.txt b/CMakeLists.txt
|
||||||
- -DCMAKE_CXX_COMPILER=${CMAKE_CXX_COMPILER}
|
- -DCMAKE_CXX_COMPILER=${CMAKE_CXX_COMPILER}
|
||||||
- -DCMAKE_CXX_FLAGS=${CMAKE_CXX_FLAGS}
|
- -DCMAKE_CXX_FLAGS=${CMAKE_CXX_FLAGS}
|
||||||
- -DCMAKE_INSTALL_PREFIX=${SQUIRREL_PREFIX}
|
- -DCMAKE_INSTALL_PREFIX=${SQUIRREL_PREFIX}
|
||||||
- -DINSTALL_INC_DIR=include)
|
- -DINSTALL_INC_DIR=include
|
||||||
|
- -DCMAKE_POSITION_INDEPENDENT_CODE=ON)
|
||||||
-
|
-
|
||||||
-if(WIN32)
|
-if(WIN32)
|
||||||
- add_library(squirrel_lib SHARED IMPORTED)
|
- add_library(squirrel_lib SHARED IMPORTED)
|
||||||
|
|
Loading…
Reference in a new issue