mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
gnu: crossmap: Update to 0.2.9.
* gnu/packages/bioinformatics.scm (crossmap): Update to 0.2.9. * gnu/packages/patches/crossmap-allow-system-pysam.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove patch.
This commit is contained in:
parent
8640f9ec91
commit
7321920cd3
3 changed files with 6 additions and 141 deletions
|
@ -634,7 +634,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/cracklib-fix-buffer-overflow.patch \
|
||||
%D%/packages/patches/crawl-upgrade-saves.patch \
|
||||
%D%/packages/patches/crda-optional-gcrypt.patch \
|
||||
%D%/packages/patches/crossmap-allow-system-pysam.patch \
|
||||
%D%/packages/patches/clucene-contribs-lib.patch \
|
||||
%D%/packages/patches/cube-nocheck.patch \
|
||||
%D%/packages/patches/cursynth-wave-rand.patch \
|
||||
|
|
|
@ -1894,31 +1894,18 @@ (define-public clustal-omega
|
|||
(define-public crossmap
|
||||
(package
|
||||
(name "crossmap")
|
||||
(version "0.2.1")
|
||||
(version "0.2.9")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/crossmap/CrossMap-"
|
||||
version ".tar.gz"))
|
||||
(uri (pypi-uri "CrossMap" version))
|
||||
(sha256
|
||||
(base32
|
||||
"07y179f63d7qnzdvkqcziwk9bs3k4zhp81q392fp1hwszjdvy22f"))
|
||||
;; This patch has been sent upstream already and is available
|
||||
;; for download from Sourceforge, but it has not been merged.
|
||||
(patches (search-patches "crossmap-allow-system-pysam.patch"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet '(begin
|
||||
;; remove bundled copy of pysam
|
||||
(delete-file-recursively "lib/pysam")
|
||||
#t))))
|
||||
"1byhclrqnqpvc1rqkfh4jwj6yhn0x9y7jk47i0qcjlhk0pjkw92p"))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
`(#:python ,python-2
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'set-env
|
||||
(lambda _ (setenv "CROSSMAP_USE_SYSTEM_PYSAM" "1") #t)))))
|
||||
(arguments `(#:python ,python-2))
|
||||
(inputs
|
||||
`(("python-numpy" ,python2-numpy)
|
||||
`(("python-bx-python" ,python2-bx-python)
|
||||
("python-numpy" ,python2-numpy)
|
||||
("python-pysam" ,python2-pysam)
|
||||
("zlib" ,zlib)))
|
||||
(native-inputs
|
||||
|
|
|
@ -1,121 +0,0 @@
|
|||
This patch modifies the build process such that the bundled copy of pysam does
|
||||
not need to be built if CROSSMAP_USE_SYSTEM_PYSAM is set and the pysam module
|
||||
can be imported.
|
||||
|
||||
Upstream has agreed to apply the patch in the next maintenance release of
|
||||
crossmap. The patch has already been uploaded to
|
||||
http://sourceforge.net/projects/crossmap/files/patch/.
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
--- a/setup.py 2015-02-26 15:28:49.771189185 +0100
|
||||
+++ b/setup.py 2015-02-26 15:55:03.440327752 +0100
|
||||
@@ -19,6 +19,15 @@
|
||||
except:
|
||||
have_numpy = False
|
||||
|
||||
+try:
|
||||
+ import pysam
|
||||
+ if os.environ['CROSSMAP_USE_SYSTEM_PYSAM']:
|
||||
+ have_pysam = True
|
||||
+ else:
|
||||
+ have_pysam = False
|
||||
+except ImportError:
|
||||
+ have_pysam = False
|
||||
+
|
||||
if platform.system()=='Windows':
|
||||
print >> sys.stderr, "Sorry, Windows platform is not supported!"
|
||||
sys.exit()
|
||||
@@ -165,49 +174,50 @@
|
||||
|
||||
|
||||
#================= pysam samtools ====================
|
||||
- extensions.append(Extension(
|
||||
- "pysam.csamtools",
|
||||
- csamtools_sources + [ "lib/pysam/%s" % x for x in ("pysam_util.c", )] +\
|
||||
- glob.glob( os.path.join( "lib/samtools", "*.pysam.c" )) +\
|
||||
- os_c_files + \
|
||||
- glob.glob( os.path.join( "lib/samtools", "*", "*.pysam.c" ) ),
|
||||
- library_dirs=[],
|
||||
- include_dirs=[ "lib/samtools", "lib/pysam" ] + include_os,
|
||||
- libraries=[ "z", ],
|
||||
- language="c",
|
||||
- define_macros = [('_FILE_OFFSET_BITS','64'),('_USE_KNETFILE','')],
|
||||
- ))
|
||||
-
|
||||
- extensions.append(Extension(
|
||||
- "pysam.ctabix",
|
||||
- tabix_sources + [ "lib/pysam/%s" % x for x in ( "tabix_util.c", )] +\
|
||||
- os_c_files + \
|
||||
- glob.glob( os.path.join( "lib/tabix", "*.pysam.c" ) ),
|
||||
- library_dirs=[],
|
||||
- include_dirs=[ "lib/tabix", "lib/pysam" ] + include_os,
|
||||
- libraries=[ "z", ],
|
||||
- language="c",
|
||||
- define_macros = [('_FILE_OFFSET_BITS','64'),
|
||||
- ('_USE_KNETFILE','')],
|
||||
- ))
|
||||
-
|
||||
- extensions.append(Extension(
|
||||
- "pysam.TabProxies",
|
||||
- tabproxies_sources + os_c_files,
|
||||
- library_dirs=[],
|
||||
- include_dirs= include_os,
|
||||
- libraries=[ "z", ],
|
||||
- language="c",
|
||||
- ))
|
||||
-
|
||||
- extensions.append(Extension(
|
||||
- "pysam.cvcf",
|
||||
- cvcf_sources + os_c_files,
|
||||
- library_dirs=[],
|
||||
- include_dirs= ["lib/tabix",] + include_os,
|
||||
- libraries=[ "z", ],
|
||||
- language="c",
|
||||
- ))
|
||||
+ if not have_pysam:
|
||||
+ extensions.append(Extension(
|
||||
+ "pysam.csamtools",
|
||||
+ csamtools_sources + [ "lib/pysam/%s" % x for x in ("pysam_util.c", )] +\
|
||||
+ glob.glob( os.path.join( "lib/samtools", "*.pysam.c" )) +\
|
||||
+ os_c_files + \
|
||||
+ glob.glob( os.path.join( "lib/samtools", "*", "*.pysam.c" ) ),
|
||||
+ library_dirs=[],
|
||||
+ include_dirs=[ "lib/samtools", "lib/pysam" ] + include_os,
|
||||
+ libraries=[ "z", ],
|
||||
+ language="c",
|
||||
+ define_macros = [('_FILE_OFFSET_BITS','64'),('_USE_KNETFILE','')],
|
||||
+ ))
|
||||
+
|
||||
+ extensions.append(Extension(
|
||||
+ "pysam.ctabix",
|
||||
+ tabix_sources + [ "lib/pysam/%s" % x for x in ( "tabix_util.c", )] +\
|
||||
+ os_c_files + \
|
||||
+ glob.glob( os.path.join( "lib/tabix", "*.pysam.c" ) ),
|
||||
+ library_dirs=[],
|
||||
+ include_dirs=[ "lib/tabix", "lib/pysam" ] + include_os,
|
||||
+ libraries=[ "z", ],
|
||||
+ language="c",
|
||||
+ define_macros = [('_FILE_OFFSET_BITS','64'),
|
||||
+ ('_USE_KNETFILE','')],
|
||||
+ ))
|
||||
+
|
||||
+ extensions.append(Extension(
|
||||
+ "pysam.TabProxies",
|
||||
+ tabproxies_sources + os_c_files,
|
||||
+ library_dirs=[],
|
||||
+ include_dirs= include_os,
|
||||
+ libraries=[ "z", ],
|
||||
+ language="c",
|
||||
+ ))
|
||||
+
|
||||
+ extensions.append(Extension(
|
||||
+ "pysam.cvcf",
|
||||
+ cvcf_sources + os_c_files,
|
||||
+ library_dirs=[],
|
||||
+ include_dirs= ["lib/tabix",] + include_os,
|
||||
+ libraries=[ "z", ],
|
||||
+ language="c",
|
||||
+ ))
|
||||
|
||||
|
||||
return extensions
|
Loading…
Reference in a new issue