mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: libmemcached: Fix build.
* gnu/packages/databases.scm (libmemcached)[source]: Add patch. * gnu/packages/patches/libmemcached-build-with-gcc7.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
973218a374
commit
737a3c12cd
3 changed files with 32 additions and 1 deletions
|
@ -1165,6 +1165,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/mcrypt-CVE-2012-4409.patch \
|
||||
%D%/packages/patches/mcrypt-CVE-2012-4426.patch \
|
||||
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \
|
||||
%D%/packages/patches/libmemcached-build-with-gcc7.patch \
|
||||
%D%/packages/patches/mes-remove-store-name.patch \
|
||||
%D%/packages/patches/mesa-skip-disk-cache-test.patch \
|
||||
%D%/packages/patches/mescc-tools-boot.patch \
|
||||
|
|
|
@ -370,7 +370,9 @@ (define-public libmemcached
|
|||
(file-name (string-append name "-" version "-checkout"))
|
||||
(sha256
|
||||
(base32
|
||||
"1842s4dxdh21gdr46q4dgxigidcs6dkqnbnqjwb9l8r0bqx5nb10"))))
|
||||
"1842s4dxdh21gdr46q4dgxigidcs6dkqnbnqjwb9l8r0bqx5nb10"))
|
||||
(patches
|
||||
(search-patches "libmemcached-build-with-gcc7.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("memcached" ,memcached)
|
||||
|
|
28
gnu/packages/patches/libmemcached-build-with-gcc7.patch
Normal file
28
gnu/packages/patches/libmemcached-build-with-gcc7.patch
Normal file
|
@ -0,0 +1,28 @@
|
|||
Author: Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
Date: Wed 22 Jan 22:58:13 CET 2020
|
||||
Subject: gnu: memcached: Fix build with GCC 7.
|
||||
|
||||
Taken verbating from this bug report:
|
||||
<https://bugs.launchpad.net/libmemcached/+bug/1663985>.
|
||||
|
||||
diff -up ./clients/memflush.cc.old ./clients/memflush.cc
|
||||
--- ./clients/memflush.cc.old 2017-02-12 10:12:59.615209225 +0100
|
||||
+++ ./clients/memflush.cc 2017-02-12 10:13:39.998382783 +0100
|
||||
@@ -39,7 +39,7 @@ int main(int argc, char *argv[])
|
||||
{
|
||||
options_parse(argc, argv);
|
||||
|
||||
- if (opt_servers == false)
|
||||
+ if (!opt_servers)
|
||||
{
|
||||
char *temp;
|
||||
|
||||
@@ -48,7 +48,7 @@ int main(int argc, char *argv[])
|
||||
opt_servers= strdup(temp);
|
||||
}
|
||||
|
||||
- if (opt_servers == false)
|
||||
+ if (!opt_servers)
|
||||
{
|
||||
std::cerr << "No Servers provided" << std::endl;
|
||||
exit(EXIT_FAILURE);
|
Loading…
Reference in a new issue