gnu: librewolf: Add rdd paths allowlist patch.

* gnu/packages/patches/librewolf-add-paths-to-rdd-allowlist.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it here.

Change-Id: Ice417148b0ddf9acf0062eb6d16a875a81e350e6
This commit is contained in:
Andrew Tropin 2024-09-24 12:24:33 +04:00
parent 8888f930ad
commit 75824be1ac
No known key found for this signature in database
GPG key ID: 2208D20958C1DEB0
2 changed files with 12 additions and 0 deletions

View file

@ -1687,6 +1687,7 @@ dist_patch_DATA = \
%D%/packages/patches/libphonenumber-reproducible-build.patch \ %D%/packages/patches/libphonenumber-reproducible-build.patch \
%D%/packages/patches/libqalculate-3.8.0-libcurl-ssl-fix.patch \ %D%/packages/patches/libqalculate-3.8.0-libcurl-ssl-fix.patch \
%D%/packages/patches/libquicktime-ffmpeg.patch \ %D%/packages/patches/libquicktime-ffmpeg.patch \
%D%/packages/patches/librewolf-add-paths-to-rdd-allowlist.patch \
%D%/packages/patches/libsepol-versioned-docbook.patch \ %D%/packages/patches/libsepol-versioned-docbook.patch \
%D%/packages/patches/libtar-CVE-2013-4420.patch \ %D%/packages/patches/libtar-CVE-2013-4420.patch \
%D%/packages/patches/libtgvoip-disable-sse2.patch \ %D%/packages/patches/libtgvoip-disable-sse2.patch \

View file

@ -0,0 +1,11 @@
--- a/security/sandbox/linux/broker/SandboxBrokerPolicyFactory.cpp
+++ b/security/sandbox/linux/broker/SandboxBrokerPolicyFactory.cpp
@@ -920,6 +920,8 @@
policy->AddDir(rdonly, "/usr/lib64");
policy->AddDir(rdonly, "/run/opengl-driver/lib");
policy->AddDir(rdonly, "/nix/store");
+ policy->AddDir(rdonly, "/gnu/store");
+ policy->AddDir(rdonly, "/run/current-system/profile/lib");
// Bug 1647957: memory reporting.
AddMemoryReporting(policy.get(), aPid);