mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: e2fsprogs: Update to 1.44.3.
* gnu/packages/linux.scm (e2fsprogs): Update to 1.44.3. [source]: Remove glibc-2.27 patch. (extundelete)[source]: Apply e2fsprogs-1.44 patch. * gnu/packages/patches/e2fsprogs-glibc-2.27.patch: Delete file... * gnu/local.mk (dist_patch_DATA): ...remove it, and add... * gnu/packages/patches/extundelete-e2fsprogs-1.44.patch: ...this new file.
This commit is contained in:
parent
1d9b96c08f
commit
76c888cb94
4 changed files with 36 additions and 68 deletions
|
@ -650,7 +650,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/doxygen-gcc-ice.patch \
|
||||
%D%/packages/patches/doxygen-test.patch \
|
||||
%D%/packages/patches/dvd+rw-tools-add-include.patch \
|
||||
%D%/packages/patches/e2fsprogs-glibc-2.27.patch \
|
||||
%D%/packages/patches/eigen-arm-neon-fixes.patch \
|
||||
%D%/packages/patches/elfutils-tests-ptrace.patch \
|
||||
%D%/packages/patches/elogind-glibc-2.27.patch \
|
||||
|
@ -668,6 +667,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/evilwm-lost-focus-bug.patch \
|
||||
%D%/packages/patches/exiv2-CVE-2017-14860.patch \
|
||||
%D%/packages/patches/exiv2-CVE-2017-14859-14862-14864.patch \
|
||||
%D%/packages/patches/extundelete-e2fsprogs-1.44.patch \
|
||||
%D%/packages/patches/fastcap-mulGlobal.patch \
|
||||
%D%/packages/patches/fastcap-mulSetup.patch \
|
||||
%D%/packages/patches/fasthenry-spAllocate.patch \
|
||||
|
|
|
@ -738,7 +738,7 @@ (define-public usbutils
|
|||
(define-public e2fsprogs
|
||||
(package
|
||||
(name "e2fsprogs")
|
||||
(version "1.43.6")
|
||||
(version "1.44.3")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -747,8 +747,7 @@ (define-public e2fsprogs
|
|||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"00ilv65dzcgiap435j89xk86shf7rrav3wsik7cahy789qijdcn9"))
|
||||
(patches (search-patches "e2fsprogs-glibc-2.27.patch"))))
|
||||
"1djb9qnid1j0vvna2bhq4jsz2ig1xckbx7h4d86cr0gl61yrz2ax"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("util-linux" ,util-linux)))
|
||||
(native-inputs `(("pkg-config" ,pkg-config)
|
||||
|
@ -862,14 +861,16 @@ (define-public extundelete
|
|||
(package
|
||||
(name "extundelete")
|
||||
(version "0.2.4")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/extundelete/"
|
||||
"extundelete/" version "/extundelete-"
|
||||
version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1x0r7ylxlp9lbj3d7sqf6j2a222dwy2nfpff05jd6mkh4ihxvyd1"))))
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/extundelete/"
|
||||
"extundelete/" version "/extundelete-"
|
||||
version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1x0r7ylxlp9lbj3d7sqf6j2a222dwy2nfpff05jd6mkh4ihxvyd1"))
|
||||
(patches (search-patches "extundelete-e2fsprogs-1.44.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("e2fsprogs" ,e2fsprogs)))
|
||||
(home-page "http://extundelete.sourceforge.net/")
|
||||
|
|
|
@ -1,56 +0,0 @@
|
|||
Copied from:
|
||||
https://github.com/openwrt/openwrt/blob/58a95f0f8ff768b43d68eed2b6a786e0f40f723b/tools/e2fsprogs/patches/005-misc-rename-copy_file_range-to-copy_file_chunk.patch
|
||||
|
||||
From 01551bdba16ab16512a01affe02ade32c41ede8a Mon Sep 17 00:00:00 2001
|
||||
From: Palmer Dabbelt <palmer@dabbelt.com>
|
||||
Date: Fri, 29 Dec 2017 10:19:51 -0800
|
||||
Subject: [PATCH] misc: rename copy_file_range to copy_file_chunk
|
||||
|
||||
As of 2.27, glibc will have a copy_file_range library call to wrap the
|
||||
new copy_file_range system call. This conflicts with the function in
|
||||
misc/create_inode.c, which this patch renames _copy_file_range.
|
||||
|
||||
Signed-off-by: Palmer Dabbelt <palmer@dabbelt.com>
|
||||
Signed-off-by: Theodore Ts'o <tytso@mit.edu>
|
||||
---
|
||||
misc/create_inode.c | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
--- a/misc/create_inode.c
|
||||
+++ b/misc/create_inode.c
|
||||
@@ -392,7 +392,7 @@ static ssize_t my_pread(int fd, void *bu
|
||||
}
|
||||
#endif /* !defined HAVE_PREAD64 && !defined HAVE_PREAD */
|
||||
|
||||
-static errcode_t copy_file_range(ext2_filsys fs, int fd, ext2_file_t e2_file,
|
||||
+static errcode_t copy_file_chunk(ext2_filsys fs, int fd, ext2_file_t e2_file,
|
||||
off_t start, off_t end, char *buf,
|
||||
char *zerobuf)
|
||||
{
|
||||
@@ -466,7 +466,7 @@ static errcode_t try_lseek_copy(ext2_fil
|
||||
|
||||
data_blk = data & ~(fs->blocksize - 1);
|
||||
hole_blk = (hole + (fs->blocksize - 1)) & ~(fs->blocksize - 1);
|
||||
- err = copy_file_range(fs, fd, e2_file, data_blk, hole_blk, buf,
|
||||
+ err = copy_file_chunk(fs, fd, e2_file, data_blk, hole_blk, buf,
|
||||
zerobuf);
|
||||
if (err)
|
||||
return err;
|
||||
@@ -516,7 +516,7 @@ static errcode_t try_fiemap_copy(ext2_fi
|
||||
}
|
||||
for (i = 0, ext = ext_buf; i < fiemap_buf->fm_mapped_extents;
|
||||
i++, ext++) {
|
||||
- err = copy_file_range(fs, fd, e2_file, ext->fe_logical,
|
||||
+ err = copy_file_chunk(fs, fd, e2_file, ext->fe_logical,
|
||||
ext->fe_logical + ext->fe_length,
|
||||
buf, zerobuf);
|
||||
if (err)
|
||||
@@ -569,7 +569,7 @@ static errcode_t copy_file(ext2_filsys f
|
||||
goto out;
|
||||
#endif
|
||||
|
||||
- err = copy_file_range(fs, fd, e2_file, 0, statbuf->st_size, buf,
|
||||
+ err = copy_file_chunk(fs, fd, e2_file, 0, statbuf->st_size, buf,
|
||||
zerobuf);
|
||||
out:
|
||||
ext2fs_free_mem(&zerobuf);
|
23
gnu/packages/patches/extundelete-e2fsprogs-1.44.patch
Normal file
23
gnu/packages/patches/extundelete-e2fsprogs-1.44.patch
Normal file
|
@ -0,0 +1,23 @@
|
|||
From: Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
Date: Thu, 16 Aug 2018 21:12:30 +0200
|
||||
Subject: extundelete: Fix build with e2fsprogs 1.44.
|
||||
|
||||
The ‘inode.i_file_acl’ field was replaced with ‘inode.i_size_high’. I'm
|
||||
not sure the field name is still accurate or useful, so don't print it
|
||||
at all.
|
||||
|
||||
Based on this[0] patch by ‘conikost’[1].
|
||||
|
||||
[0]: https://sourceforge.net/p/extundelete/tickets/5/
|
||||
[1]: https://sourceforge.net/u/conikost
|
||||
|
||||
--- a/src/insertionops.cc 2012-12-30 18:23:32.000000000 +0100
|
||||
+++ b/src/insertionops.cc 2018-05-07 22:58:13.065868723 +0200
|
||||
@@ -33,7 +33,6 @@
|
||||
os << "File flags: " << inode.i_flags << std::endl;
|
||||
os << "File version (for NFS): " << inode.i_generation << std::endl;
|
||||
os << "File ACL: " << inode.i_file_acl << std::endl;
|
||||
- os << "Directory ACL: " << inode.i_dir_acl << std::endl;
|
||||
os << "Fragment address: " << inode.i_faddr << std::endl;
|
||||
os << "Direct blocks: ";
|
||||
for (int n = 0; n < EXT2_NDIR_BLOCKS; n++)
|
Loading…
Reference in a new issue