mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: perl-net-ssleay: Update to 1.81.
* gnu/packages/tls.scm (perl-net-ssleay): Update to 1.81. [native-inputs]: Remove 'perl-net-ssleay-disable-ede-test.patch'. [arguments]: Remove 'apply-patch' phase. * gnu/packages/patches/perl-net-ssleay-disable-ede-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
503c8c5882
commit
76cb906083
3 changed files with 2 additions and 39 deletions
|
@ -868,7 +868,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/perl-gd-options-passthrough-and-fontconfig.patch \
|
||||
%D%/packages/patches/perl-io-socket-ssl-openssl-1.0.2f-fix.patch \
|
||||
%D%/packages/patches/perl-net-amazon-s3-moose-warning.patch \
|
||||
%D%/packages/patches/perl-net-ssleay-disable-ede-test.patch \
|
||||
%D%/packages/patches/perl-net-dns-resolver-programmable-fix.patch \
|
||||
%D%/packages/patches/perl-no-sys-dirs.patch \
|
||||
%D%/packages/patches/perl-module-pluggable-search.patch \
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
Disable a test that fails with openssl-1.0.2b.
|
||||
|
||||
--- Net-SSLeay-1.68/t/local/33_x509_create_cert.t.orig 2014-06-07 02:01:39.000000000 -0400
|
||||
+++ Net-SSLeay-1.68/t/local/33_x509_create_cert.t 2015-06-12 03:38:57.620286888 -0400
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
use strict;
|
||||
use warnings;
|
||||
-use Test::More tests => 123;
|
||||
+use Test::More tests => 122;
|
||||
use Net::SSLeay qw/MBSTRING_ASC MBSTRING_UTF8 EVP_PK_RSA EVP_PKT_SIGN EVP_PKT_ENC/;
|
||||
use File::Spec;
|
||||
use utf8;
|
||||
@@ -101,7 +101,8 @@
|
||||
like(my $key_pem3 = Net::SSLeay::PEM_get_string_PrivateKey($pk,"password",$alg1), qr/-----BEGIN (ENCRYPTED|RSA) PRIVATE KEY-----/, "PEM_get_string_PrivateKey+passwd+enc_alg");
|
||||
|
||||
ok(my $alg2 = Net::SSLeay::EVP_get_cipherbyname("DES-EDE3-OFB"), "EVP_get_cipherbyname");
|
||||
- like(my $key_pem4 = Net::SSLeay::PEM_get_string_PrivateKey($pk,"password",$alg2), qr/-----BEGIN (ENCRYPTED|RSA) PRIVATE KEY-----/, "PEM_get_string_PrivateKey+passwd+enc_alg");
|
||||
+ # This test fails with openssl-1.0.2b
|
||||
+ #like(my $key_pem4 = Net::SSLeay::PEM_get_string_PrivateKey($pk,"password",$alg2), qr/-----BEGIN (ENCRYPTED|RSA) PRIVATE KEY-----/, "PEM_get_string_PrivateKey+passwd+enc_alg");
|
||||
|
||||
is(Net::SSLeay::X509_NAME_print_ex($name), "O=Company Name,C=UK,CN=Common name text X509", "X509_NAME_print_ex");
|
||||
|
|
@ -587,32 +587,19 @@ (define-public letsencrypt
|
|||
(define-public perl-net-ssleay
|
||||
(package
|
||||
(name "perl-net-ssleay")
|
||||
(version "1.68")
|
||||
(version "1.81")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://cpan/authors/id/M/MI/MIKEM/"
|
||||
"Net-SSLeay-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1m2wwzhjwsg0drlhp9w12fl6bsgj69v8gdz72jqrqll3qr7f408p"))))
|
||||
"0z8vya34g88bc41kx955sv7y4niwbbywji8liqbl52v29qbvdjq0"))))
|
||||
(build-system perl-build-system)
|
||||
(native-inputs
|
||||
`(("patch" ,patch)
|
||||
("patch/disable-ede-test"
|
||||
,(search-patch "perl-net-ssleay-disable-ede-test.patch"))))
|
||||
(inputs `(("openssl" ,openssl)))
|
||||
(arguments
|
||||
`(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after
|
||||
'unpack 'apply-patch
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
;; XXX We apply this patch here instead of in the 'origin' because
|
||||
;; this package's build system fails badly when the source file
|
||||
;; times are zeroed.
|
||||
;; XXX Try removing this patch for perl-net-ssleay > 1.68
|
||||
(zero? (system* "patch" "--force" "-p1" "-i"
|
||||
(assoc-ref inputs "patch/disable-ede-test")))))
|
||||
(add-before
|
||||
'configure 'set-ssl-prefix
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
|
|
Loading…
Reference in a new issue