mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 22:08:16 -05:00
gnu: wicd: Fix curses client to work with urwid 1.3.
* gnu/packages/patches/wicd-urwid-1.3.patch: New file. * gnu-system (dist_patch_DATA): Add it. * gnu/packages/wicd.scm (wicd): Add patch.
This commit is contained in:
parent
b7921ba5a7
commit
7747c4ca3d
3 changed files with 22 additions and 1 deletions
|
@ -496,6 +496,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/vpnc-script.patch \
|
gnu/packages/patches/vpnc-script.patch \
|
||||||
gnu/packages/patches/vtk-mesa-10.patch \
|
gnu/packages/patches/vtk-mesa-10.patch \
|
||||||
gnu/packages/patches/w3m-fix-compile.patch \
|
gnu/packages/patches/w3m-fix-compile.patch \
|
||||||
|
gnu/packages/patches/wicd-urwid-1.3.patch \
|
||||||
gnu/packages/patches/wmctrl-64-fix.patch \
|
gnu/packages/patches/wmctrl-64-fix.patch \
|
||||||
gnu/packages/patches/xf86-video-ark-remove-mibstore.patch \
|
gnu/packages/patches/xf86-video-ark-remove-mibstore.patch \
|
||||||
gnu/packages/patches/xf86-video-ast-remove-mibstore.patch \
|
gnu/packages/patches/xf86-video-ast-remove-mibstore.patch \
|
||||||
|
|
18
gnu/packages/patches/wicd-urwid-1.3.patch
Normal file
18
gnu/packages/patches/wicd-urwid-1.3.patch
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
Update the wicd-curses client to work with urwid-1.3. Based on a patch from:
|
||||||
|
http://technik.blogbasis.net/wicd-curses-fix-fuer-attributeerror-screen-object-no-attribute-get_input_nonblocking-04-12-2014
|
||||||
|
|
||||||
|
--- wicd-1.7.3/curses/wicd-curses.py.orig 2014-12-21 14:40:46.000000000 -0500
|
||||||
|
+++ wicd-1.7.3/curses/wicd-curses.py 2015-02-05 23:41:17.530901204 -0500
|
||||||
|
@@ -1153,9 +1153,10 @@
|
||||||
|
if not ui._started:
|
||||||
|
return False
|
||||||
|
|
||||||
|
- input_data = ui.get_input_nonblocking()
|
||||||
|
+ ui.set_input_timeouts(max_wait=0)
|
||||||
|
+ input_data = ui.get_input()
|
||||||
|
# Resolve any "alarms" in the waiting
|
||||||
|
- self.handle_keys(input_data[1])
|
||||||
|
+ self.handle_keys(input_data)
|
||||||
|
|
||||||
|
# Update the screen
|
||||||
|
canvas = self.frame.render((self.size), True)
|
|
@ -23,6 +23,7 @@ (define-module (gnu packages wicd)
|
||||||
#:use-module (guix build-system python)
|
#:use-module (guix build-system python)
|
||||||
#:use-module (guix licenses)
|
#:use-module (guix licenses)
|
||||||
#:use-module (guix utils)
|
#:use-module (guix utils)
|
||||||
|
#:use-module (gnu packages)
|
||||||
#:use-module (gnu packages glib)
|
#:use-module (gnu packages glib)
|
||||||
#:use-module (gnu packages gtk)
|
#:use-module (gnu packages gtk)
|
||||||
#:use-module (gnu packages gnome)
|
#:use-module (gnu packages gnome)
|
||||||
|
@ -42,7 +43,8 @@ (define-public wicd
|
||||||
(version-major+minor version) "/" version
|
(version-major+minor version) "/" version
|
||||||
"/+download/wicd-" version ".tar.gz"))
|
"/+download/wicd-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "00c4rq753bhg64rv1v9yl834ssq7igyy7cz3swp287b5n5bqiqwi"))))
|
(base32 "00c4rq753bhg64rv1v9yl834ssq7igyy7cz3swp287b5n5bqiqwi"))
|
||||||
|
(patches (list (search-patch "wicd-urwid-1.3.patch")))))
|
||||||
(build-system python-build-system)
|
(build-system python-build-system)
|
||||||
(native-inputs `(("gettext" ,gnu-gettext)))
|
(native-inputs `(("gettext" ,gnu-gettext)))
|
||||||
(inputs `(("dbus" ,dbus)
|
(inputs `(("dbus" ,dbus)
|
||||||
|
|
Loading…
Reference in a new issue