gnu: flatpak: Update to 1.14.10 [security fixes].

Fixes CVE-2024-42472.
Fixes <https://issues.guix.gnu.org/73059>.

* gnu/packages/package-management.scm (flatpak): Update to 1.14.10.
* gnu/packages/patches/flatpak-unset-gdk-pixbuf-for-sandbox.patch: Adjust it.

Change-Id: Ia0bd866ee46e8b0cd24d37d14df61cdc22692d4e
This commit is contained in:
Zheng Junjie 2024-09-06 10:28:05 +08:00
parent fc20559209
commit 776334bfdb
No known key found for this signature in database
GPG key ID: 3B5AA993E1A2DFF0
2 changed files with 5 additions and 7 deletions

View file

@ -2036,14 +2036,14 @@ (define-public libostree
(define-public flatpak
(package
(name "flatpak")
(version "1.14.6")
(version "1.14.10")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/flatpak/flatpak/releases/download/"
version "/flatpak-" version ".tar.xz"))
(sha256
(base32 "0ij93vl9skcfdfgkmgd80q0q4c6q39dss4rds7phxizqqsr3d3sk"))
(base32 "1k91v0csghiis8gjpcvpx534qbyaj81dfisabbc0ld97h68cggbb"))
(patches
(search-patches "flatpak-fix-fonts-icons.patch"
"flatpak-fix-path.patch"

View file

@ -9,13 +9,11 @@ of host system.
--- a/common/flatpak-run.c
+++ b/common/flatpak-run.c
@@ -1900,8 +1900,9 @@ static const ExportData default_exports[] = {
@@ -1900,6 +1900,7 @@ static const ExportData default_exports[] = {
{"XKB_CONFIG_ROOT", NULL},
{"GIO_EXTRA_MODULES", NULL},
{"GDK_BACKEND", NULL},
+ {"GDK_PIXBUF_MODULE_FILE", NULL},
{"VK_ADD_DRIVER_FILES", NULL},
{"VK_ADD_LAYER_PATH", NULL},
{"VK_DRIVER_FILES", NULL},
{"VK_ICD_FILENAMES", NULL},
};
static const ExportData no_ld_so_cache_exports[] = {