mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 05:18:07 -05:00
gnu: librecad: Fix build with boost 1.76.
Fixes <https://issues.guix.gnu.org/53694>. * gnu/packages/patches/librecad-support-for-boost-1.76.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/engineering.scm (librecad)[source]: Use it.
This commit is contained in:
parent
f07459ea05
commit
787b13a5d9
3 changed files with 21 additions and 1 deletions
|
@ -1408,6 +1408,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libmygpo-qt-missing-qt5-modules.patch \
|
||||
%D%/packages/patches/libqalculate-3.8.0-libcurl-ssl-fix.patch \
|
||||
%D%/packages/patches/libquicktime-ffmpeg.patch \
|
||||
%D%/packages/patches/librecad-support-for-boost-1.76.patch \
|
||||
%D%/packages/patches/libssh2-CVE-2019-17498.patch \
|
||||
%D%/packages/patches/libtar-CVE-2013-4420.patch \
|
||||
%D%/packages/patches/libtgvoip-disable-sse2.patch \
|
||||
|
|
|
@ -147,7 +147,9 @@ (define-public librecad
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"08cl4935c9vznz9qdw1zgd86rn7hl64zpfayxl07x21bhf53pn24"))))
|
||||
"08cl4935c9vznz9qdw1zgd86rn7hl64zpfayxl07x21bhf53pn24"))
|
||||
(patches
|
||||
(search-patches "librecad-support-for-boost-1.76.patch"))))
|
||||
(build-system qt-build-system)
|
||||
(arguments
|
||||
'(#:test-target "check"
|
||||
|
|
17
gnu/packages/patches/librecad-support-for-boost-1.76.patch
Normal file
17
gnu/packages/patches/librecad-support-for-boost-1.76.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
Upstream commit e02f3580311d50b617427652ff77988f6bd62d9d adding Boost 1.76
|
||||
compatibility.
|
||||
|
||||
diff --git a/librecad/src/lib/engine/rs_ellipse.cpp b/librecad/src/lib/engine/rs_ellipse.cpp
|
||||
index 291f734ea..d47bf6ca4 100644
|
||||
--- a/librecad/src/lib/engine/rs_ellipse.cpp
|
||||
+++ b/librecad/src/lib/engine/rs_ellipse.cpp
|
||||
@@ -48,6 +48,9 @@
|
||||
#include <boost/version.hpp>
|
||||
#include <boost/math/tools/roots.hpp>
|
||||
#include <boost/math/special_functions/ellint_2.hpp>
|
||||
+#if BOOST_VERSION > 104500
|
||||
+#include <boost/math/tools/tuple.hpp>
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
namespace{
|
Loading…
Reference in a new issue