mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 21:38:07 -05:00
gnu: freecad: Add patch for vtk 9.3.0.
* gnu/packages/patches/freecad-vtk-9.3.patch: New file. * gnu/local.mk (dist_patch_DATA): Register file. * gnu/packages/engineering.scm (freecad)[source]: Add patch. Change-Id: Ie520a92ffe6f8bdd2678470ee06f618d74349460 Signed-off-by: Andreas Enge <andreas@enge.fr>
This commit is contained in:
parent
79408989ff
commit
78b881722f
3 changed files with 47 additions and 1 deletions
|
@ -1241,6 +1241,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/fpc-reproducibility.patch \
|
||||
%D%/packages/patches/fpc-glibc-2.34-compat.patch \
|
||||
%D%/packages/patches/fpm-newer-clamp-fix.patch \
|
||||
%D%/packages/patches/freecad-vtk-9.3.patch \
|
||||
%D%/packages/patches/freedink-engine-fix-sdl-hints.patch \
|
||||
%D%/packages/patches/freeimage-libtiff-compat.patch \
|
||||
%D%/packages/patches/freeimage-unbundle.patch \
|
||||
|
|
|
@ -2783,7 +2783,9 @@ (define-public freecad
|
|||
(commit version)))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "0s720q6vxlh78jzahqp69nl8wagb42l05dym5aqhfnr31dx666hc"))))
|
||||
(base32 "0s720q6vxlh78jzahqp69nl8wagb42l05dym5aqhfnr31dx666hc"))
|
||||
;; https://github.com/FreeCAD/FreeCAD/pull/11496
|
||||
(patches (search-patches "freecad-vtk-9.3.patch"))))
|
||||
(build-system qt-build-system)
|
||||
(native-inputs
|
||||
(list doxygen
|
||||
|
|
43
gnu/packages/patches/freecad-vtk-9.3.patch
Normal file
43
gnu/packages/patches/freecad-vtk-9.3.patch
Normal file
|
@ -0,0 +1,43 @@
|
|||
From d0fb2b8b29fe0428d9dd8aa790b0d6e45c8a9516 Mon Sep 17 00:00:00 2001
|
||||
From: Adrian Insaurralde Avalos <adrianinsaval@gmail.com>
|
||||
Date: Wed, 22 Nov 2023 16:42:06 -0300
|
||||
Subject: [PATCH] 3rdPart/salomesmesh - fix for vtk 9.3 compatibility
|
||||
|
||||
minimum required version is 7.1
|
||||
---
|
||||
src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx | 4 ----
|
||||
src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp | 5 +++++
|
||||
2 files changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx b/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx
|
||||
index 7f89573efd0d..47a52fe585fe 100644
|
||||
--- a/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx
|
||||
+++ b/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx
|
||||
@@ -39,10 +39,6 @@
|
||||
#define SMDS_EXPORT
|
||||
#endif
|
||||
|
||||
-#ifdef VTK_HAS_MTIME_TYPE
|
||||
#define VTK_MTIME_TYPE vtkMTimeType
|
||||
-#else
|
||||
-#define VTK_MTIME_TYPE unsigned long
|
||||
-#endif
|
||||
|
||||
#endif
|
||||
diff --git a/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp b/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp
|
||||
index 7e3de0070a02..e9895d615717 100644
|
||||
--- a/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp
|
||||
+++ b/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp
|
||||
@@ -1026,7 +1026,12 @@ void SMDS_UnstructuredGrid::BuildLinks()
|
||||
GetLinks()->Allocate(this->GetNumberOfPoints());
|
||||
GetLinks()->Register(this);
|
||||
//FIXME: vtk9
|
||||
+ #if VTK_VERSION_NUMBER < VTK_VERSION_CHECK(9,3,0)
|
||||
GetLinks()->BuildLinks(this);
|
||||
+ #else
|
||||
+ GetLinks()->SetDataSet(this);
|
||||
+ GetLinks()->BuildLinks();
|
||||
+ #endif
|
||||
GetLinks()->Delete();
|
||||
#else
|
||||
this->Links = SMDS_CellLinks::New();
|
Loading…
Reference in a new issue