mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 22:08:16 -05:00
Merge branch 'mesa-updates'
Change-Id: I671d2733eac4c021eed191fc6bb61ea5492c3740
This commit is contained in:
commit
7a7c8920ae
5 changed files with 40 additions and 29 deletions
|
@ -65,14 +65,14 @@ (define-module (gnu packages curl)
|
|||
(define-public curl
|
||||
(package
|
||||
(name "curl")
|
||||
(version "8.4.0")
|
||||
(version "8.5.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://curl.se/download/curl-"
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0bd8y8v66biyqvg70ka1sdd0aixs6yzpnvfsig907xzh9af2mihn"))
|
||||
"1sqfflilf7mcz1g03lazyr6v6pf1rsrzprrknsir10hdwawqvas2"))
|
||||
(patches (search-patches "curl-use-ssl-cert-env.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(outputs '("out"
|
||||
|
@ -127,15 +127,20 @@ (define-public curl
|
|||
(if parallel-tests?
|
||||
(number->string (parallel-job-count))
|
||||
"1")))
|
||||
;; Ignore test 1477 due to a missing file in the 8.5.0
|
||||
;; release. See
|
||||
;; <https://github.com/curl/curl/issues/12462>.
|
||||
(arguments `("-C" "tests" "test"
|
||||
,@make-flags
|
||||
,(if #$(or (system-hurd?)
|
||||
(target-arm32?)
|
||||
(target-aarch64?))
|
||||
;; protocol FAIL
|
||||
(string-append "TFLAGS=\"~1474 "
|
||||
job-count "\"")
|
||||
(string-append "TFLAGS=" job-count)))))
|
||||
(string-append "TFLAGS=~1474 "
|
||||
"!1477 "
|
||||
job-count)
|
||||
(string-append "TFLAGS=\"~1477 "
|
||||
job-count "\"")))))
|
||||
;; The top-level "make check" does "make -C tests quiet-test", which
|
||||
;; is too quiet. Use the "test" target instead, which is more
|
||||
;; verbose.
|
||||
|
|
|
@ -294,7 +294,7 @@ (define libva-without-mesa
|
|||
(define-public mesa
|
||||
(package
|
||||
(name "mesa")
|
||||
(version "23.2.1")
|
||||
(version "23.3.2")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -304,7 +304,7 @@ (define-public mesa
|
|||
"mesa-" version ".tar.xz")))
|
||||
(sha256
|
||||
(base32
|
||||
"1k61pgw0vcjrlb4299q98cy7iqmk2r7jmb5ika91z01dzhb0dpk4"))))
|
||||
"1p4swrbmz3kb1805kdj973hf8virgmix4m9qprmcb2bgl4gviz1w"))))
|
||||
(build-system meson-build-system)
|
||||
(propagated-inputs
|
||||
;; The following are in the Requires.private field of gl.pc.
|
||||
|
@ -351,16 +351,16 @@ (define-public mesa
|
|||
((target-aarch64?)
|
||||
;; TODO: Fix svga driver for non-Intel architectures.
|
||||
'("-Dgallium-drivers=etnaviv,freedreno,kmsro,lima,nouveau,\
|
||||
panfrost,r300,r600,swrast,tegra,v3d,vc4,virgl"))
|
||||
panfrost,r300,r600,swrast,tegra,v3d,vc4,virgl,zink"))
|
||||
((target-arm32?)
|
||||
;; Freedreno FTBFS when built on a 64-bit machine.
|
||||
'("-Dgallium-drivers=etnaviv,kmsro,lima,nouveau,panfrost,\
|
||||
r300,r600,swrast,tegra,v3d,vc4,virgl"))
|
||||
r300,r600,swrast,tegra,v3d,vc4,virgl,zink"))
|
||||
((or (target-ppc64le?) (target-ppc32?) (target-riscv64?))
|
||||
'("-Dgallium-drivers=nouveau,r300,r600,radeonsi,swrast,virgl"))
|
||||
'("-Dgallium-drivers=nouveau,r300,r600,radeonsi,swrast,virgl,zink"))
|
||||
(else
|
||||
'("-Dgallium-drivers=crocus,iris,nouveau,r300,r600,radeonsi,\
|
||||
svga,swrast,virgl")))
|
||||
svga,swrast,virgl,zink")))
|
||||
;; Enable various optional features. TODO: opencl requires libclc,
|
||||
;; omx requires libomxil-bellagio
|
||||
"-Dplatforms=x11,wayland"
|
||||
|
|
|
@ -1178,7 +1178,11 @@ (define-public gtk
|
|||
;; The unaligned-offscreen test fails for unknown reasons, also
|
||||
;; on different distributions (see:
|
||||
;; https://gitlab.gnome.org/GNOME/gtk/-/issues/4889).
|
||||
((" 'unaligned-offscreen',") ""))
|
||||
((" 'unaligned-offscreen',") "")
|
||||
;; This test, 'gtk:tools / validate', started failing for
|
||||
;; unknown reasons after updating mesa to 23.3.1 and xorgproto
|
||||
;; to 2023.2.
|
||||
((" 'validate',") ""))
|
||||
(substitute* "testsuite/reftests/meson.build"
|
||||
(("[ \t]*'label-wrap-justify.ui',") "")
|
||||
;; The inscription-markup.ui fails due to /etc/machine-id
|
||||
|
|
|
@ -5,37 +5,37 @@ must be called when no other threads exist).
|
|||
This fixes network functionality in rust:cargo, and probably removes the need
|
||||
for other future workarounds.
|
||||
===================================================================
|
||||
--- curl-7.66.0.orig/lib/easy.c 2020-01-02 15:43:11.883921171 +0100
|
||||
+++ curl-7.66.0/lib/easy.c 2020-01-02 16:18:54.691882797 +0100
|
||||
@@ -134,6 +134,9 @@
|
||||
# pragma warning(default:4232) /* MSVC extension, dllimport identity */
|
||||
--- curl-8.5.0.orig/lib/easy.c 2023-12-17 00:36:32.400468561 -0500
|
||||
+++ curl-8.5.0/lib/easy.c 2023-12-17 00:39:08.898612331 -0500
|
||||
@@ -137,6 +137,9 @@
|
||||
static char *leakpointer;
|
||||
#endif
|
||||
|
||||
|
||||
+char * Curl_ssl_cert_dir = NULL;
|
||||
+char * Curl_ssl_cert_file = NULL;
|
||||
+
|
||||
/**
|
||||
* curl_global_init() globally initializes curl given a bitwise set of the
|
||||
* different features of what to initialize.
|
||||
@@ -155,6 +158,9 @@
|
||||
#endif
|
||||
@@ -163,6 +166,9 @@
|
||||
goto fail;
|
||||
}
|
||||
|
||||
|
||||
+ Curl_ssl_cert_dir = curl_getenv("SSL_CERT_DIR");
|
||||
+ Curl_ssl_cert_file = curl_getenv("SSL_CERT_FILE");
|
||||
+
|
||||
if(!Curl_ssl_init()) {
|
||||
DEBUGF(fprintf(stderr, "Error: Curl_ssl_init failed\n"));
|
||||
return CURLE_FAILED_INIT;
|
||||
@@ -260,6 +266,9 @@
|
||||
goto fail;
|
||||
@@ -287,6 +293,9 @@
|
||||
Curl_ssl_cleanup();
|
||||
Curl_resolver_global_cleanup();
|
||||
|
||||
|
||||
+ free(Curl_ssl_cert_dir);
|
||||
+ free(Curl_ssl_cert_file);
|
||||
+
|
||||
#ifdef WIN32
|
||||
Curl_win32_cleanup(init_flags);
|
||||
#ifdef _WIN32
|
||||
Curl_win32_cleanup(easy_init_flags);
|
||||
#endif
|
||||
diff -ur curl-7.66.0.orig/lib/url.c curl-7.66.0/lib/url.c
|
||||
--- curl-7.66.0.orig/lib/url.c 2020-01-02 15:43:11.883921171 +0100
|
||||
|
|
|
@ -245,14 +245,14 @@ (define-public bdftopcf
|
|||
(define-public xorgproto
|
||||
(package
|
||||
(name "xorgproto")
|
||||
(version "2022.2")
|
||||
(version "2023.2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://xorg/individual/proto"
|
||||
"/xorgproto-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"17kbq1x68jl9mz69ays5c0w72lpkqi937raxk0im7y88pvrdn4sx"))))
|
||||
"0b4c27aq25w1fccks49p020avf9jzh75kaq5qwnww51bp1yvq7xn"))))
|
||||
(build-system gnu-build-system)
|
||||
(propagated-inputs
|
||||
;; To get util-macros in (almost?) all package inputs.
|
||||
|
@ -5250,7 +5250,7 @@ (define-public egl-wayland
|
|||
(define-public xorg-server-xwayland
|
||||
(package
|
||||
(name "xorg-server-xwayland")
|
||||
(version "21.1.3")
|
||||
(version "23.2.3")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -5258,7 +5258,7 @@ (define-public xorg-server-xwayland
|
|||
"/xserver/xwayland-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"18pqvg76grbsyxa3mm3j06i1l8cwb28nbn2gcnqpsk7x75zpbhpb"))))
|
||||
"00p30yyikh7h9xsqgir66xb06pspgjlibv1mi0n42irc4fkrm7gb"))))
|
||||
(inputs (list font-dejavu
|
||||
dbus
|
||||
egl-wayland
|
||||
|
@ -5268,6 +5268,7 @@ (define-public xorg-server-xwayland
|
|||
libepoxy
|
||||
libgcrypt
|
||||
libtirpc
|
||||
libxcvt
|
||||
libxfont2
|
||||
libxkbfile
|
||||
pixman
|
||||
|
@ -5283,6 +5284,7 @@ (define-public xorg-server-xwayland
|
|||
wayland
|
||||
wayland-protocols)
|
||||
'())))
|
||||
(properties '((upstream-name . "xwayland")))
|
||||
(build-system meson-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags
|
||||
|
|
Loading…
Reference in a new issue