mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: libetonyek: Update to 0.1.7.
* gnu/packages/libreoffice.scm (libetonyek): Update to 0.1.7. [source](patches): Remove. [arguments]<#:phases>: Remove. [native-inputs]: Remove AUTOCONF and AUTOMAKE. * gnu/packages/patches/libetonyek-build-with-mdds-1.2.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
074ff555ab
commit
7a9283a619
3 changed files with 4 additions and 97 deletions
|
@ -785,7 +785,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libcroco-CVE-2017-7960.patch \
|
||||
%D%/packages/patches/libcroco-CVE-2017-7961.patch \
|
||||
%D%/packages/patches/libdrm-symbol-check.patch \
|
||||
%D%/packages/patches/libetonyek-build-with-mdds-1.2.patch \
|
||||
%D%/packages/patches/libevent-dns-tests.patch \
|
||||
%D%/packages/patches/libevent-2.0-CVE-2016-10195.patch \
|
||||
%D%/packages/patches/libevent-2.0-CVE-2016-10196.patch \
|
||||
|
|
|
@ -357,33 +357,17 @@ (define-public libcdr
|
|||
(define-public libetonyek
|
||||
(package
|
||||
(name "libetonyek")
|
||||
(version "0.1.6")
|
||||
(version "0.1.7")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
|
||||
name "-" version ".tar.xz"))
|
||||
(sha256 (base32
|
||||
"0y60vi1plyq69fqbcjnc0v8mvcjqjsl1ry6rmb3bq3q7j8a2fm6z"))
|
||||
(patches
|
||||
(cons
|
||||
(origin
|
||||
(method url-fetch)
|
||||
;; Drop incorrect test that fails with latest liblangtag.
|
||||
(uri (string-append "https://cgit.freedesktop.org/libreoffice"
|
||||
"/libetonyek/patch/?id="
|
||||
"1a20d8ece2ea3e8aa1d319cd88e8a6aa637982f2"))
|
||||
(file-name "libetonyek-build-with-liblangtag-0.6.patch")
|
||||
(sha256
|
||||
(base32
|
||||
"0zdyykg3cmq226m54yjhg1fj5200c371h2qgjfna62dxa1jd6m97")))
|
||||
(search-patches "libetonyek-build-with-mdds-1.2.patch")))))
|
||||
"1b1lqy6g7flximlv0bp8jbsivyhdp679yj0d0q4jzm968h6y3nv9"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags '("--with-mdds=1.2")
|
||||
#:phases (modify-phases %standard-phases
|
||||
(add-after 'unpack 'autoreconf
|
||||
(lambda _ (system* "autoreconf"))))))
|
||||
`(#:configure-flags '("--with-mdds=1.2")))
|
||||
(native-inputs
|
||||
`(("cppunit" ,cppunit)
|
||||
("doxygen" ,doxygen)
|
||||
|
@ -391,9 +375,7 @@ (define-public libetonyek
|
|||
("gperf" ,gperf)
|
||||
("liblangtag" ,liblangtag)
|
||||
("mdds" ,mdds)
|
||||
("pkg-config" ,pkg-config)
|
||||
("autoconf" ,autoconf) ; due to patch
|
||||
("automake" ,automake)))
|
||||
("pkg-config" ,pkg-config)))
|
||||
(propagated-inputs ; in Requires or Requires.private field of .pkg
|
||||
`(("librevenge" ,librevenge)
|
||||
("libxml2" ,libxml2)))
|
||||
|
|
|
@ -1,74 +0,0 @@
|
|||
Allow building with mdds 1.2.
|
||||
|
||||
Patch taken from upstream commit f6d14b3b510de5c50e45c98fe812a73ba00f3def
|
||||
see https://gerrit.libreoffice.org/gitweb?p=libetonyek.git;a=commitdiff;h=f6d14b3b510de5c50e45c98fe812a73ba00f3def
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index ca4bb07..bb946eb 100644 (file)
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -24,7 +24,7 @@ AC_LANG([C++])
|
||||
# Configure options
|
||||
# =================
|
||||
AC_ARG_WITH([mdds],
|
||||
- AS_HELP_STRING([--with-mdds=1.0|0.x], [Specify which version of mdds to use (1.0 is the default)]),
|
||||
+ AS_HELP_STRING([--with-mdds=1.2|1.0|0.x], [Specify which version of mdds to use (1.0 is the default)]),
|
||||
[], [with_mdds="1.0"])
|
||||
|
||||
# ===========================
|
||||
@@ -47,7 +47,7 @@ AC_PROG_SED
|
||||
|
||||
AM_MISSING_PROG([GPERF], [gperf])
|
||||
|
||||
-AS_IF([test "$with_mdds" = "1.0"], [AX_CXX_COMPILE_STDCXX_11([noext])])
|
||||
+AS_IF([test "$with_mdds" = "1.0" -o "$with_mdds" = "1.2" ], [AX_CXX_COMPILE_STDCXX_11([noext])])
|
||||
|
||||
# ===============
|
||||
# Find librevenge
|
||||
@@ -138,25 +138,27 @@ AC_SUBST([GLM_CFLAGS])
|
||||
# =========
|
||||
# Find mdds
|
||||
# =========
|
||||
-AS_IF([test "$with_mdds" = "1.0"], [
|
||||
- PKG_CHECK_MODULES([MDDS], [mdds-1.0])
|
||||
-], [
|
||||
- PKG_CHECK_MODULES([MDDS], [mdds])
|
||||
- AC_MSG_CHECKING([checking if mdds::flat_segment_tree can store values of any type])
|
||||
- old_CPPFLAGS="$CPPFLAGS"
|
||||
- CPPFLAGS="$MDDS_CFLAGS $CPPFLAGS"
|
||||
- AC_COMPILE_IFELSE([AC_LANG_SOURCE([
|
||||
- #include <mdds/flat_segment_tree.hpp>
|
||||
- struct Value {};
|
||||
- mdds::flat_segment_tree<int, Value> tree(0, 4, Value());
|
||||
- ])], [
|
||||
- AC_MSG_RESULT([yes])
|
||||
- ], [
|
||||
- AC_MSG_RESULT([no])
|
||||
- AC_MSG_ERROR([please install mdds >= 0.12.1])
|
||||
- ])
|
||||
- CPPFLAGS="$old_CPPFLAGS"
|
||||
-])
|
||||
+AS_CASE(["$with_mdds"],
|
||||
+ ["1.2"], [PKG_CHECK_MODULES([MDDS], [mdds-1.2])],
|
||||
+ ["1.0"], [PKG_CHECK_MODULES([MDDS], [mdds-1.0])],
|
||||
+ [
|
||||
+ PKG_CHECK_MODULES([MDDS], [mdds])
|
||||
+ AC_MSG_CHECKING([checking if mdds::flat_segment_tree can store values of any type])
|
||||
+ old_CPPFLAGS="$CPPFLAGS"
|
||||
+ CPPFLAGS="$MDDS_CFLAGS $CPPFLAGS"
|
||||
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
|
||||
+ #include <mdds/flat_segment_tree.hpp>
|
||||
+ struct Value {};
|
||||
+ mdds::flat_segment_tree<int, Value> tree(0, 4, Value());
|
||||
+ ])], [
|
||||
+ AC_MSG_RESULT([yes])
|
||||
+ ], [
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ AC_MSG_ERROR([please install mdds >= 0.12.1])
|
||||
+ ])
|
||||
+ CPPFLAGS="$old_CPPFLAGS"
|
||||
+ ]
|
||||
+)
|
||||
|
||||
# =================================
|
||||
# Libtool/Version Makefile settings
|
Loading…
Reference in a new issue