mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-11 13:49:23 -05:00
gnu: PHP: Fix test failure with newer cURL.
* gnu/packages/patches/php-curl-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/php.scm (php)[source](patches): Add it.
This commit is contained in:
parent
8f2be58833
commit
7aab4eddd0
3 changed files with 21 additions and 2 deletions
|
@ -1631,7 +1631,8 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/perl-www-curl-fix-struct-void.patch \
|
||||
%D%/packages/patches/perl-www-curl-remove-symbol.patch \
|
||||
%D%/packages/patches/phoronix-test-suite-fsdg.patch \
|
||||
%D%/packages/patches/php-bug-74093-test.patch \
|
||||
%D%/packages/patches/php-bug-74093-test.patch \
|
||||
%D%/packages/patches/php-curl-compat.patch \
|
||||
%D%/packages/patches/picard-fix-id3-rename-test.patch \
|
||||
%D%/packages/patches/picprog-non-intel-support.patch \
|
||||
%D%/packages/patches/pidgin-add-search-path.patch \
|
||||
|
|
17
gnu/packages/patches/php-curl-compat.patch
Normal file
17
gnu/packages/patches/php-curl-compat.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
Fix test result with cURL 7.83 and later.
|
||||
|
||||
Taken from upstream:
|
||||
|
||||
https://github.com/php/php-src/commit/a4179e4c92b6365d39e09cb9cd63c476848013af
|
||||
|
||||
diff --git a/ext/curl/tests/curl_basic_007.phpt b/ext/curl/tests/curl_basic_007.phpt
|
||||
index 3b53658d6a7e..3834e4674f82 100644
|
||||
--- a/ext/curl/tests/curl_basic_007.phpt
|
||||
+++ b/ext/curl/tests/curl_basic_007.phpt
|
||||
@@ -20,5 +20,5 @@ curl_close($ch);
|
||||
|
||||
?>
|
||||
--EXPECTF--
|
||||
-string(%d) "No URL set!%w"
|
||||
+string(%d) "No URL set%A"
|
||||
int(3)
|
|
@ -70,7 +70,8 @@ (define-public php
|
|||
(sha256
|
||||
(base32
|
||||
"03d7icwys4ikl45q3rgsxv1m3i7kfxhykpx75nn7jzn6697s6wpa"))
|
||||
(patches (search-patches "php-bug-74093-test.patch"))
|
||||
(patches (search-patches "php-bug-74093-test.patch"
|
||||
"php-curl-compat.patch"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(with-directory-excursion "ext"
|
||||
|
|
Loading…
Reference in a new issue