mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 13:28:12 -05:00
gnu: higan: Various improvements.
* gnu/packages/games.scm (higan): Use semi-official repository at GitLab (using hotfix tag 098b which is equivalent to official release 098). Add a patch to remove the build flag -march=native. Set profile to balanced. * gnu/packages/patches/higan-remove-march-native-flag.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
c59f62e9cb
commit
7c6058c082
3 changed files with 20 additions and 3 deletions
|
@ -542,6 +542,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gtk3-respect-GUIX_GTK3_PATH.patch \
|
||||
%D%/packages/patches/gtkglext-disable-disable-deprecated.patch \
|
||||
%D%/packages/patches/hdf5-config-date.patch \
|
||||
%D%/packages/patches/higan-remove-march-native-flag.patch \
|
||||
%D%/packages/patches/hop-bigloo-4.0b.patch \
|
||||
%D%/packages/patches/hop-linker-flags.patch \
|
||||
%D%/packages/patches/hydra-automake-1.15.patch \
|
||||
|
|
|
@ -2247,15 +2247,17 @@ (define-public red-eclipse
|
|||
(define-public higan
|
||||
(package
|
||||
(name "higan")
|
||||
(version "098")
|
||||
(version "098b")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"https://github.com/TaylanUB/higan/archive/v" version ".tar.gz"))
|
||||
"https://gitlab.com/higan/higan/repository/archive.tar.gz?ref=v"
|
||||
version))
|
||||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32 "12snxrk8wa94x3l69qcimgm0xc22zjgf7vzhckp2lzyfbf27950v"))))
|
||||
(base32 "05j0xzr01gsyia4gj6jmdzklll4iky1kwxgxw0mmfcgm10m0h3bf"))
|
||||
(patches (search-patches "higan-remove-march-native-flag.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("pkg-config" ,pkg-config)))
|
||||
|
@ -2321,6 +2323,7 @@ (define-public higan
|
|||
`("PATH" ":" prefix (,bin))))))))
|
||||
#:make-flags
|
||||
(list "compiler=g++"
|
||||
"profile=balanced" ;default is accuracy; which is quite slow
|
||||
(string-append "prefix=" (assoc-ref %outputs "out")))
|
||||
;; There is no test suite.
|
||||
#:tests? #f))
|
||||
|
|
13
gnu/packages/patches/higan-remove-march-native-flag.patch
Normal file
13
gnu/packages/patches/higan-remove-march-native-flag.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
Remove -march=native from build flags.
|
||||
|
||||
--- a/higan/GNUmakefile
|
||||
+++ b/higan/GNUmakefile
|
||||
@@ -32,7 +32,7 @@ ifeq ($(platform),windows)
|
||||
else ifeq ($(platform),macosx)
|
||||
flags += -march=native
|
||||
else ifneq ($(filter $(platform),linux bsd),)
|
||||
- flags += -march=native -fopenmp
|
||||
+ flags += -fopenmp
|
||||
link += -fopenmp
|
||||
link += -Wl,-export-dynamic
|
||||
link += -lX11 -lXext
|
Loading…
Reference in a new issue