gnu: libksysguard: Update to 6.1.2.

* gnu/packages/kde-plasma.scm (libksysguard): Update to 6.1.2.
[source]: Remvoe patches.
[inputs]: Remove plasma-framework, qtbase-5, qtdeclarative-5, qtscript,
qtwebchannel-5, qtwebengine-5, and qtx11extras; add libplasma,
qtdeclarative, qtwebchannel, and qtwebengine.
[native-inputs]: Remove qttools-5; add qttools.
[arguments]: Set #:qtbase to qtbase.

* gnu/packages/patches/libksysguard-qdiriterator-follow-symlinks.patch: Remove it.
* gnu/local.mk (dist_patch_DATA): Unregister it.

Change-Id: Ic5b88315da7682dcd47ec19894b8ed88b87d6688
This commit is contained in:
Zheng Junjie 2024-05-02 23:12:19 +08:00
parent 69149f1fb6
commit 7ce98fe4d9
No known key found for this signature in database
GPG key ID: 3B5AA993E1A2DFF0
3 changed files with 15 additions and 42 deletions

View file

@ -1638,7 +1638,6 @@ dist_patch_DATA = \
%D%/packages/patches/libofa-ftbfs-2.diff \ %D%/packages/patches/libofa-ftbfs-2.diff \
%D%/packages/patches/libotr-test-auth-fix.patch \ %D%/packages/patches/libotr-test-auth-fix.patch \
%D%/packages/patches/libksieve-Fix-missing-link-libraries.patch \ %D%/packages/patches/libksieve-Fix-missing-link-libraries.patch \
%D%/packages/patches/libksysguard-qdiriterator-follow-symlinks.patch \
%D%/packages/patches/libmad-armv7-thumb-pt1.patch \ %D%/packages/patches/libmad-armv7-thumb-pt1.patch \
%D%/packages/patches/libmad-armv7-thumb-pt2.patch \ %D%/packages/patches/libmad-armv7-thumb-pt2.patch \
%D%/packages/patches/libmad-length-check.patch \ %D%/packages/patches/libmad-length-check.patch \

View file

@ -1090,17 +1090,16 @@ (define-public libkscreen
(define-public libksysguard (define-public libksysguard
(package (package
(name "libksysguard") (name "libksysguard")
(version "5.27.7") (version "6.1.2")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
(uri (string-append "mirror://kde/stable/plasma/" version (uri (string-append "mirror://kde/stable/plasma/" version
"/libksysguard-" version ".tar.xz")) "/libksysguard-" version ".tar.xz"))
(patches (search-patches "libksysguard-qdiriterator-follow-symlinks.patch"))
(sha256 (sha256
(base32 "066bjar4105bfyry6ni7nnikz66bqzy5nvssz6vm4np3aa996ak8")))) (base32 "1l1fy5i9yxh7fnxfyfsk0hnyd1vfzac336kcfwklkqa7l796hpc0"))))
(native-inputs (native-inputs
(list bash-minimal extra-cmake-modules pkg-config qttools-5)) (list bash-minimal extra-cmake-modules pkg-config qttools))
(inputs (inputs
(list kauth (list kauth
kcompletion kcompletion
@ -1120,22 +1119,21 @@ (define-public libksysguard
libcap libcap
libpcap libpcap
`(,lm-sensors "lib") `(,lm-sensors "lib")
plasma-framework libplasma
qtbase-5 qtdeclarative
qtdeclarative-5 qtwebchannel
qtscript qtwebengine
qtwebchannel-5
qtwebengine-5
qtx11extras
zlib)) zlib))
(build-system qt-build-system) (build-system qt-build-system)
(arguments (arguments
(list #:phases #~(modify-phases %standard-phases (list
(add-after 'unpack 'fix-test #:qtbase qtbase
(lambda* _ #:phases #~(modify-phases %standard-phases
(substitute* "autotests/processtest.cpp" (add-after 'unpack 'fix-test
(("/bin/sh") (lambda* _
(which "bash")))))))) (substitute* "autotests/processtest.cpp"
(("/bin/sh")
(which "bash"))))))))
(home-page "https://userbase.kde.org/KSysGuard") (home-page "https://userbase.kde.org/KSysGuard")
(synopsis "Network enabled task and system monitoring") (synopsis "Network enabled task and system monitoring")
(description "KSysGuard can obtain information on system load and (description "KSysGuard can obtain information on system load and

View file

@ -1,24 +0,0 @@
From 46164a50de4102d02ae9d1d480acdd4b12303db8 Mon Sep 17 00:00:00 2001
From: Thomas Tuegel <ttuegel@gmail.com>
Date: Wed, 14 Oct 2015 07:07:22 -0500
Subject: [PATCH] qdiriterator follow symlinks
---
processui/scripting.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/processui/scripting.cpp b/processui/scripting.cpp
index efed8ff..841761a 100644
--- a/processui/scripting.cpp
+++ b/processui/scripting.cpp
@@ -293,7 +293,7 @@ void Scripting::loadContextMenu()
const QStringList dirs =
QStandardPaths::locateAll(QStandardPaths::GenericDataLocation, QStringLiteral("ksysguard/scripts/"), QStandardPaths::LocateDirectory);
for (const QString &dir : dirs) {
- QDirIterator it(dir, QStringList() << QStringLiteral("*.desktop"), QDir::NoFilter, QDirIterator::Subdirectories);
+ QDirIterator it(dir, QStringList() << QStringLiteral("*.desktop"), QDir::NoFilter, QDirIterator::Subdirectories | QDirIterator::FollowSymlinks);
while (it.hasNext()) {
scripts.append(it.next());
}
--
2.5.2