mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: soundconverter: Update to 3.0.2.
* gnu/packages/gnome.scm (soundconverter): Update to 3.0.2. [source]: Remove upstreamed patch. * gnu/packages/patches/soundconverter-remove-gconf-dependency.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
aa784dc850
commit
7f4b45a320
3 changed files with 2 additions and 35 deletions
|
@ -1498,7 +1498,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/slim-display.patch \
|
%D%/packages/patches/slim-display.patch \
|
||||||
%D%/packages/patches/snappy-add-O2-flag-in-CmakeLists.txt.patch \
|
%D%/packages/patches/snappy-add-O2-flag-in-CmakeLists.txt.patch \
|
||||||
%D%/packages/patches/sooperlooper-build-with-wx-30.patch \
|
%D%/packages/patches/sooperlooper-build-with-wx-30.patch \
|
||||||
%D%/packages/patches/soundconverter-remove-gconf-dependency.patch \
|
|
||||||
%D%/packages/patches/steghide-fixes.patch \
|
%D%/packages/patches/steghide-fixes.patch \
|
||||||
%D%/packages/patches/suitesparse-mongoose-cmake.patch \
|
%D%/packages/patches/suitesparse-mongoose-cmake.patch \
|
||||||
%D%/packages/patches/superlu-dist-awpm-grid.patch \
|
%D%/packages/patches/superlu-dist-awpm-grid.patch \
|
||||||
|
|
|
@ -9198,7 +9198,7 @@ (define-public sound-juicer
|
||||||
(define-public soundconverter
|
(define-public soundconverter
|
||||||
(package
|
(package
|
||||||
(name "soundconverter")
|
(name "soundconverter")
|
||||||
(version "3.0.1")
|
(version "3.0.2")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -9207,10 +9207,7 @@ (define-public soundconverter
|
||||||
"soundconverter-" version ".tar.xz"))
|
"soundconverter-" version ".tar.xz"))
|
||||||
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "1d6x1yf8psqbd9zbybxivfqg55khcnngp2mn92l161dfdk9512c5"))
|
(base32 "1jv8m82hi23ilrgdznlc1jhp2jm8bw1yrw0chh3qw2l0sixvkl11"))))
|
||||||
(patches
|
|
||||||
(search-patches
|
|
||||||
"soundconverter-remove-gconf-dependency.patch"))))
|
|
||||||
(build-system glib-or-gtk-build-system)
|
(build-system glib-or-gtk-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:imported-modules ((guix build python-build-system)
|
`(#:imported-modules ((guix build python-build-system)
|
||||||
|
|
|
@ -1,29 +0,0 @@
|
||||||
From: Tobias Geerinckx-Rice <me@tobias.gr>
|
|
||||||
Date: Tue, 19 Feb 2019 07:46:28 +0100
|
|
||||||
Subject: [PATCH] gnu: soundconverter: Catch (and ignore) the right error.
|
|
||||||
|
|
||||||
Without this patch and GConf:
|
|
||||||
|
|
||||||
Traceback (most recent call last):
|
|
||||||
File "/gnu/…/bin/...soundconverter-real-real-real", line 164, in <module>
|
|
||||||
from soundconverter.batch import cli_convert_main
|
|
||||||
File "/gnu/…/lib/soundconverter/python/soundconverter/batch.py", line 31, in <module>
|
|
||||||
from soundconverter.gstreamer import TagReader
|
|
||||||
File "/gnu/…/lib/soundconverter/python/soundconverter/gstreamer.py", line 70, in <module>
|
|
||||||
gi.require_version('GConf', '2.0')
|
|
||||||
File "/gnu/…/lib/python3.7/site-packages/gi/__init__.py", line 130, in require_version
|
|
||||||
raise ValueError('Namespace %s not available' % namespace)
|
|
||||||
ValueError: Namespace GConf not available
|
|
||||||
---
|
|
||||||
diff -Naur soundconverter-3.0.1/soundconverter/gstreamer.py soundconverter-3.0.1/soundconverter/gstreamer.py
|
|
||||||
--- soundconverter-3.0.1/soundconverter/gstreamer.py 2018-11-23 20:38:46.000000000 +0100
|
|
||||||
+++ soundconverter-3.0.1/soundconverter/gstreamer.py 2019-02-19 07:42:15.767684388 +0100
|
|
||||||
@@ -88,7 +88,7 @@
|
|
||||||
profile = description, extension, pipeline
|
|
||||||
audio_profiles_list.append(profile)
|
|
||||||
audio_profiles_dict[description] = profile
|
|
||||||
-except ImportError:
|
|
||||||
+except ValueError:
|
|
||||||
pass
|
|
||||||
|
|
||||||
required_elements = ('decodebin', 'fakesink', 'audioconvert', 'typefind', 'audiorate')
|
|
Loading…
Reference in a new issue