mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-11 13:49:23 -05:00
gnu: tcsh: Update to 6.20.00.
* gnu/packages/shells.scm (tcsh): Update to 6.20.00. [source]: Remove 'tcsh-do-not-define-BSDWAIT.patch'. [inputs]: Remove coreutils. Move autoconf to ... [native-inputs]: ... here. Add perl. * gnu/packages/patches/tcsh-fix-autotest.patch: Adjust patch to upstream changes. * gnu/packages/patches/tcsh-do-not-define-BSDWAIT.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
83090f6ae7
commit
816417f5a4
4 changed files with 58 additions and 101 deletions
|
@ -918,7 +918,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/tar-skip-unreliable-tests.patch \
|
||||
%D%/packages/patches/tcl-mkindex-deterministic.patch \
|
||||
%D%/packages/patches/tclxml-3.2-install.patch \
|
||||
%D%/packages/patches/tcsh-do-not-define-BSDWAIT.patch \
|
||||
%D%/packages/patches/tcsh-fix-autotest.patch \
|
||||
%D%/packages/patches/tcsh-fix-out-of-bounds-read.patch \
|
||||
%D%/packages/patches/teensy-loader-cli-help.patch \
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
Do not define BSDWAIT to avoid error "storage size of ‘w’ isn’t known".
|
||||
|
||||
This is an adapted version of the upstream patch taken from here:
|
||||
https://github.com/tcsh-org/tcsh/commit/4689eb60a74bf13bc146ca3d76e9d7a124ab7b49.patch
|
||||
|
||||
From 4689eb60a74bf13bc146ca3d76e9d7a124ab7b49 Mon Sep 17 00:00:00 2001
|
||||
From: christos <christos>
|
||||
Date: Fri, 23 Sep 2016 19:17:28 +0000
|
||||
Subject: [PATCH] Don't define BSDWAIT for linux anymore.
|
||||
|
||||
---
|
||||
sh.proc.c | 8 +++-----
|
||||
1 file changed, 3 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/sh.proc.c b/sh.proc.c
|
||||
index 49b199f..874d67c 100644
|
||||
--- sh.proc.c
|
||||
+++ sh.proc.c
|
||||
@@ -47,11 +47,9 @@ RCSID("$tcsh$")
|
||||
# define HZ 16
|
||||
#endif /* aiws */
|
||||
|
||||
-#if defined(_BSD) || (defined(IRIS4D) && __STDC__) || defined(__lucid) || defined(__linux__) || defined(__GNU__) || defined(__GLIBC__)
|
||||
-# if !defined(__ANDROID__)
|
||||
-# define BSDWAIT
|
||||
-# endif
|
||||
-#endif /* _BSD || (IRIS4D && __STDC__) || __lucid || glibc */
|
||||
+#if defined(_BSD) || (defined(IRIS4D) && __STDC__) || defined(__lucid)
|
||||
+# define BSDWAIT
|
||||
+#endif /* _BSD || (IRIS4D && __STDC__) || __lucid */
|
||||
#ifndef WTERMSIG
|
||||
# define WTERMSIG(w) (((union wait *) &(w))->w_termsig)
|
||||
# ifndef BSDWAIT
|
|
@ -1,6 +1,6 @@
|
|||
--- tests/commands.at 2011-01-22 01:04:02.000000000 +0100
|
||||
+++ tests/commands.at 2013-02-04 10:57:24.000000000 +0100
|
||||
@@ -919,26 +919,27 @@
|
||||
--- tests/commands.at
|
||||
+++ tests/commands.at
|
||||
@@ -921,26 +921,27 @@ AT_CLEANUP
|
||||
TCSH_UNTESTED([notify])
|
||||
|
||||
|
||||
|
@ -48,27 +48,9 @@
|
|||
|
||||
|
||||
AT_SETUP([popd])
|
||||
@@ -1203,11 +1204,12 @@
|
||||
AT_DATA([script.csh],
|
||||
[[set var=$1
|
||||
]])
|
||||
-AT_CHECK([[tcsh -f -c 'source -h script.csh foo; history' \
|
||||
- | sed 's/ [^ ]* / TIME /']], ,
|
||||
-[ 1 TIME source -h script.csh foo ; history
|
||||
- 2 TIME set var=$1
|
||||
-])
|
||||
+# XXX: Not sure why this fails. The output is : "1 TIME set var=$1"
|
||||
+#AT_CHECK([[tcsh -f -c 'source -h script.csh foo; history' \
|
||||
+# | sed 's/ [^ ]* / TIME /']], ,
|
||||
+#[ 1 TIME source -h script.csh foo ; history
|
||||
+# 2 TIME set var=$1
|
||||
+#])
|
||||
|
||||
AT_CHECK([tcsh -f -c 'source -h script.csh foo; echo $var'], 1, [],
|
||||
[var: Undefined variable.
|
||||
--- tests/lexical.at 2011-12-27 22:50:52.000000000 +0100
|
||||
+++ tests/lexical.at 2013-02-04 10:53:21.000000000 +0100
|
||||
@@ -33,9 +33,9 @@
|
||||
--- tests/lexical.at
|
||||
+++ tests/lexical.at
|
||||
@@ -35,9 +35,9 @@ AT_CHECK([if [ ! -t 0 ]; then exit 77; fi],, [Skipping comment tests])
|
||||
AT_CHECK([echo 'echo OK@%:@comment' | tcsh -f], , [OK
|
||||
])
|
||||
|
||||
|
@ -81,9 +63,33 @@
|
|||
|
||||
AT_DATA([comment2.csh],
|
||||
[[echo testing...@%:@\
|
||||
--- tests/subst.at 2011-12-27 22:50:52.000000000 +0100
|
||||
+++ tests/subst.at 2013-02-01 08:14:25.000000000 +0100
|
||||
@@ -54,7 +54,7 @@
|
||||
@@ -567,10 +567,10 @@ run=3
|
||||
# Adapt to changes in sed 4.3:
|
||||
# https://github.com/tcsh-org/tcsh/commit/2ad4fc1705893207598ed5cd21713ddf3f17bba0
|
||||
]])
|
||||
AT_DATA([uniformity_test.csh],
|
||||
[[
|
||||
-set SERVICE_NAME_LOG = `cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[:blank:]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g'`
|
||||
+set SERVICE_NAME_LOG = `cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[[:blank:]]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g'`
|
||||
echo -n "$SERVICE_NAME_LOG" > ./output1
|
||||
|
||||
-cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[:blank:]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g' > ./output2
|
||||
+cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[[:blank:]]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g' > ./output2
|
||||
|
||||
diff -uprN ./output1 ./output2 >& /dev/null
|
||||
|
||||
@@ -587,7 +587,7 @@ AT_DATA([quoting_result_test.csh],
|
||||
echo "(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP\)(HOST=db\)(PORT=1521\)\)(CONNECT_DATA=(SERVER=DEDICATED\)(SERVICE_NAME=bns03\)\)\)" > ./expected_result
|
||||
|
||||
set string = "jdbc_url=jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=db)(PORT=1521))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=bns03)))"
|
||||
-set SERVICE_NAME_LOG = `echo "$string" | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[:blank:]*\([^$]*\)$/\1/p' | perl -pe 's/\)/\\\)/g'`
|
||||
+set SERVICE_NAME_LOG = `echo "$string" | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[[:blank:]]*\([^$]*\)$/\1/p' | perl -pe 's/\)/\\\)/g'`
|
||||
|
||||
echo "$SERVICE_NAME_LOG" > ./actual_result
|
||||
|
||||
--- tests/subst.at
|
||||
+++ tests/subst.at
|
||||
@@ -54,7 +54,7 @@ AT_CHECK([echo 'echo ~; echo "$HOME"' | tcsh -f | uniq | wc -l | tr -d ' \t'],
|
||||
, [1
|
||||
])
|
||||
|
||||
|
@ -92,39 +98,9 @@
|
|||
| wc -l | tr -d ' \t'], , [1
|
||||
])
|
||||
|
||||
--- tests/variables.at 2011-12-27 22:50:52.000000000 +0100
|
||||
+++ tests/variables.at 2013-02-04 11:40:35.000000000 +0100
|
||||
@@ -317,17 +317,18 @@
|
||||
AT_CLEANUP
|
||||
|
||||
|
||||
-AT_SETUP([$ edit])
|
||||
-
|
||||
-AT_CHECK([TERM=something tcsh -f -c 'echo $?edit'], ,
|
||||
-[1
|
||||
-])
|
||||
-
|
||||
-AT_CHECK([TERM=dumb tcsh -f -c 'echo $?edit'], ,
|
||||
-[0
|
||||
-])
|
||||
-
|
||||
-AT_CLEANUP
|
||||
+# XXX
|
||||
+#AT_SETUP([$ edit])
|
||||
+#
|
||||
+#AT_CHECK([TERM=something tcsh -f -c 'echo $?edit'], ,
|
||||
+#[1
|
||||
+#])
|
||||
+#
|
||||
+#AT_CHECK([TERM=dumb tcsh -f -c 'echo $?edit'], ,
|
||||
+#[0
|
||||
+#])
|
||||
+#
|
||||
+#AT_CLEANUP
|
||||
|
||||
|
||||
AT_SETUP([$ ellipsis])
|
||||
@@ -642,7 +643,8 @@
|
||||
--- tests/variables.at
|
||||
+++ tests/variables.at
|
||||
@@ -666,7 +666,8 @@ set listflags=(-xA $cwd/args.sh)
|
||||
ls-F -something .
|
||||
]])
|
||||
AT_DATA([args.sh],
|
||||
|
@ -134,7 +110,22 @@
|
|||
]])
|
||||
chmod a+x args.sh
|
||||
AT_CHECK([tcsh -f listflags.csh], ,
|
||||
@@ -695,55 +697,57 @@
|
||||
@@ -704,9 +705,9 @@ AT_CHECK([tcsh -f mail.csh], ,
|
||||
# This test fails by trying to change to the build user's home
|
||||
# directory, which does not exist.
|
||||
AT_CLEANUP
|
||||
|
||||
|
||||
-AT_SETUP([$ cdtohome])
|
||||
-AT_CHECK([tcsh -f -c 'cd'], 0)
|
||||
-AT_CLEANUP
|
||||
+#AT_SETUP([$ cdtohome])
|
||||
+#AT_CHECK([tcsh -f -c 'cd'], 0)
|
||||
+#AT_CLEANUP
|
||||
AT_SETUP([$ noimplicithome])
|
||||
AT_CHECK([tcsh -f -c 'unset cdtohome; cd'], 1, , [cd: Too few arguments.
|
||||
])
|
||||
@@ -728,55 +729,57 @@ TCSH_UNTESTED([$ oid])
|
||||
AT_SETUP([$ owd])
|
||||
|
||||
AT_DATA([owd.csh],
|
||||
|
|
|
@ -218,7 +218,7 @@ (define-public es
|
|||
(define-public tcsh
|
||||
(package
|
||||
(name "tcsh")
|
||||
(version "6.18.01")
|
||||
(version "6.20.00")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
;; Old tarballs are moved to old/.
|
||||
|
@ -228,16 +228,16 @@ (define-public tcsh
|
|||
"old/tcsh-" version ".tar.gz")))
|
||||
(sha256
|
||||
(base32
|
||||
"1a4z9kwgx1iqqzvv64si34m60gj34p7lp6rrcrb59s7ka5wa476q"))
|
||||
"17ggxkkn5skl0v1x0j6hbv5l0sgnidfzwv16992sqkdm983fg7dq"))
|
||||
(patches (search-patches "tcsh-fix-autotest.patch"
|
||||
"tcsh-do-not-define-BSDWAIT.patch"
|
||||
"tcsh-fix-out-of-bounds-read.patch"))
|
||||
(patch-flags '("-p0"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
(native-inputs
|
||||
`(("autoconf" ,autoconf)
|
||||
("coreutils" ,coreutils)
|
||||
("ncurses" ,ncurses)))
|
||||
("perl" ,perl)))
|
||||
(inputs
|
||||
`(("ncurses" ,ncurses)))
|
||||
(arguments
|
||||
`(#:phases
|
||||
(alist-cons-before
|
||||
|
|
Loading…
Reference in a new issue