gnu: mupen64plus-video-z64: Update to 2.5.9.

* gnu/packages/emulators.scm (mupen64plus-video-z64): Update to 2.5.9.
[source]: Delete patches.
* gnu/packages/patches/mupen64plus-video-z64-glew-correct-path.patch: Delete
file.
* gnu/local.mk (dist_patch_DATA): De-register it.

Change-Id: Ic8022c3a88f88f48644cc694e0a18c0b0a6745a1
This commit is contained in:
Maxim Cournoyer 2024-05-05 12:19:22 -04:00
parent 71e99742ab
commit 8521d0b81e
No known key found for this signature in database
GPG key ID: 1260E46482E63562
3 changed files with 2 additions and 40 deletions

View file

@ -1723,7 +1723,6 @@ dist_patch_DATA = \
%D%/packages/patches/mrrescue-support-love-11.patch \ %D%/packages/patches/mrrescue-support-love-11.patch \
%D%/packages/patches/mtools-mformat-uninitialized.patch \ %D%/packages/patches/mtools-mformat-uninitialized.patch \
%D%/packages/patches/mupen64plus-ui-console-notice.patch \ %D%/packages/patches/mupen64plus-ui-console-notice.patch \
%D%/packages/patches/mupen64plus-video-z64-glew-correct-path.patch \
%D%/packages/patches/musl-cross-locale.patch \ %D%/packages/patches/musl-cross-locale.patch \
%D%/packages/patches/mutt-store-references.patch \ %D%/packages/patches/mutt-store-references.patch \
%D%/packages/patches/m17n-lib-1.8.0-use-pkg-config-for-freetype.patch \ %D%/packages/patches/m17n-lib-1.8.0-use-pkg-config-for-freetype.patch \

View file

@ -1238,7 +1238,7 @@ (define-public mupen64plus-video-rice
(define-public mupen64plus-video-z64 (define-public mupen64plus-video-z64
(package (package
(name "mupen64plus-video-z64") (name "mupen64plus-video-z64")
(version "2.0.0") (version "2.5.9")
(source (source
(origin (origin
(method git-fetch) (method git-fetch)
@ -1247,8 +1247,7 @@ (define-public mupen64plus-video-z64
(commit version))) (commit version)))
(file-name (git-file-name name version)) (file-name (git-file-name name version))
(sha256 (sha256
(base32 "04qa2fdd6dakpk2v0d4l80xh9b4h8gm71g80c0wyyxdhmhwk1r9c")) (base32 "1i8dxa0lhcsm5ss1bf74dqnzaa2bw5naj6f56ixw2qjvybrnsmk2"))))
(patches (search-patches "mupen64plus-video-z64-glew-correct-path.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(native-inputs (native-inputs
(list pkg-config which)) (list pkg-config which))

View file

@ -1,36 +0,0 @@
From 21507b3600c616bca7049004eb518cf11f45f299 Mon Sep 17 00:00:00 2001
From: "Anthony J. Bentley" <anthony@cathet.us>
Date: Sun, 7 Jun 2015 02:41:28 -0600
Subject: [PATCH] Correct the path to the GLEW header.
---
src/glshader.cpp | 2 +-
src/rgl.h | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/glshader.cpp b/src/glshader.cpp
index 4729945..a8947ea 100644
--- a/src/glshader.cpp
+++ b/src/glshader.cpp
@@ -23,7 +23,7 @@
#include <stdio.h>
#include <string.h>
#include "rgl_assert.h"
-#include <glew.h>
+#include <GL/glew.h>
#if defined(__MACOSX__)
#include <OpenGL/gl.h>
#include <OpenGL/glext.h>
diff --git a/src/rgl.h b/src/rgl.h
index c15f93f..1748406 100644
--- a/src/rgl.h
+++ b/src/rgl.h
@@ -26,7 +26,7 @@
#include "rgl_assert.h"
#include "rdp.h"
-#include <glew.h>
+#include <GL/glew.h>
#if defined(__MACOSX__)
#include <OpenGL/gl.h>
#elif defined(__MACOS__)