mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-12 06:06:53 -05:00
gnu: pdfpc: Fix build with vala 0.56.
* gnu/packages/patches/pdfpc-build-with-vala-0.56.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/pdf.scm (pdfpc): Use it here. [inputs]: Drop labels. Change-Id: Ib762da3dd23612f952215a2f8d383552e7bc050c Signed-off-by: Christopher Baines <mail@cbaines.net>
This commit is contained in:
parent
f8c6cc02ee
commit
85c99aa1cf
3 changed files with 57 additions and 14 deletions
|
@ -1795,6 +1795,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/pam-krb5-CVE-2020-10595.patch \
|
%D%/packages/patches/pam-krb5-CVE-2020-10595.patch \
|
||||||
%D%/packages/patches/pango-skip-libthai-test.patch \
|
%D%/packages/patches/pango-skip-libthai-test.patch \
|
||||||
%D%/packages/patches/password-store-tree-compat.patch \
|
%D%/packages/patches/password-store-tree-compat.patch \
|
||||||
|
%D%/packages/patches/pdfpc-build-with-vala-0.56.patch \
|
||||||
%D%/packages/patches/petri-foo-0.1.87-fix-recent-file-not-exist.patch \
|
%D%/packages/patches/petri-foo-0.1.87-fix-recent-file-not-exist.patch \
|
||||||
%D%/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch \
|
%D%/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch \
|
||||||
%D%/packages/patches/plasp-fix-normalization.patch \
|
%D%/packages/patches/plasp-fix-normalization.patch \
|
||||||
|
|
40
gnu/packages/patches/pdfpc-build-with-vala-0.56.patch
Normal file
40
gnu/packages/patches/pdfpc-build-with-vala-0.56.patch
Normal file
|
@ -0,0 +1,40 @@
|
||||||
|
From 18beaecbbcc066e0d4c889b3aa3ecaa7351f7768 Mon Sep 17 00:00:00 2001
|
||||||
|
Message-ID: <18beaecbbcc066e0d4c889b3aa3ecaa7351f7768.1711183363.git.vivien@planete-kraus.eu>
|
||||||
|
From: Evgeny Stambulchik <fnevgeny@gmail.com>
|
||||||
|
Date: Tue, 25 Apr 2023 16:11:25 +0300
|
||||||
|
Subject: [PATCH] Create Lists of nullable types
|
||||||
|
|
||||||
|
---
|
||||||
|
This is the pull request for issue 686, merged in master, not released
|
||||||
|
yet.
|
||||||
|
|
||||||
|
src/classes/drawings/drawing_commands.vala | 6 +++---
|
||||||
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/classes/drawings/drawing_commands.vala b/src/classes/drawings/drawing_commands.vala
|
||||||
|
index 77e56e6..c305a8c 100644
|
||||||
|
--- a/src/classes/drawings/drawing_commands.vala
|
||||||
|
+++ b/src/classes/drawings/drawing_commands.vala
|
||||||
|
@@ -54,8 +54,8 @@ namespace pdfpc {
|
||||||
|
}
|
||||||
|
|
||||||
|
public void clear() {
|
||||||
|
- this.drawing_commands = new List<DrawingCommand>();
|
||||||
|
- this.redo_commands = new List<DrawingCommand>();
|
||||||
|
+ this.drawing_commands = new List<DrawingCommand?>();
|
||||||
|
+ this.redo_commands = new List<DrawingCommand?>();
|
||||||
|
}
|
||||||
|
|
||||||
|
public void add_line(bool is_eraser,
|
||||||
|
@@ -70,7 +70,7 @@ namespace pdfpc {
|
||||||
|
|
||||||
|
// After adding a new line you can no longer redo the old
|
||||||
|
// path.
|
||||||
|
- this.redo_commands = new List<DrawingCommand>(); // clear
|
||||||
|
+ this.redo_commands = new List<DrawingCommand?>(); // clear
|
||||||
|
|
||||||
|
bool new_path = true;
|
||||||
|
double epsilon = 1e-4; // Less than 0.1 pixel for a 1000x1000 img
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
|
@ -1526,22 +1526,24 @@ (define-public pdfpc
|
||||||
(commit (string-append "v" version))))
|
(commit (string-append "v" version))))
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0kj84sf5hgr2v2ra6dxmxqcr173h17cpnhg9lcq36shdbdnncwg4"))))
|
(base32 "0kj84sf5hgr2v2ra6dxmxqcr173h17cpnhg9lcq36shdbdnncwg4"))
|
||||||
|
(patches
|
||||||
|
(search-patches "pdfpc-build-with-vala-0.56.patch"))))
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
(arguments '(#:tests? #f)) ; no test target
|
(arguments '(#:tests? #f)) ; no test target
|
||||||
(inputs
|
(inputs (list
|
||||||
`(("cairo" ,cairo)
|
cairo
|
||||||
("discount" ,discount) ; libmarkdown
|
discount ; libmarkdown
|
||||||
("qrencode" ,qrencode)
|
qrencode
|
||||||
("gtk+" ,gtk+)
|
gtk+
|
||||||
("gstreamer" ,gstreamer)
|
gstreamer
|
||||||
("gst-plugins-base" ,gst-plugins-base)
|
gst-plugins-base
|
||||||
("json-glib" ,json-glib)
|
json-glib
|
||||||
("libgee" ,libgee)
|
libgee
|
||||||
("poppler" ,poppler)
|
poppler
|
||||||
("pango" ,pango)
|
pango
|
||||||
("vala" ,vala)
|
vala
|
||||||
("webkitgtk" ,webkitgtk-with-libsoup2)))
|
webkitgtk-with-libsoup2))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list pkg-config))
|
(list pkg-config))
|
||||||
(home-page "https://pdfpc.github.io/")
|
(home-page "https://pdfpc.github.io/")
|
||||||
|
|
Loading…
Reference in a new issue