mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: shishi: Update to 1.0.2.
* gnu/packages/shishi.scm (shishi): Update to 1.0.2. * gnu/packages/patches/shishi-gets-undeclared.patch: Remove it. * Makefile.am (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
3fdc99da19
commit
865c4ef33c
3 changed files with 16 additions and 102 deletions
|
@ -238,7 +238,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/procps-make-3.82.patch \
|
||||
gnu/packages/patches/qemu-multiple-smb-shares.patch \
|
||||
gnu/packages/patches/readline-link-ncurses.patch \
|
||||
gnu/packages/patches/shishi-gets-undeclared.patch \
|
||||
gnu/packages/patches/tar-gets-undeclared.patch \
|
||||
gnu/packages/patches/tcsh-fix-autotest.patch \
|
||||
gnu/packages/patches/teckit-cstdio.patch \
|
||||
|
|
|
@ -1,71 +0,0 @@
|
|||
This patch is needed to allow builds with newer versions of
|
||||
the GNU libc (2.16+).
|
||||
|
||||
|
||||
commit 66712c23388e93e5c518ebc8515140fa0c807348
|
||||
Author: Eric Blake <eblake@redhat.com>
|
||||
Date: Thu Mar 29 13:30:41 2012 -0600
|
||||
|
||||
stdio: don't assume gets any more
|
||||
|
||||
Gnulib intentionally does not have a gets module, and now that C11
|
||||
and glibc have dropped it, we should be more proactive about warning
|
||||
any user on a platform that still has a declaration of this dangerous
|
||||
interface.
|
||||
|
||||
* m4/stdio_h.m4 (gl_STDIO_H, gl_STDIO_H_DEFAULTS): Drop gets
|
||||
support.
|
||||
* modules/stdio (Makefile.am): Likewise.
|
||||
* lib/stdio-read.c (gets): Likewise.
|
||||
* tests/test-stdio-c++.cc: Likewise.
|
||||
* m4/warn-on-use.m4 (gl_WARN_ON_USE_PREPARE): Fix comment.
|
||||
* lib/stdio.in.h (gets): Make warning occur in more places.
|
||||
* doc/posix-functions/gets.texi (gets): Update documentation.
|
||||
Reported by Christer Solskogen.
|
||||
|
||||
Signed-off-by: Eric Blake <eblake@redhat.com>
|
||||
|
||||
diff --git a/gl/stdio.in.h b/gl/stdio.in.h
|
||||
index aa7b599..c377b6e 100644
|
||||
--- a/gl/stdio.in.h
|
||||
+++ b/gl/stdio.in.h
|
||||
@@ -698,22 +698,11 @@ _GL_WARN_ON_USE (getline, "getline is unportable - "
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#if @GNULIB_GETS@
|
||||
-# if @REPLACE_STDIO_READ_FUNCS@ && @GNULIB_STDIO_H_NONBLOCKING@
|
||||
-# if !(defined __cplusplus && defined GNULIB_NAMESPACE)
|
||||
-# undef gets
|
||||
-# define gets rpl_gets
|
||||
-# endif
|
||||
-_GL_FUNCDECL_RPL (gets, char *, (char *s) _GL_ARG_NONNULL ((1)));
|
||||
-_GL_CXXALIAS_RPL (gets, char *, (char *s));
|
||||
-# else
|
||||
-_GL_CXXALIAS_SYS (gets, char *, (char *s));
|
||||
-# undef gets
|
||||
-# endif
|
||||
-_GL_CXXALIASWARN (gets);
|
||||
/* It is very rare that the developer ever has full control of stdin,
|
||||
- so any use of gets warrants an unconditional warning. Assume it is
|
||||
- always declared, since it is required by C89. */
|
||||
+ so any use of gets warrants an unconditional warning; besides, C11
|
||||
+ removed it. */
|
||||
+#undef gets
|
||||
+#if HAVE_RAW_DECL_GETS
|
||||
_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
|
||||
#endif
|
||||
|
||||
@@ -1053,9 +1042,9 @@ _GL_WARN_ON_USE (snprintf, "snprintf is unportable - "
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-/* Some people would argue that sprintf should be handled like gets
|
||||
- (for example, OpenBSD issues a link warning for both functions),
|
||||
- since both can cause security holes due to buffer overruns.
|
||||
+/* Some people would argue that all sprintf uses should be warned about
|
||||
+ (for example, OpenBSD issues a link warning for it),
|
||||
+ since it can cause security holes due to buffer overruns.
|
||||
However, we believe that sprintf can be used safely, and is more
|
||||
efficient than snprintf in those safe cases; and as proof of our
|
||||
belief, we use sprintf in several gnulib modules. So this header
|
|
@ -1,5 +1,5 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
|
||||
;;; Copyright © 2012, 2013 Nikita Karetnikov <nikita@karetnikov.org>
|
||||
;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
|
@ -18,12 +18,11 @@
|
|||
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
|
||||
|
||||
(define-module (gnu packages shishi)
|
||||
#:use-module (guix licenses)
|
||||
#:use-module ((guix licenses) #:select (gpl3+))
|
||||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages gnutls)
|
||||
#:use-module (gnu packages gnupg)
|
||||
#:use-module ((gnu packages compression)
|
||||
#:renamer (symbol-prefix-proc 'guix:))
|
||||
#:use-module (gnu packages compression)
|
||||
#:use-module (guix packages)
|
||||
#:use-module (guix download)
|
||||
#:use-module (guix build-system gnu))
|
||||
|
@ -31,41 +30,28 @@ (define-module (gnu packages shishi)
|
|||
(define-public shishi
|
||||
(package
|
||||
(name "shishi")
|
||||
(version "1.0.1")
|
||||
(version "1.0.2")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"mirror://gnu/shishi/shishi-"
|
||||
version
|
||||
".tar.gz"))
|
||||
(uri (string-append "mirror://gnu/shishi/shishi-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"13c6w9rpaqb3am65nrn86byvmll5r78pld2vb0i68491vww4fzlx"))))
|
||||
"032qf72cpjdfffq1yq54gz3ahgqf2ijca4vl31sfabmjzq9q370d"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:make-flags
|
||||
'("CPPFLAGS=-DMAX_ERROR_DESCRIPTION_SIZE=ASN1_MAX_ERROR_DESCRIPTION_SIZE")
|
||||
#:patches (list (assoc-ref %build-inputs
|
||||
"patch/gets"))))
|
||||
(inputs
|
||||
`(("gnutls" ,gnutls)
|
||||
("zlib" ,guix:zlib)
|
||||
("zlib" ,zlib)
|
||||
("libgcrypt" ,libgcrypt)
|
||||
("libtasn1" ,libtasn1)
|
||||
("patch/gets" ,(search-patch "shishi-gets-undeclared.patch"))))
|
||||
("libtasn1" ,libtasn1)))
|
||||
(home-page "http://www.gnu.org/software/shishi/")
|
||||
(synopsis
|
||||
"GNU Shishi, free implementation of the Kerberos 5 network security system")
|
||||
"GNU Shishi, an implementation of the Kerberos 5 network security system")
|
||||
(description
|
||||
" GNU Shishi is an implementation of the Kerberos 5 network
|
||||
authentication system, as specified in RFC 4120. Shishi can be
|
||||
used to authenticate users in distributed systems.
|
||||
|
||||
Shishi contains a library (`libshishi') that can be used by
|
||||
application developers to add support for Kerberos 5. Shishi
|
||||
contains a command line utility (1shishi') that is used by
|
||||
users to acquire and manage tickets (and more). The server
|
||||
side, a Key Distribution Center, is implemented by `shishid'.
|
||||
")
|
||||
(license gpl3+))) ; some files are under GPLv2+
|
||||
"Shishi contains a library ('libshishi') that can be used by application
|
||||
developers to add support for Kerberos 5. Shishi contains a command line
|
||||
utility ('shishi') that is used by users to acquire and manage tickets (and
|
||||
more). The server side, a Key Distribution Center (KDC), is implemented by
|
||||
'shishid', and support X.509 authenticated TLS via GnuTLS.")
|
||||
(license gpl3+)))
|
||||
|
|
Loading…
Reference in a new issue