mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 13:58:15 -05:00
gnu: aspell: Fix FTBFS with GCC7.
* gnu/packages/patches/aspell-gcc-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/aspell.scm (aspell)[source](patches): Use it.
This commit is contained in:
parent
a555c3f438
commit
8771fc1715
3 changed files with 34 additions and 1 deletions
|
@ -643,6 +643,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/apr-skip-getservbyname-test.patch \
|
%D%/packages/patches/apr-skip-getservbyname-test.patch \
|
||||||
%D%/packages/patches/aria2-CVE-2019-3500.patch \
|
%D%/packages/patches/aria2-CVE-2019-3500.patch \
|
||||||
%D%/packages/patches/aspell-default-dict-dir.patch \
|
%D%/packages/patches/aspell-default-dict-dir.patch \
|
||||||
|
%D%/packages/patches/aspell-gcc-compat.patch \
|
||||||
%D%/packages/patches/ath9k-htc-firmware-binutils.patch \
|
%D%/packages/patches/ath9k-htc-firmware-binutils.patch \
|
||||||
%D%/packages/patches/ath9k-htc-firmware-gcc.patch \
|
%D%/packages/patches/ath9k-htc-firmware-gcc.patch \
|
||||||
%D%/packages/patches/ath9k-htc-firmware-objcopy.patch \
|
%D%/packages/patches/ath9k-htc-firmware-objcopy.patch \
|
||||||
|
|
|
@ -45,7 +45,8 @@ (define-public aspell
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm"))
|
"1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm"))
|
||||||
(patches (search-patches "aspell-default-dict-dir.patch"))))
|
(patches (search-patches "aspell-default-dict-dir.patch"
|
||||||
|
"aspell-gcc-compat.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:phases
|
`(#:phases
|
||||||
|
|
31
gnu/packages/patches/aspell-gcc-compat.patch
Normal file
31
gnu/packages/patches/aspell-gcc-compat.patch
Normal file
|
@ -0,0 +1,31 @@
|
||||||
|
Fix GCC7 warnings.
|
||||||
|
|
||||||
|
Taken from upstream:
|
||||||
|
https://git.savannah.gnu.org/cgit/aspell.git/commit/?id=8089fa02122fed0a6394eba14bbedcb1d18e2384
|
||||||
|
|
||||||
|
diff --git a/modules/filter/tex.cpp b/modules/filter/tex.cpp
|
||||||
|
index a979539..19ab63c 100644
|
||||||
|
--- a/modules/filter/tex.cpp
|
||||||
|
+++ b/modules/filter/tex.cpp
|
||||||
|
@@ -174,7 +174,7 @@ namespace {
|
||||||
|
|
||||||
|
if (c == '{') {
|
||||||
|
|
||||||
|
- if (top.in_what == Parm || top.in_what == Opt || top.do_check == '\0')
|
||||||
|
+ if (top.in_what == Parm || top.in_what == Opt || *top.do_check == '\0')
|
||||||
|
push_command(Parm);
|
||||||
|
|
||||||
|
top.in_what = Parm;
|
||||||
|
diff --git a/prog/check_funs.cpp b/prog/check_funs.cpp
|
||||||
|
index db54f3d..89ee09d 100644
|
||||||
|
--- a/prog/check_funs.cpp
|
||||||
|
+++ b/prog/check_funs.cpp
|
||||||
|
@@ -647,7 +647,7 @@ static void print_truncate(FILE * out, const char * word, int width) {
|
||||||
|
}
|
||||||
|
}
|
||||||
|
if (i == width-1) {
|
||||||
|
- if (word == '\0')
|
||||||
|
+ if (*word == '\0')
|
||||||
|
put(out,' ');
|
||||||
|
else if (word[len] == '\0')
|
||||||
|
put(out, word, len);
|
Loading…
Reference in a new issue