mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: emacs-unpackaged-el: Add patch for missing require statement.
* gnu/packages/emacs-xyz.scm (emacs-unpackaged-el)[source]: Add patch. * gnu/packages/patches/emacs-unpackaged-req.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
a7a3182761
commit
8785a71faf
3 changed files with 29 additions and 1 deletions
|
@ -765,6 +765,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
|
||||
%D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch \
|
||||
%D%/packages/patches/emacs-source-date-epoch.patch \
|
||||
%D%/packages/patches/emacs-unpackaged-req.patch \
|
||||
%D%/packages/patches/emacs-undohist-ignored.patch \
|
||||
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
|
||||
%D%/packages/patches/emacs-zones-called-interactively.patch \
|
||||
|
|
|
@ -591,12 +591,15 @@ (define-public emacs-unpackaged-el
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"1yf3zrgqfhnr0az8gn1kqqwnhfi3nc0vbjkcagwcqwk3sp1jda86"))))
|
||||
"1yf3zrgqfhnr0az8gn1kqqwnhfi3nc0vbjkcagwcqwk3sp1jda86"))
|
||||
(patches
|
||||
(search-patches "emacs-unpackaged-req.patch"))))
|
||||
(build-system emacs-build-system)
|
||||
(propagated-inputs
|
||||
`(("emacs-dash" ,emacs-dash)
|
||||
("emacs-org" ,emacs-org)
|
||||
("emacs-s" ,emacs-s)
|
||||
("emacs-hydra" ,emacs-hydra)
|
||||
("emacs-use-package" ,emacs-use-package)))
|
||||
(home-page "https://github.com/alphapapa/unpackaged.el")
|
||||
(synopsis "Useful snippets of Emacs Lisp code")
|
||||
|
|
24
gnu/packages/patches/emacs-unpackaged-req.patch
Normal file
24
gnu/packages/patches/emacs-unpackaged-req.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
From e5be173e201710538464c279335bef735a327a68 Mon Sep 17 00:00:00 2001
|
||||
From: Brian Leung <bkleung89@gmail.com>
|
||||
Date: Tue, 18 Jun 2019 06:37:46 +0200
|
||||
Subject: [PATCH] Add missing require.
|
||||
|
||||
---
|
||||
unpackaged.el | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/unpackaged.el b/unpackaged.el
|
||||
index 2d46b3c..e62184a 100644
|
||||
--- a/unpackaged.el
|
||||
+++ b/unpackaged.el
|
||||
@@ -38,6 +38,7 @@
|
||||
(require 'dash)
|
||||
(require 's)
|
||||
(require 'use-package)
|
||||
+(require 'hydra)
|
||||
|
||||
;;; Faces, fonts
|
||||
|
||||
--
|
||||
2.22.0
|
||||
|
Loading…
Reference in a new issue