mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: Add agg.
* gnu/packages/graphics.scm (agg): New variable. * gnu/packages/patches/agg-am_c_prototype.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
This commit is contained in:
parent
ca0d2a637b
commit
87bafa07ae
3 changed files with 62 additions and 1 deletions
|
@ -359,6 +359,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/aegis-perl-tempdir2.patch \
|
||||
gnu/packages/patches/aegis-test-fixup-1.patch \
|
||||
gnu/packages/patches/aegis-test-fixup-2.patch \
|
||||
gnu/packages/patches/agg-am_c_prototype.patch \
|
||||
gnu/packages/patches/alsa-lib-mips-atomic-fix.patch \
|
||||
gnu/packages/patches/apr-skip-getservbyname-test.patch \
|
||||
gnu/packages/patches/ath9k-htc-firmware-binutils.patch \
|
||||
|
|
|
@ -24,12 +24,18 @@ (define-module (gnu packages graphics)
|
|||
#:use-module (guix build-system cmake)
|
||||
#:use-module ((guix licenses) #:prefix license:)
|
||||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages autotools)
|
||||
#:use-module (gnu packages bash)
|
||||
#:use-module (gnu packages boost)
|
||||
#:use-module (gnu packages fontutils)
|
||||
#:use-module (gnu packages pkg-config)
|
||||
#:use-module (gnu packages compression)
|
||||
#:use-module (gnu packages multiprecision)
|
||||
#:use-module (gnu packages boost)
|
||||
#:use-module (gnu packages gl)
|
||||
#:use-module (gnu packages qt))
|
||||
#:use-module (gnu packages qt)
|
||||
#:use-module (gnu packages sdl)
|
||||
#:use-module (gnu packages xorg))
|
||||
|
||||
(define-public cgal
|
||||
(package
|
||||
|
@ -217,3 +223,47 @@ (define-public brdf-explorer
|
|||
real time as parameters are changed, making it a useful tool for evaluating
|
||||
and understanding different BRDFs (and other component functions).")
|
||||
(license license:ms-pl)))
|
||||
|
||||
(define-public agg
|
||||
(package
|
||||
(name "agg")
|
||||
(version "2.5")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://www.antigrain.com/agg-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32 "07wii4i824vy9qsvjsgqxppgqmfdxq0xa87i5yk53fijriadq7mb"))
|
||||
(patches (list (search-patch "agg-am_c_prototype.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:configure-flags
|
||||
(list (string-append "--x-includes=" (assoc-ref %build-inputs "libx11")
|
||||
"/include")
|
||||
(string-append "--x-libraries=" (assoc-ref %build-inputs "libx11")
|
||||
"/lib"))
|
||||
#:phases
|
||||
(alist-cons-after
|
||||
'unpack 'autoreconf
|
||||
(lambda _
|
||||
;; let's call configure from configure phase and not now
|
||||
(substitute* "autogen.sh" (("./configure") "# ./configure"))
|
||||
(zero? (system* "sh" "autogen.sh")))
|
||||
%standard-phases)))
|
||||
(native-inputs
|
||||
`(("pkg-config" ,pkg-config)
|
||||
("libtool" ,libtool)
|
||||
("autoconf" ,autoconf)
|
||||
("automake" ,automake)
|
||||
("bash" ,bash)))
|
||||
(inputs
|
||||
`(("libx11" ,libx11)
|
||||
("freetype" ,freetype)
|
||||
("sdl" ,sdl)))
|
||||
(home-page "http://antigrain.com")
|
||||
(synopsis "High-quality 2D graphics rendering engine for C++")
|
||||
(description
|
||||
"Anti-Grain Geometry is a high quality rendering engine written in C++.
|
||||
It supports sub-pixel resolutions and anti-aliasing. It is also library for
|
||||
rendering SVG graphics.")
|
||||
(license license:gpl2+)))
|
||||
|
|
10
gnu/packages/patches/agg-am_c_prototype.patch
Normal file
10
gnu/packages/patches/agg-am_c_prototype.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- a/configure.in 2015-03-15 18:59:12.557417149 +0100
|
||||
+++ b/configure.in 2015-03-15 18:59:29.273416518 +0100
|
||||
@@ -8,7 +8,6 @@
|
||||
AC_PROG_CC
|
||||
AC_PROG_CXX
|
||||
AC_ISC_POSIX
|
||||
-AM_C_PROTOTYPES
|
||||
if test "x$U" != "x"; then
|
||||
AC_MSG_ERROR(Compiler not ANSI compliant)
|
||||
fi
|
Loading…
Reference in a new issue