mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-28 07:12:30 -05:00
gnu: emacs-exwm: Remove obsolete patch.
* gnu/packages/patches/emacs-exwm-fix-fullscreen-states.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/emacs-xyz.scm (emacs-exwm)[source]: Remove patch.
This commit is contained in:
parent
8d02b0d46c
commit
87e57cbecb
3 changed files with 1 additions and 46 deletions
|
@ -1024,7 +1024,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/elm-compiler-disable-reactor.patch \
|
%D%/packages/patches/elm-compiler-disable-reactor.patch \
|
||||||
%D%/packages/patches/elm-compiler-fix-map-key.patch \
|
%D%/packages/patches/elm-compiler-fix-map-key.patch \
|
||||||
%D%/packages/patches/emacs-exec-path.patch \
|
%D%/packages/patches/emacs-exec-path.patch \
|
||||||
%D%/packages/patches/emacs-exwm-fix-fullscreen-states.patch \
|
|
||||||
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
|
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
|
||||||
%D%/packages/patches/emacs-ignore-empty-xim-styles.patch \
|
%D%/packages/patches/emacs-ignore-empty-xim-styles.patch \
|
||||||
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
|
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
|
||||||
|
|
|
@ -14064,12 +14064,7 @@ (define-public emacs-exwm
|
||||||
(uri (string-append "https://elpa.gnu.org/packages/"
|
(uri (string-append "https://elpa.gnu.org/packages/"
|
||||||
"exwm-" version ".tar"))
|
"exwm-" version ".tar"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0imd4v9ccvpsskmfnycz5fgabsvdjp1msg5v8rc7x0v26r3kr4x7"))
|
(base32 "0imd4v9ccvpsskmfnycz5fgabsvdjp1msg5v8rc7x0v26r3kr4x7"))))
|
||||||
(patches
|
|
||||||
;; Patch fixing fullscreen view. Applied upstream as
|
|
||||||
;; edb930005b0ba83051ca8a59b493e9a3c8ef580a. It can be removed in
|
|
||||||
;; next release.
|
|
||||||
(search-patches "emacs-exwm-fix-fullscreen-states.patch"))))
|
|
||||||
(build-system emacs-build-system)
|
(build-system emacs-build-system)
|
||||||
(propagated-inputs
|
(propagated-inputs
|
||||||
`(("emacs-xelb" ,emacs-xelb)))
|
`(("emacs-xelb" ,emacs-xelb)))
|
||||||
|
|
|
@ -1,39 +0,0 @@
|
||||||
From edb930005b0ba83051ca8a59b493e9a3c8ef580a Mon Sep 17 00:00:00 2001
|
|
||||||
From: Chris Feng <chris.w.feng@gmail.com>
|
|
||||||
Date: Sun, 14 Jun 2020 00:00:00 +0000
|
|
||||||
Subject: [PATCH] Fix fullscreen states
|
|
||||||
|
|
||||||
* exwm-layout.el (exwm-layout-set-fullscreen,
|
|
||||||
exwm-layout-unset-fullscreen): Use `exwm--id' for interactive use.
|
|
||||||
(exwm-layout-unset-fullscreen): Mandatorily clear fullscreen states.
|
|
||||||
---
|
|
||||||
exwm-layout.el | 6 ++++--
|
|
||||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/exwm-layout.el b/exwm-layout.el
|
|
||||||
index 170c2be..79d0c95 100644
|
|
||||||
--- a/exwm-layout.el
|
|
||||||
+++ b/exwm-layout.el
|
|
||||||
@@ -205,7 +205,7 @@
|
|
||||||
:border-width 0
|
|
||||||
:stack-mode xcb:StackMode:Above))
|
|
||||||
(cl-pushnew xcb:Atom:_NET_WM_STATE_FULLSCREEN exwm--ewmh-state)
|
|
||||||
- (exwm-layout--set-ewmh-state id)
|
|
||||||
+ (exwm-layout--set-ewmh-state exwm--id)
|
|
||||||
(xcb:flush exwm--connection)
|
|
||||||
(set-window-dedicated-p (get-buffer-window) t)
|
|
||||||
(exwm-input--release-keyboard exwm--id)))
|
|
||||||
@@ -233,7 +233,9 @@
|
|
||||||
(let ((window (get-buffer-window nil t)))
|
|
||||||
(when window
|
|
||||||
(exwm-layout--show exwm--id window))))
|
|
||||||
- (exwm-layout--set-ewmh-state id)
|
|
||||||
+ (setq exwm--ewmh-state
|
|
||||||
+ (delq xcb:Atom:_NET_WM_STATE_FULLSCREEN exwm--ewmh-state))
|
|
||||||
+ (exwm-layout--set-ewmh-state exwm--id)
|
|
||||||
(xcb:flush exwm--connection)
|
|
||||||
(set-window-dedicated-p (get-buffer-window) nil)
|
|
||||||
(when (eq 'line-mode exwm--selected-input-mode)
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
Loading…
Reference in a new issue