mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-24 11:39:46 -05:00
gnu: Add go-github-com-mattbaird-jsonpatch.
* gnu/packages/golang-web.scm (go-github-com-mattbaird-jsonpatch): New variable. Change-Id: I571c51f2141dbba53067f4279003a4604f21b1a4 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
This commit is contained in:
parent
1c69f719af
commit
88c4c0fd69
1 changed files with 32 additions and 0 deletions
|
@ -2271,6 +2271,38 @@ (define-public go-github-com-makeworld-the-better-one-go-gemini-socks5
|
||||||
@@url{https://github.com/makeworld-the-better-one/go-gemini,go-gemini}.")
|
@@url{https://github.com/makeworld-the-better-one/go-gemini,go-gemini}.")
|
||||||
(license license:expat)))
|
(license license:expat)))
|
||||||
|
|
||||||
|
(define-public go-github-com-mattbaird-jsonpatch
|
||||||
|
(package
|
||||||
|
(name "go-github-com-mattbaird-jsonpatch")
|
||||||
|
(version "0.0.0-20240118010651-0ba75a80ca38")
|
||||||
|
(source
|
||||||
|
(origin
|
||||||
|
(method git-fetch)
|
||||||
|
(uri (git-reference
|
||||||
|
(url "https://github.com/mattbaird/jsonpatch")
|
||||||
|
(commit (go-version->git-ref version))))
|
||||||
|
(file-name (git-file-name name version))
|
||||||
|
(sha256
|
||||||
|
(base32 "1nxbrpk8bvvmfgl4sfsbx82g0q44i2sakl7vigbsj3prx6nql5iv"))))
|
||||||
|
(build-system go-build-system)
|
||||||
|
(arguments
|
||||||
|
(list
|
||||||
|
#:import-path "github.com/mattbaird/jsonpatch"))
|
||||||
|
(native-inputs
|
||||||
|
(list go-github-com-evanphx-json-patch go-github-com-stretchr-testify))
|
||||||
|
(home-page "https://github.com/mattbaird/jsonpatch")
|
||||||
|
(synopsis "JSON Patch library for Go")
|
||||||
|
(description
|
||||||
|
"@url{http://jsonpatch.com/, JSON Patch} implementation for Go as
|
||||||
|
specified in @url{https://datatracker.ietf.org/doc/html/rfc6902/, RFC 6902}
|
||||||
|
from the IETF.
|
||||||
|
|
||||||
|
JSON Patch allows you to generate JSON that describes changes you want to make
|
||||||
|
to a document, so you don't have to send the whole doc. JSON Patch format is
|
||||||
|
supported by HTTP PATCH method, allowing for standards based partial updates
|
||||||
|
via REST APIs.")
|
||||||
|
(license license:asl2.0)))
|
||||||
|
|
||||||
(define-public go-github-com-microcosm-cc-bluemonday
|
(define-public go-github-com-microcosm-cc-bluemonday
|
||||||
(package
|
(package
|
||||||
(name "go-github-com-microcosm-cc-bluemonday")
|
(name "go-github-com-microcosm-cc-bluemonday")
|
||||||
|
|
Loading…
Reference in a new issue