mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: xorg-server: Update to 1.20.1.
* gnu/packages/patches/xorg-server-rotate-fb.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/xorg.scm (xorg-server): Update to 1.20.1. [source](patches): Remove 'xorg-server-rotate-fb.patch'.
This commit is contained in:
parent
f71561567b
commit
88c54b1b75
3 changed files with 3 additions and 40 deletions
|
@ -1238,7 +1238,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/xinetd-fix-fd-leak.patch \
|
||||
%D%/packages/patches/xinetd-CVE-2013-4342.patch \
|
||||
%D%/packages/patches/xmodmap-asprintf.patch \
|
||||
%D%/packages/patches/xorg-server-rotate-fb.patch \
|
||||
%D%/packages/patches/zathura-pdf-mupdf-link-to-jpeg-libraries.patch \
|
||||
%D%/packages/patches/zathura-plugindir-environment-variable.patch \
|
||||
%D%/packages/patches/zstd-fix-stdin-list-without-tty.patch \
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
commit a85e94a50c94b07574c8701a3ff3c1243f4257f4
|
||||
Author: Olivier Fourdan <ofourdan@redhat.com>
|
||||
Date: Fri Jun 15 08:57:12 2018 +0200
|
||||
|
||||
modesetting: use drmmode_bo_import() for rotate_fb
|
||||
|
||||
drmmode_shadow_allocate() still uses drmModeAddFB() which may fail if
|
||||
the format is not as expected, preventing from using a rotated output.
|
||||
|
||||
Change it to use the new function drmmode_bo_import() which takes care
|
||||
of calling the drmModeAddFB2() API.
|
||||
|
||||
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=106715
|
||||
Signed-off-by: Olivier Fourdan <ofourdan@redhat.com>
|
||||
Tested-by: Tomas Pelka <tpelka@redhat.com>
|
||||
Reviewed-by: Lyude Paul <lyude@redhat.com>
|
||||
|
||||
diff --git a/hw/xfree86/drivers/modesetting/drmmode_display.c b/hw/xfree86/drivers/modesetting/drmmode_display.c
|
||||
index 859a21a9d..ec11b3f56 100644
|
||||
--- a/hw/xfree86/drivers/modesetting/drmmode_display.c
|
||||
+++ b/hw/xfree86/drivers/modesetting/drmmode_display.c
|
||||
@@ -1794,11 +1794,8 @@ drmmode_shadow_allocate(xf86CrtcPtr crtc, int width, int height)
|
||||
return NULL;
|
||||
}
|
||||
|
||||
- ret = drmModeAddFB(drmmode->fd, width, height, crtc->scrn->depth,
|
||||
- drmmode->kbpp,
|
||||
- drmmode_bo_get_pitch(&drmmode_crtc->rotate_bo),
|
||||
- drmmode_bo_get_handle(&drmmode_crtc->rotate_bo),
|
||||
- &drmmode_crtc->rotate_fb_id);
|
||||
+ ret = drmmode_bo_import(drmmode, &drmmode_crtc->rotate_bo,
|
||||
+ &drmmode_crtc->rotate_fb_id);
|
||||
|
||||
if (ret) {
|
||||
ErrorF("failed to add rotate fb\n");
|
|
@ -5070,7 +5070,7 @@ (define-public libxcb
|
|||
(define-public xorg-server
|
||||
(package
|
||||
(name "xorg-server")
|
||||
(version "1.20.0")
|
||||
(version "1.20.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -5079,7 +5079,7 @@ (define-public xorg-server
|
|||
name "-" version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1rnka3sp8yg2bir0bjjhwn33jikj8qd8ckqcxrs94w05bwc7v5lx"))
|
||||
"0679942x1ma2p30vlvqylpjc5v1ak1pgqysnqrj82nz7dzl9zjar"))
|
||||
(patches
|
||||
(list
|
||||
;; See:
|
||||
|
@ -5093,8 +5093,7 @@ (define-public xorg-server
|
|||
(sha256
|
||||
(base32
|
||||
"0mm70y058r8s9y9jiv7q2myv0ycnaw3iqzm7d274410s0ik38w7q"))
|
||||
(file-name "xorg-server-use-intel-only-on-pre-gen4.diff"))
|
||||
(search-patch "xorg-server-rotate-fb.patch")))))
|
||||
(file-name "xorg-server-use-intel-only-on-pre-gen4.diff"))))))
|
||||
(build-system gnu-build-system)
|
||||
(propagated-inputs
|
||||
`(("libpciaccess" ,libpciaccess)
|
||||
|
|
Loading…
Reference in a new issue