gnu: gash-utils: Update to 0.2.0.

* gnu/packages/patches/gash-utils-ls-test.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/shells.scm (gash-utils): Update to 0.2.0.
[source]: Remove patch and Guile 3.0 snippet.
* gnu/packages/commencement.scm (gash-utils-boot)[source]: Do not
modify parent value.
[arguments]: Add "env" to the list of scripts to create in the
'pre-configure' phase; add the "gash-utils" module directory in the
'configure', 'build', and 'install' phases.
This commit is contained in:
Timothy Sample 2021-02-06 21:13:52 -05:00
parent 0db2a6e749
commit 892aac72a2
No known key found for this signature in database
GPG key ID: 2AC6A5EC1C357C59
4 changed files with 9 additions and 47 deletions

View file

@ -1077,7 +1077,6 @@ dist_patch_DATA = \
%D%/packages/patches/ganeti-shepherd-master-failover.patch \
%D%/packages/patches/ganeti-shepherd-support.patch \
%D%/packages/patches/ganeti-sphinx-compat.patch \
%D%/packages/patches/gash-utils-ls-test.patch \
%D%/packages/patches/gawk-shell.patch \
%D%/packages/patches/gcc-arm-bug-71399.patch \
%D%/packages/patches/gcc-arm-link-spec-fix.patch \

View file

@ -175,10 +175,6 @@ (define gash-utils-boot
(package
(inherit gash-utils)
(name "gash-utils-boot")
(source (origin
(inherit (package-source gash-utils))
(patches '())
(snippet #f))) ;discard snippet for Guile 3.0 support
(arguments
`(#:implicit-inputs? #f
#:tests? #f
@ -210,9 +206,9 @@ (define gash-utils-boot
(substitute* target
(("@UTILITY@") script))))
'("awk" "basename" "cat" "chmod" "cmp" "command"
"compress" "cp" "cut" "diff" "dirname" "expr"
"false" "find" "grep" "head" "ln" "ls" "mkdir"
"mv" "printf" "pwd" "reboot" "rm" "rmdir"
"compress" "cp" "cut" "diff" "dirname" "env"
"expr" "false" "find" "grep" "head" "ln" "ls"
"mkdir" "mv" "printf" "pwd" "reboot" "rm" "rmdir"
"sed" "sleep" "sort" "tar" "test" "touch" "tr"
"true" "uname" "uniq" "wc" "which"))
(format #t "Creating scripts/[.in~%")
@ -222,9 +218,10 @@ (define gash-utils-boot
(delete-file "scripts/template.in")))
(replace 'configure
(bootstrap-configure "Gash-Utils" ,(package-version gash-utils)
'("gash") "scripts"))
(replace 'build (bootstrap-build '("gash")))
(replace 'install (bootstrap-install '("gash") "scripts"))
'("gash" "gash-utils") "scripts"))
(replace 'build (bootstrap-build '("gash" "gash-utils")))
(replace 'install
(bootstrap-install '("gash" "gash-utils") "scripts"))
;; XXX: The scripts should add Gash to their load paths and
;; this phase should not exist.
(add-after 'install 'copy-gash

View file

@ -1,25 +0,0 @@
'ls.scm' monkey-patches (ice-9 getopt-long) to allow it to recognize '-1'
as a valid option. Unfortunately, monkey patching no longer works with
Guile 3.0 due to inlining, so change the test to make do without '-1'.
diff --git a/tests/core-utils.org b/tests/core-utils.org
index d35ede8..22718e3 100644
--- a/tests/core-utils.org
+++ b/tests/core-utils.org
@@ -93,14 +93,11 @@
* ls
:script:
#+begin_src sh
- ls -1 tests/data/star
+ ls tests/data/star
#+end_src
:stdout:
#+begin_example
- 0
- 1
- 2
- 3
+ 0 1 2 3
#+end_example
* test-file

View file

@ -904,23 +904,14 @@ (define-public gash
(define-public gash-utils
(package
(name "gash-utils")
(version "0.1.0")
(version "0.2.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/gash/gash-utils-"
version ".tar.gz"))
(sha256
(base32
"0ib2p52qmbac5n0s5bys4fiwim461ps546976l1n7pwbs0avh7fk"))
(patches (search-patches "gash-utils-ls-test.patch"))
(modules '((guix build utils)))
(snippet
'(begin
;; Allow builds with Guile 3.0.
(substitute* "configure"
(("search=\"2\\.2 2\\.0\"")
"search=\"3.0 2.2 2.0\""))
#t))))
"18ylb54l9lmaynapbncc1zhbsirhihznrxihhxgqrpqgyjkfbap6"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config))