mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: gcc@4.8: Fix libsanitizer cross-compilation.
This patch is modified from the original patch targeting gcc@5. * gnu/packages/patches/gcc-asan-missing-include.patch: New file. * gnu/packages/gcc.scm (gcc@4.8)[source](patches): Add it. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
7bbc708a4e
commit
8e7ec29df4
3 changed files with 22 additions and 0 deletions
|
@ -647,6 +647,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gawk-shell.patch \
|
||||
%D%/packages/patches/gcc-arm-bug-71399.patch \
|
||||
%D%/packages/patches/gcc-arm-link-spec-fix.patch \
|
||||
%D%/packages/patches/gcc-asan-missing-include.patch \
|
||||
%D%/packages/patches/gcc-cross-environment-variables.patch \
|
||||
%D%/packages/patches/gcc-fix-texi2pod.patch \
|
||||
%D%/packages/patches/gcc-libvtv-runpath.patch \
|
||||
|
|
|
@ -363,6 +363,7 @@ (define-public gcc-4.8
|
|||
(base32
|
||||
"08yggr18v373a1ihj0rg2vd6psnic42b518xcgp3r9k81xz1xyr2"))
|
||||
(patches (search-patches "gcc-arm-link-spec-fix.patch"
|
||||
"gcc-asan-missing-include.patch"
|
||||
"gcc-fix-texi2pod.patch"))
|
||||
(modules '((guix build utils)))
|
||||
;; This is required for building with glibc-2.26.
|
||||
|
|
20
gnu/packages/patches/gcc-asan-missing-include.patch
Normal file
20
gnu/packages/patches/gcc-asan-missing-include.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
Add missing include that triggers a build failure on PowerPC:
|
||||
|
||||
../../../../gcc-5.4.0/libsanitizer/asan/asan_linux.cc: In function ‘bool __asan::AsanInterceptsSignal(int)’:
|
||||
../../../../gcc-5.4.0/libsanitizer/asan/asan_linux.cc:222:20: error: ‘SIGSEGV’ was not declared in this scope
|
||||
return signum == SIGSEGV && common_flags()->handle_segv;
|
||||
^
|
||||
From <https://patchwork.ozlabs.org/patch/725596/>.
|
||||
|
||||
diff --git a/libsanitizer/asan/asan_linux.cc b/libsanitizer/asan/asan_linux.cc
|
||||
index c504168..59087b9 100644
|
||||
--- a/libsanitizer/asan/asan_linux.cc
|
||||
+++ b/libsanitizer/asan/asan_linux.cc
|
||||
@@ -29,6 +29,7 @@
|
||||
#include <dlfcn.h>
|
||||
#include <fcntl.h>
|
||||
#include <pthread.h>
|
||||
+#include <signal.h>
|
||||
#include <stdio.h>
|
||||
#include <unistd.h>
|
||||
#include <unwind.h>
|
Loading…
Reference in a new issue