mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-28 07:12:30 -05:00
gnu: gst-plugins-base: Update to 1.19.2.
* gnu/packages/gstreamer.scm (gst-plugins-base): Update to 1.19.2 [origin]: Delete patches field. Remove trailing #t. [meson]: Use meson-0.55. * gnu/packages/patches/gst-plugins-base-fix-id3v2-invalid-read.patch: Delete. * gnu/local.mk (dist_patch_DATA): De-register.
This commit is contained in:
parent
9b6dfe664e
commit
8f22b547ef
3 changed files with 6 additions and 49 deletions
|
@ -1218,7 +1218,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gspell-dash-test.patch \
|
||||
%D%/packages/patches/gst-libav-64channels-stack-corruption.patch \
|
||||
%D%/packages/patches/gst-plugins-bad-fix-overflow.patch \
|
||||
%D%/packages/patches/gst-plugins-base-fix-id3v2-invalid-read.patch \
|
||||
%D%/packages/patches/gst-plugins-good-fix-test.patch \
|
||||
%D%/packages/patches/gst-plugins-good-CVE-2021-3497.patch \
|
||||
%D%/packages/patches/gst-plugins-good-CVE-2021-3498.patch \
|
||||
|
|
|
@ -532,16 +532,15 @@ (define-public gstreamer
|
|||
(define-public gst-plugins-base
|
||||
(package
|
||||
(name "gst-plugins-base")
|
||||
(version "1.18.4")
|
||||
(version "1.19.2")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://gstreamer.freedesktop.org/src/" name "/"
|
||||
name "-" version ".tar.xz"))
|
||||
(patches (search-patches "gst-plugins-base-fix-id3v2-invalid-read.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"08w3ivbc6n4vdds2ap6q7l8zdk9if8417nznyqidf0adm0lk5r99"))))
|
||||
"04x5666vgg89dd9psxmnr99dszk8ykkc9dclg2ln2sq07kyh9qyd"))))
|
||||
(build-system meson-build-system)
|
||||
(propagated-inputs
|
||||
`(("glib" ,glib) ;required by gstreamer-sdp-1.0.pc
|
||||
|
@ -584,14 +583,14 @@ (define-public gst-plugins-base
|
|||
("gettext" ,gettext-minimal)
|
||||
("xorg-server" ,xorg-server-for-tests)))
|
||||
(arguments
|
||||
`(#:phases
|
||||
`(#:meson ,meson-0.55
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
,@%common-gstreamer-phases
|
||||
(add-before 'configure 'patch
|
||||
(lambda _
|
||||
(substitute* "tests/check/libs/pbutils.c"
|
||||
(("/bin/sh") (which "sh")))
|
||||
#t))
|
||||
(("/bin/sh") (which "sh")))))
|
||||
(add-before 'check 'pre-check
|
||||
(lambda _
|
||||
;; Tests require a running X server.
|
||||
|
@ -602,8 +601,7 @@ (define-public gst-plugins-base
|
|||
;; Tests look for $XDG_RUNTIME_DIR.
|
||||
(setenv "XDG_RUNTIME_DIR" (getcwd))
|
||||
;; For missing '/etc/machine-id'.
|
||||
(setenv "DBUS_FATAL_WARNINGS" "0")
|
||||
#t)))))
|
||||
(setenv "DBUS_FATAL_WARNINGS" "0"))))))
|
||||
(home-page "https://gstreamer.freedesktop.org/")
|
||||
(synopsis
|
||||
"Plugins for the GStreamer multimedia library")
|
||||
|
|
|
@ -1,40 +0,0 @@
|
|||
Fix an "invalid read during ID3v2 tag parsing".
|
||||
|
||||
https://security-tracker.debian.org/tracker/TEMP-0000000-57E7C1
|
||||
https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/issues/876
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/commit/f4a1428a6997658625d529b9db60fde812fbf1ee
|
||||
|
||||
From f4a1428a6997658625d529b9db60fde812fbf1ee Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim@centricular.com>
|
||||
Date: Wed, 3 Mar 2021 01:08:25 +0000
|
||||
Subject: [PATCH] tag: id3v2: fix frame size check and potential invalid reads
|
||||
|
||||
Check the right variable when checking if there's
|
||||
enough data left to read the frame size.
|
||||
|
||||
Closes https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/issues/876
|
||||
|
||||
Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/merge_requests/1065>
|
||||
---
|
||||
gst-libs/gst/tag/id3v2frames.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gst-libs/gst/tag/id3v2frames.c b/gst-libs/gst/tag/id3v2frames.c
|
||||
index 8e9f78254..f39659bf7 100644
|
||||
--- a/gst-libs/gst/tag/id3v2frames.c
|
||||
+++ b/gst-libs/gst/tag/id3v2frames.c
|
||||
@@ -109,7 +109,7 @@ id3v2_parse_frame (ID3TagsWorking * work)
|
||||
|
||||
if (work->frame_flags & (ID3V2_FRAME_FORMAT_COMPRESSION |
|
||||
ID3V2_FRAME_FORMAT_DATA_LENGTH_INDICATOR)) {
|
||||
- if (work->hdr.frame_data_size <= 4)
|
||||
+ if (frame_data_size <= 4)
|
||||
return FALSE;
|
||||
if (ID3V2_VER_MAJOR (work->hdr.version) == 3) {
|
||||
work->parse_size = GST_READ_UINT32_BE (frame_data);
|
||||
--
|
||||
2.31.1
|
||||
|
Loading…
Reference in a new issue