mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-14 07:00:32 -05:00
gnu: mesa: Update to 19.2.7.
* gnu/packages/patches/mesa-timespec-test-32bit.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gl.scm (mesa): Update to 19.2.7. [source](patches): Remove obsolete.
This commit is contained in:
parent
8d9d6adbab
commit
91304b7945
3 changed files with 3 additions and 22 deletions
|
@ -1136,7 +1136,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \
|
||||
%D%/packages/patches/mes-remove-store-name.patch \
|
||||
%D%/packages/patches/mesa-skip-disk-cache-test.patch \
|
||||
%D%/packages/patches/mesa-timespec-test-32bit.patch \
|
||||
%D%/packages/patches/mescc-tools-boot.patch \
|
||||
%D%/packages/patches/meson-for-build-rpath.patch \
|
||||
%D%/packages/patches/metabat-fix-compilation.patch \
|
||||
|
|
|
@ -229,7 +229,7 @@ (define libva-without-mesa
|
|||
(define-public mesa
|
||||
(package
|
||||
(name "mesa")
|
||||
(version "19.2.1")
|
||||
(version "19.2.7")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -241,10 +241,9 @@ (define-public mesa
|
|||
version "/mesa-" version ".tar.xz")))
|
||||
(sha256
|
||||
(base32
|
||||
"1s81kwcjkkahnf5y5mshmd3q9j057hhsai7awpq6yb6im2hkriac"))
|
||||
"17jp8ghipgz62vqqz5llskxypkcmgf8gnlgnj0pyvnbgi6vryyg3"))
|
||||
(patches
|
||||
(search-patches "mesa-skip-disk-cache-test.patch"
|
||||
"mesa-timespec-test-32bit.patch"))))
|
||||
(search-patches "mesa-skip-disk-cache-test.patch"))))
|
||||
(build-system meson-build-system)
|
||||
(propagated-inputs
|
||||
`(;; The following are in the Requires.private field of gl.pc.
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
Fix a test failure on 32-bit systems.
|
||||
|
||||
Taken from upstream:
|
||||
https://gitlab.freedesktop.org/mesa/mesa/commit/dd1dba80b9ee74ec8b90761285a8262e374bf8ef
|
||||
|
||||
diff --git a/src/util/tests/timespec/timespec_test.cpp b/src/util/tests/timespec/timespec_test.cpp
|
||||
--- a/src/util/tests/timespec/timespec_test.cpp
|
||||
+++ b/src/util/tests/timespec/timespec_test.cpp
|
||||
@@ -206,7 +206,7 @@ TEST(timespec_test, timespec_from_nsec)
|
||||
|
||||
timespec_from_nsec(&a, UINT64_MAX);
|
||||
EXPECT_EQ(a.tv_nsec, UINT64_MAX % NSEC_PER_SEC);
|
||||
- EXPECT_EQ(a.tv_sec, UINT64_MAX / NSEC_PER_SEC);
|
||||
+ EXPECT_EQ(a.tv_sec, (time_t)(UINT64_MAX / NSEC_PER_SEC));
|
||||
}
|
||||
|
||||
TEST(timespec_test, timespec_from_usec)
|
Loading…
Reference in a new issue